<!DOCTYPE html>
<html>
<head>
<link rel="stylesheet" href="https://use.typekit.net/cdb4vyt.css">
<meta name="viewport" content="width=device-width, initial-scale=1">

<script type="text/javascript">
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function(){
       var gads = document.createElement("script");
        gads.async = true;
        gads.type = "text/javascript";
        var useSSL = "https:" == document.location.protocol;
        gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
        var node = document.getElementsByTagName("script")[0];
        node.parentNode.insertBefore(gads, node);
    })();
</script>

<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.2634970.min.js?cachebuster=1';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      // Return control to GPT if the AdBridg library fails to load.
      adb.onerror = function() {
        console.log('Fallback: ')
        if (AdBridg.exists) { return; }
        document.createElement('IMG').src = '//adspsp.com/pt/2634970/3/1/?e=0';
        var dq = [], es;
        dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
        AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
        AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
        AdBridg.destroySlots = function(s) { return googletag.destroySlots(s); }
        AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
        AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
        AdBridg.render = function() { }
        AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
        AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
        AdBridg.useSizeMapping = function() { }
        AdBridg.cmd.push = function(f) {
          if (typeof(f)=='object') {
            var api_fallback = function(o) {
              googletag.cmd.push(function() {
                var u=AdBridg.defineSlot(o.gpt_path,o.size||[],o.dom_id);
                if(o.size_map) {
                  var m = googletag.sizeMapping();
                  for(var oi=0;oi<o.size_map.length;oi++){m=m.addSize(o.size_map[oi].viewport, o.size_map[oi].sizes);}
                  u.defineSizeMapping(m.build());
                }
                if(o.events) {
                  if(o.events["gpt.defined"]){o.events["gpt.defined"](u);}
                  var fl = function(a,b){if(o.events[a]){googletag.pubads().addEventListener(b,function(e){if(e.slot===u){o.events[a](u,e)}})}}
                  fl("gpt.rendered",'slotRenderEnded');
                  fl("gpt.viewed",'impressionViewable');
                  fl("gpt.visibilityChanged",'slotVisibilityChanged');
                }
              });
            }
            if(f.length){for(var i=0;i<f.length;++i){api_fallback(f[i]);}}else{api_fallback(f);}
            f=function(){AdBridg.serve()}
          }
          return googletag.cmd.push(f);
        }
        while (AdBridg.cmd.length) { AdBridg.cmd.push(AdBridg.cmd.shift()); }
      }
  })();
</script>
<script>
AdBridg.cmd.push(function () {
	googletag.pubads().collapseEmptyDivs();
	googletag.pubads().setTargeting('articleid', ['553400']);
	googletag.pubads().setTargeting('Tag', ['articlepage','cant stop the music','daily dose','queerantined','ad friendly','entertainment','feature']);
	googletag.pubads().setTargeting('UGC', ['no']);
	
  });
</script>
<script>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</script><title>Daily Dose: Matcho men in a gloriously awful musical / Queerty</title>
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//a.opmnstr.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Feed" href="https://www.queerty.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Comments Feed" href="https://www.queerty.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Daily Dose: Matcho men in a gloriously awful musical Comments Feed" href="https://www.queerty.com/daily-dose-matcho-men-gloriously-awful-musical-20200405/feed" />
<link rel='stylesheet' id='queerty_2017-style-css' href='https://www.queerty.com/content/themes/queerty_2017/style.css?ver=201901203' type='text/css' media='all' />
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' data-cfasync="false" id="omapi-script" async="async" src='https://a.opmnstr.com/app/js/api.min.js'></script>
<link rel='prev' title='Here’s a wondrously bi comeback for that homophobic ‘Adam and Eve’ argument' href='https://www.queerty.com/heres-wondrously-bi-comeback-homophobic-adam-eve-argument-20200405' />
<link rel="canonical" href="https://www.queerty.com/daily-dose-matcho-men-gloriously-awful-musical-20200405" />
<meta property="og:site_name" content="Queerty" /> <meta name="description" content="It&#039;s not a great movie, but it is great fun..." />
<meta property="og:description" content="It&#039;s not a great movie, but it is great fun...">
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.queerty.com/daily-dose-matcho-men-gloriously-awful-musical-20200405" />
<meta property="og:title" content="Daily Dose: Matcho men in a gloriously awful musical" />
<meta property="og:image" content="https://queerty-prodweb.imgix.net/2020/04/cant-stop-the-music.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=1024&h=576" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta name="twitter:image" content="https://queerty-prodweb.imgix.net/2020/04/cant-stop-the-music.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=1024&h=576" />
<meta property="article:published_time" content="2020-04-05T16:37:10-04:00" />
<meta property="article:modified_time" content="2020-04-05T16:37:10-04:00" />
<meta name="twitter:url" content="https://www.queerty.com/daily-dose-matcho-men-gloriously-awful-musical-20200405" />
<meta name="twitter:title" content="Daily Dose: Matcho men in a gloriously awful musical" />
<meta name="twitter:description" content="It&#039;s not a great movie, but it is great fun..." />
<meta name="news_keywords" content="can't stop the music, daily dose, Queerantined"><meta property="article:tags" content="can't stop the music, daily dose, Queerantined"><meta name="author" property="author" content="David Reddish" /><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://markedmeasure.com/v2/0/usuN3x8i68_Z8gwS4SdT8eDT_Ad8WacFr9oPLapk9ssVTVpLlBZxNg",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://markedmeasure.com/v2/0/ctcel1hVo5PTOjGzO9r_VCnB26nnPExye9f6GitMktQniZ1gg1xESEtPGMrBIdYwIzCUVC_",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script>

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@Queerty" />
<meta name="twitter:url" content="https://www.queerty.com/daily-dose-matcho-men-gloriously-awful-musical-20200405" />
<meta name="twitter:title" content="Daily Dose: Matcho men in a gloriously awful musical" />
<meta name="twitter:description" content="It&#039;s not a great movie, but it is great fun &hellip;" />
<meta name="twitter:image" content="https://queerty-prodweb.s3.amazonaws.com/2020/04/cant-stop-the-music.jpg"><meta name="twitter:image:alt" content="">

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KRQPBJR');</script>

<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.queerty.com/wp");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '2269d7e8-77de-42f4-85e0-e16c905e72b8';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Queerty";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing!";
oneSignal_options['welcomeNotification']['url'] = "https://www.queerty.com/";
oneSignal_options['path'] = "https://www.queerty.com/content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.32a023df-3e37-4c19-843f-3978a63a946e";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = 'Queerty';
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = 'Titles of Breaking Stories Will Appear Here';
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = 'Queerty';
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
<script type="text/javascript">var algolia = {"debug":false,"application_id":"6S92GABH7H","search_api_key":"cfd5e12cdf4a6106712391cbcf54f087","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"queerty_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true},{"index_id":"terms_category","index_name":"queerty_terms_category","label":"Categories","admin_name":"Categories","position":20,"max_suggestions":3,"tmpl_suggestion":"autocomplete-term-suggestion","enabled":true},{"index_id":"terms_post_tag","index_name":"queerty_terms_post_tag","label":"Tags","admin_name":"Tags","position":20,"max_suggestions":3,"tmpl_suggestion":"autocomplete-term-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"queerty_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]},"terms_category":{"name":"queerty_terms_category","id":"terms_category","enabled":true,"replicas":[]},"terms_post_tag":{"name":"queerty_terms_post_tag","id":"terms_post_tag","enabled":true,"replicas":[]}}};</script><link rel="amphtml" href="https://www.queerty.com/daily-dose-matcho-men-gloriously-awful-musical-20200405/amp"> <meta property="fb:app_id" content="153299894806318" />
<meta name="theme-color" content="#f43700" />
<meta name="apple-itunes-app" content="app-id=1046987164">
<meta property="fb:pages" content="33720334139" />
<meta name="apple-mobile-web-app-title" content="Queerty*">
<meta name="application-name" content="Queerty*">
<meta name="msapplication-config" content="/assets/q-2017/favicons/browserconfig.xml?v=lkgzj5W5Gl">
<link rel="apple-touch-icon" sizes="180x180" href="/assets/q-2017/favicons/apple-touch-icon.png?v=lkgzj5W5Gl">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-32x32.png?v=lkgzj5W5Gl" sizes="32x32">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-16x16.png?v=lkgzj5W5Gl" sizes="16x16">
<link rel="manifest" href="/assets/q-2017/favicons/manifest.json?v=20180829">
<link rel="mask-icon" href="/assets/q-2017/favicons/safari-pinned-tab.svg?v=lkgzj5W5Gl" color="#5bbad5">
<link rel="shortcut icon" href="/assets/q-2017/favicons/favicon.ico?v=lkgzj5W5Gl">
<meta property="article:publisher" content="https://www.facebook.com/queerty" />
<style>
.ad-leaderboard-header {
	background-color:transparent !important;
	position:relative;
	margin-top:10px;
}
.queerty-header {
	padding-top:10px !important;
}
@media screen and (max-height: 769px) {
	.queerty-header {
    	min-height: 4.688rem;
    	padding: 10px 0 10px !important;
	}
}
</style>
</head>
<body class="post-template-default single single-post postid-553400 single-format-standard category-ad-friendly category-entertainment category-feature">
<div id="top-of-page" style="display:none;"></div>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRQPBJR"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="page" class="site">
<div class="ad-leaderboard-header" id="div-gpt-ad-leader1">
<script>
				AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-leader1'); });
				</script>
</div>

<div id="is-phone"></div>

<header id="masthead" class="queerty-header">
<div class="queerty-header-wrapper">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="js-header-main-menu" class="queerty-header-menu show">
<li class="nav-link "><a href="/">Latest</a>
</li>
<li class="nav-link navcat-life "><a class="scroll-on-page-link" data-scroll="category-life" href="https://www.queerty.com/life">Life</a></li>
<li class="nav-link navcat-entertainment selected"><a class="scroll-on-page-link" data-scroll="category-entertainment" href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li class="nav-link navcat-politics "><a class="scroll-on-page-link" data-scroll="category-politics" href="https://www.queerty.com/politics">Politics</a></li>
<li class="nav-link navcat-goods "><a class="scroll-on-page-link" data-scroll="category-goods" href="https://www.queerty.com/goods">Goods</a></li>
</ul>
</nav>
<div class="logo-area">
<a href="/" class="queerty-logo">
<img src="/assets/q-2017/queerty-logo.svg" width="275" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo">
<img src="/assets/promos/pride/2019/queerty-pride.svg" width="275" alt="Queerty* Pride" class="queerty-header-pride-logo" style="display:none;">
</a>
</div>
<nav id="right-navigation" class="secondary-navigation" role="navigation">
<ul id="js-header-secondary-menu" class="queerty-header-menu show">
<li class="nav-link">
<a href="https://www.facebook.com/Queerty/"><img src="/assets/icons/facebook-f-icon.svg" height="19" aria-hidden="true" alt="Facebook"></a>
</li>
<li class="nav-link">
<a href="https://twitter.com/queerty"><img src="/assets/icons/twitter-icon.svg" height="19" aria-hidden="true" alt="Twitter"></a>
</li>
<li class="nav-link">
<a href="https://www.instagram.com/queerty/"><img src="/assets/icons/instagram-icon.svg" height="19" aria-hidden="true" alt="Instagram"></a>
</li>
<li class="nav-link">
<a href="https://eepurl.com/RrfMf"><img src="/assets/icons/envelope-regular.svg" height="19" aria-hidden="true" alt="newsletter"></a>
</li>
<li class="nav-link queerty-menu-button" id="more-menu">
<img src="/assets/icons/bars-solid.svg" height="19" aria-hidden="true" title="Open Menu" alt="Menu">
</li>
</ul>
</nav>
</div>
</header>
<nav class="queerty-menu-content">
<div class="queerty-menu-close"><img src="/assets/icons/times-solid.svg" height="19" aria-hidden="true" title="Close Menu" alt="Close"></i></div>
<div class="queerty-menu-searchbox">
<form role="search" method="get" class="search-form" action="https://www.queerty.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
<ul>
<li><a href="https://www.queerty.com/wp/wp-login.php?redirect_to=%2F%2Fwww.queerty.com%2Fdaily-dose-matcho-men-gloriously-awful-musical-20200405" id="menu-login">Log in</a></li>
<li><a href="https://www.queerty.com/wp/wp-login.php?action=register" id="menu-register">Register</a></li>
</ul>
<div class="menu-now-on-queerty-container"><ul id="menu-now-on-queerty" class="menu"><li id="menu-item-548398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-548398"><a href="https://www.queerty.com/Queerties2020/">The Queerties 2020</a></li>
<li id="menu-item-441445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441445"><a href="https://www.queerty.com/life">Life</a></li>
<li id="menu-item-441443" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-441443"><a href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li id="menu-item-441446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441446"><a href="https://www.queerty.com/politics">Politics</a></li>
<li id="menu-item-441444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441444"><a href="https://www.queerty.com/goods">Goods</a></li>
<li id="menu-item-544444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-544444"><a href="https://www.queerty.com/health">Health</a></li>
<li id="menu-item-504333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-504333"><a href="https://www.queerty.com/ever-after">Queerty Ever After</a></li>
<li id="menu-item-420166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-420166"><a href="https://www.queerty.com/dragaholic">Dragaholic</a></li>
<li id="menu-item-469065" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-469065"><a href="https://www.queerty.com/prepared">Prepared</a></li>
<li id="menu-item-420168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-420168"><a href="//www.queerty.com/queerty-tv/">Video (Queerty TV)</a></li>
</ul></div>
<ul>
<li><a href="https://www.lgbtqnation.com/">LGBTQ Nation News</a></li>
<li><a href="https://www.gaycities.com/">GayCities Travel Guides</a></li>
</ul>
<ul>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
</ul>
</nav>
<div class="queerty-menu-fade-screen"></div>
<div id="content" class="site-content"> <div class="single-wrapper">
<div id="primary" class="content-area single-article ">
<main id="main" class="site-main" role="main">
<article id="post-553400" class="post-553400 post type-post status-publish format-standard has-post-thumbnail hentry category-ad-friendly category-entertainment category-feature tag-cant-stop-the-music tag-daily-dose tag-queerantined">
<header class="entry-header">
<div class="kicker ">Queerantined</div> <h1 class="entry-title"><a href="https://www.queerty.com/daily-dose-matcho-men-gloriously-awful-musical-20200405"><span itemprop="headline">Daily Dose: Matcho men in a gloriously awful musical</span></a></h1>
<div class="entry-meta">
<span class="byline"> By <span itemprop="author"> <a href="https://www.queerty.com/author/david-reddish" title="Posts by David Reddish" rel="author">David Reddish</a></span></span> <time class="posted-on" itemprop="datePublished" datetime="2020-04-05T16:37:10-04:00">46 minutes ago</time> </div>
</header>
<div class="entry-content" itemprop="articleBody">
<p><img class="alignnone size-large wp-image-502357" src="https://queerty-prodweb.s3.amazonaws.com/2019/06/cant-stop-the-musi-670x378.jpg" alt="" width="670" height="378" srcset="https://queerty-prodweb.imgix.net/2019/06/cant-stop-the-musi-670x378.jpg?&amp;auto=format&amp;auto=compress&amp;w=670 670w, https://queerty-prodweb.imgix.net/2019/06/cant-stop-the-musi-670x378.jpg?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://queerty-prodweb.imgix.net/2019/06/cant-stop-the-musi-670x378.jpg?&amp;auto=format&amp;auto=compress&amp;w=756 756w" sizes="(max-width: 670px) 100vw, 670px"></p>
<p><em>Welcome to Queerty’s latest entry in our Queerantined: Daily Dose series. Every day as long as the COVID-19 pandemic has us under quarantine, we’ll release a suggested bit of gloriously queer </em><em>entertainment designed to keep you from getting stir crazy in the house. Each weekend, we will also suggest a bingable title to keep you extra busy.</em></p>
<p><strong>The Camp Out: Can’t Stop the Music</strong></p>
<p>We don’t know about you, but our total lack of a social life with our queer siblings has put a massive pall our lives. The solution: wild and <em>very</em> gay romp through New York on the eve of the 1980s, starring the <a href="https://www.queerty.com/watch-stonewall-village-people-gay-dads-gospel-singing-drag-queens-20190620">Village People</a>. <em>Can’t Stop The Music</em> takes the band and their hit tunes like “Macho Man” and “YMCA” and blends them into an old-style Hollywood musical, dramatizing the rise of the band. A very twinkish Steve Guttenberg stars as a DJ with a knack for writing music, but no singing voice. He and his roommate, the model Sam (Valerie Perrine) assemble the Village People as their ticket to stardom. Or something like that. <em>Can’t Stop the Music</em> isn’t a movie to watch for plot, but for the music of the Village People, and for the outrageous ridiculousness of it all. A pre-transition Caitlyn Jenner also stars in this gloriously awful campfest, best enjoyed with a tall bottle of liquor on standby.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle1"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle1"); });</script></div>
<p><em>Streams on <a href="https://amzn.to/2UJYyW7">Amazon</a>, iTunes, VUDU &amp; YouTube. Also available on a special edition <a href="https://www.queerty.com/sylvester-cant-stop-dancing-in-new-musical-about-the-late-great-disco-queen-20140803">Blu-Ray from Shout Factory.</a></em></p>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="Can't Stop The Music (1980) - Official Trailer" width="872" height="491" src="https://www.youtube.com/embed/wqeQWYwVFo0?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
</div>
<footer class="entry-footer">
<span class="tags-links"><a href="https://www.queerty.com/entertainment" rel="category">Entertainment</a> <a href="https://www.queerty.com/tag/cant-stop-the-music" rel="tag">can't stop the music</a> <a href="https://www.queerty.com/tag/daily-dose" rel="tag">daily dose</a> <a href="https://www.queerty.com/tag/queerantined" rel="tag">Queerantined</a></span><div class="comments-link-area"><a href="https://www.queerty.com/daily-dose-matcho-men-gloriously-awful-musical-20200405#respond"><span class="comments-link">Add a comment</span></a></div> </footer>
</article>
</main>
<div class="article-email-prompt-red" id="queerty-article-email-prompt">
<h3><span class="asterisk"> </span>Get Queerty Daily</h3>
Subscribe to Queerty for a daily dose of #entertainment #can'tstopthemusic #dailydose stories and more
<form action="//queerty.us1.list-manage.com/subscribe/post?u=ecab442566f15d8d4dcf64b0d&amp;id=221c27272a" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank">
<input type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="Your email" autocomplete="email">
<input type="hidden" name="group[5437][16]" value="1">
<input type="hidden" value="2" name="group[5409][2]" id="mce-group[5409]-5409-0">
<input type="hidden" value="1" name="group[5409][1]" id="mce-group[5409]-5409-1">
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ecab442566f15d8d4dcf64b0d_221c27272a" tabindex="-1" value=""></div>
<input type="submit" value="Subscribe" name="submit" id="mc-embedded-subscribe" class="button">
</form>
</div>
<div id="esb-embed"><script src="//embed.egamiplatform.tv/embed-nxlfz.js"></script></div>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Add your Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/daily-dose-matcho-men-gloriously-awful-musical-20200405#respond" style="display:none;">Cancel reply</a></small></h3><p class="nocomments">Please <a href="https://www.queerty.com/wp/wp-login.php?redirect_to=https%3A%2F%2Fwww.queerty.com%2Fdaily-dose-matcho-men-gloriously-awful-musical-20200405">log in</a> to add your comment<br>Need an account? <strong><a href="https://www.queerty.com/wp/wp-login.php?action=register">Register</a></strong> *It's free and easy.</p> </div>
</div>
</div>
<script type="text/javascript" async="async" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-58640af04b28c97d"></script>
<script async data-cfasync="false" src="https://embed.air.tv/v1/twoview_bootstrap.js?organization=836XtBNIR-WS8sis907b8w"></script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.queerty.com\/daily-dose-matcho-men-gloriously-awful-musical-20200405"},"headline":"Daily Dose: Matcho men in a gloriously awful musical","url":"https:\/\/www.queerty.com\/daily-dose-matcho-men-gloriously-awful-musical-20200405","datePublished":"2020-04-05T16:37:10-04:00","dateModified":"2020-04-05T16:37:10-04:00","description":"It's not a great movie, but it is great fun.","thumbnailUrl":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2020\/04\/cant-stop-the-music-307x289.jpg","image":{"@type":"ImageObject","url":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2020\/04\/cant-stop-the-music-307x289.jpg","height":670,"width":358},"creator":"David Reddish","author":{"@type":"Person","name":"David Reddish"},"articleSection":"Entertainment","keywords":["Ad Friendly","Feature","can't stop the music","daily dose","Queerantined","[ Has: YouTube embed ]","[ Word count: <300 ]"],"publisher":{"@type":"NewsMediaOrganization","name":"Queerty","url":"https:\/\/www.queerty.com\/","logo":{"@type":"ImageObject","url":"https:\/\/www.queerty.com\/assets\/q-2017\/queerty-logo-225x60.png","height":"60","width":"225"},"address":{"@type":"PostalAddress","streetAddress":"584 Castro St. #623","addressLocality":"San Francisco","addressRegion":"CA","postalCode":"94114","addressCountry":"USA"},"sameAs":["https:\/\/en.wikipedia.org\/wiki\/Queerty","https:\/\/www.facebook.com\/queerty","https:\/\/www.twitter.com\/queerty","https:\/\/www.instagram.com\/queerty","https:\/\/www.youtube.com\/user\/queertyTV"]}}</script>
<aside id="secondary" class="article-sidebar" role="complementary">
<div class="sidebar-ad-1" id="div-gpt-ad-box1">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box1'); });
			</script>
</div>
<div id="civsci-id-1487938606" data-civicscience-widget="7e525d9d-2b18-3944-8162-270cab0eef2f"></div>
<script type="text/javascript" async src="https://www.civicscience.com/jspoll/4/civicscience-widget.js"></script>
<section class="sidebar-related">
<h3 class="category-heading">
More in Entertainment </h3>
<div class="cards-list">
<article id="post-553334" class="card card-small ">
<a href="https://www.queerty.com/listen-joe-exotics-ex-john-finlay-gives-disastrous-interview-relationship-20200405">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/04/joe-dillon-netflix.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="LISTEN: Joe Exotic&#8217;s ex, John Finlay, talks about their relationship">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Sound of Silence</div>
<h2 class="entry-title">LISTEN: Joe Exotic&#8217;s ex, John Finlay, talks about their relationship</h2> <div class="entry-meta">
<a href="https://www.queerty.com/listen-joe-exotics-ex-john-finlay-gives-disastrous-interview-relationship-20200405" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-05T10:00:52-04:00"> Today at 10:04am</time></a> </div>
</section>
</a>
</article>
<article id="post-553392" class="card card-small ">
<a href="https://www.queerty.com/daily-dose-purrfect-gay-icon-gets-best-big-screen-role-20200404">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/04/Yzma_42.PNG.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Daily Dose: A purrfect gay icon gets her best big-screen role">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Queerantined</div>
<h2 class="entry-title">Daily Dose: A purrfect gay icon gets her best big-screen role</h2> <div class="entry-meta">
<a href="https://www.queerty.com/daily-dose-purrfect-gay-icon-gets-best-big-screen-role-20200404" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-04T14:33:06-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-553199" class="card card-small ">
<a href="https://www.queerty.com/10-movies-male-strippers-quench-thirst-quarantine-20200404">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/03/toy-boy-netflix.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="10 movies about male strippers to quench your thirst during quarantine">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">dancing queens</div>
<div class="card-commentcount">14 comments</div><h2 class="entry-title">10 movies about male strippers to quench your thirst during quarantine</h2> <div class="entry-meta">
<a href="https://www.queerty.com/10-movies-male-strippers-quench-thirst-quarantine-20200404" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-04T11:30:03-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-553343" class="card card-small ">
<a href="https://www.queerty.com/weekend-binge-show-redefined-sci-fi-war-terror-20200403">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/04/battlestar-galactica-jamie-bamber17.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="The Weekend Binge: The show that redefined sci-fi and the War on Terror">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Queerantined</div>
<h2 class="entry-title">The Weekend Binge: The show that redefined sci-fi and the War on Terror</h2> <div class="entry-meta">
<a href="https://www.queerty.com/weekend-binge-show-redefined-sci-fi-war-terror-20200403" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-03T19:12:07-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-2" id="div-gpt-ad-box2">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box2'); });
			</script>
</div>
<br>
<section class="sidebar-related">
<h3 class="category-heading">
Popular on Queerty
</h3>
<div class="cards-list">
<article id="post-553065" class="card card-small ">
<a href="https://www.queerty.com/fox-news-purportedly-bracing-legal-bloodbath-peddling-coronavirus-misinformation-20200331">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/03/fox-news-logo-screenshot.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Fox News purportedly bracing for &#8220;legal bloodbath&#8221; after peddling coronavirus misinformation">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">legal liability</div>
<div class="card-commentcount">24 comments</div><h2 class="entry-title">Fox News purportedly bracing for &#8220;legal bloodbath&#8221; after peddling coronavirus misinformation</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-553159" class="card card-small ">
<a href="https://www.queerty.com/man-reveals-partners-terrifying-near-death-covid-19-experience-20200401">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/04/brian_zupanick_john_giarratano_supplied.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Man reveals partner’s terrifying, near-death COVID-19 experience">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Stay home</div>
<h2 class="entry-title">Man reveals partner’s terrifying, near-death COVID-19 experience</h2> <div class="entry-meta">
<a href="https://www.queerty.com/man-reveals-partners-terrifying-near-death-covid-19-experience-20200401" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-01T08:50:19-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-553043" class="card card-small gaycities-link">
<a target="_blank" href="https://www.gaycities.com/outthere/50837/the-show-must-go-on-nightlife-in-the-age-of-covid-19/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=How+we+can+support+queer+nightlife+workers+in+the+age+of+COVID-19">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/03/Screen-Shot-2020-03-31-at-12.25.15-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="How we can support queer nightlife workers in the age of COVID-19">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Show goes on</div>
<h2 class="entry-title">How we can support queer nightlife workers in the age of COVID-19</h2> <div class="entry-meta">
<a href="https://www.queerty.com/can-support-queer-nightlife-workers-age-covid-19-20200331" rel="bookmark"><time class="entry-date published updated" datetime="2020-03-31T17:45:49-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-553140" class="card card-small ">
<a href="https://www.queerty.com/photo-ansel-elgort-gives-thirsty-fans-eyeful-stepping-just-gym-shorts-20200331">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/03/Screen-Shot-2020-03-31-at-2.32.26-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="PHOTO: Ansel Elgort gives thirsty fans an eyeful stepping in just gym shorts">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Star quality</div>
<div class="card-commentcount">29 comments</div><h2 class="entry-title">PHOTO: Ansel Elgort gives thirsty fans an eyeful stepping in just gym shorts</h2> <div class="entry-meta">
<a href="https://www.queerty.com/photo-ansel-elgort-gives-thirsty-fans-eyeful-stepping-just-gym-shorts-20200331" rel="bookmark"><time class="entry-date published updated" datetime="2020-03-31T17:34:43-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-553086" class="card card-small ">
<a href="https://www.queerty.com/antigay-liberty-university-reopens-despite-warnings-now-students-face-covid-19-outbreak-20200331">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/content/docs/2016/10/19194727/496697744-dr-jerry-falwell-president-of-liberty-university.jpg.CROP_.promo-xlarge2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Antigay Liberty University reopens despite warnings. Now students face COVID-19 outbreak.">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">You Were Warned</div>
<div class="card-commentcount">10 comments</div><h2 class="entry-title">Antigay Liberty University reopens despite warnings. Now students face COVID-19 outbreak.</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div>
</section>
</aside>
<br clear=all>
<div class="single-bottom-articles">
<h3>
Latest on Queerty </h3>
<div class="single-bottom-articles-slider slider slick-slider">
<div><article id="post-551501" class="card card-small ">
<a href="https://www.queerty.com/heres-wondrously-bi-comeback-homophobic-adam-eve-argument-20200405">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/03/shutterstock_667287661-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Here’s a wondrously bi comeback for that homophobic ‘Adam and Eve’ argument">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Boy, bi</div>
<h2 class="entry-title">Here’s a wondrously bi comeback for that homophobic ‘Adam and Eve’ argument</h2> <div class="entry-meta">
<a href="https://www.queerty.com/heres-wondrously-bi-comeback-homophobic-adam-eve-argument-20200405" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-05T10:30:19-04:00"> Today at 10:04am</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-553334" class="card card-small ">
<a href="https://www.queerty.com/listen-joe-exotics-ex-john-finlay-gives-disastrous-interview-relationship-20200405">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/04/joe-dillon-netflix.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="LISTEN: Joe Exotic&#8217;s ex, John Finlay, talks about their relationship">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Sound of Silence</div>
<h2 class="entry-title">LISTEN: Joe Exotic&#8217;s ex, John Finlay, talks about their relationship</h2> <div class="entry-meta">
<a href="https://www.queerty.com/listen-joe-exotics-ex-john-finlay-gives-disastrous-interview-relationship-20200405" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-05T10:00:52-04:00"> Today at 10:04am</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-551692" class="card card-small ">
<a href="https://www.queerty.com/sex-worker-survived-hell-teach-us-forgiveness-20200405">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/03/DAVID-PORTRAIT-Jim-Cox-400x600-1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="This sex worker survived hell to teach us lessons in forgiveness">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Reading Room</div>
<h2 class="entry-title">This sex worker survived hell to teach us lessons in forgiveness</h2> <div class="entry-meta">
<a href="https://www.queerty.com/sex-worker-survived-hell-teach-us-forgiveness-20200405" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-05T09:24:31-04:00"> Today at 9:04am</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-553392" class="card card-small ">
<a href="https://www.queerty.com/daily-dose-purrfect-gay-icon-gets-best-big-screen-role-20200404">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/04/Yzma_42.PNG.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Daily Dose: A purrfect gay icon gets her best big-screen role">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Queerantined</div>
<h2 class="entry-title">Daily Dose: A purrfect gay icon gets her best big-screen role</h2> <div class="entry-meta">
<a href="https://www.queerty.com/daily-dose-purrfect-gay-icon-gets-best-big-screen-role-20200404" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-04T14:33:06-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-553366" class="card card-small ">
<a href="https://www.queerty.com/tom-daleys-home-gym-jake-bains-fur-rug-tommy-dorfmans-full-spread-20200404">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/04/Mehcad-Brooks-Dyllon-Burnside-Rafael-De-La-Fuente-Joshua-Cruz-instastuds.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Tom Daley&#8217;s home gym, Jake Bain&#8217;s fur rug, &#038; Tommy Dorfman&#8217;s full spread">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Instastuds</div>
<div class="card-commentcount">13 comments</div><h2 class="entry-title">Tom Daley&#8217;s home gym, Jake Bain&#8217;s fur rug, &#038; Tommy Dorfman&#8217;s full spread</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-553199" class="card card-small ">
<a href="https://www.queerty.com/10-movies-male-strippers-quench-thirst-quarantine-20200404">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/03/toy-boy-netflix.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="10 movies about male strippers to quench your thirst during quarantine">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">dancing queens</div>
<div class="card-commentcount">14 comments</div><h2 class="entry-title">10 movies about male strippers to quench your thirst during quarantine</h2> <div class="entry-meta">
<a href="https://www.queerty.com/10-movies-male-strippers-quench-thirst-quarantine-20200404" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-04T11:30:03-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-553127" class="card card-small ">
<a href="https://www.queerty.com/12-fascinating-works-lgbtq-nonfiction-help-pass-time-20200404">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/04/Screen-Shot-2020-04-03-at-2.34.26-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="12 fascinating works of LGBTQ nonfiction to help pass the time">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">reading room</div>
<h2 class="entry-title">12 fascinating works of LGBTQ nonfiction to help pass the time</h2> <div class="entry-meta">
<a href="https://www.queerty.com/12-fascinating-works-lgbtq-nonfiction-help-pass-time-20200404" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-04T11:00:08-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-551659" class="card card-small ">
<a href="https://www.queerty.com/trainer-ian-armstrong-take-edible-workout-20200404">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/03/Ian-Armstrong.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Trainer Ian Armstrong on why you should take an edible before a workout">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">High on Health</div>
<div class="card-commentcount">12 comments</div><h2 class="entry-title">Trainer Ian Armstrong on why you should take an edible before a workout</h2> <div class="entry-meta">
<a href="https://www.queerty.com/trainer-ian-armstrong-take-edible-workout-20200404" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-04T10:30:21-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-553056" class="card card-small ">
<a href="https://www.queerty.com/hiv-positive-student-nurse-faces-covid-19-work-fears-home-20200404">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/03/image3-3-scaled.jpeg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="HIV positive student nurse faces COVID-19 at work and fears at home">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">COVID Hero</div>
<div class="card-commentcount">14 comments</div><h2 class="entry-title">HIV positive student nurse faces COVID-19 at work and fears at home</h2> <div class="entry-meta">
<a href="https://www.queerty.com/hiv-positive-student-nurse-faces-covid-19-work-fears-home-20200404" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-04T09:08:29-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-553343" class="card card-small ">
<a href="https://www.queerty.com/weekend-binge-show-redefined-sci-fi-war-terror-20200403">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/04/battlestar-galactica-jamie-bamber17.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="The Weekend Binge: The show that redefined sci-fi and the War on Terror">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Queerantined</div>
<h2 class="entry-title">The Weekend Binge: The show that redefined sci-fi and the War on Terror</h2> <div class="entry-meta">
<a href="https://www.queerty.com/weekend-binge-show-redefined-sci-fi-war-terror-20200403" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-03T19:12:07-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-552074" class="card card-small queerty-interview-link">
<a href="https://www.queerty.com/sean-hayes-revives-oddball-indie-comedy-new-movie-lazy-susan-woman-20200403">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/03/Sean-Hayes-as-Susan-_soda-fountain_73lo.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Sean Hayes revives oddball, indie comedy in his new movie &#8216;Lazy Susan&#8217;&#8230;as a woman">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">He's a Lady</div>
<div class="card-commentcount">13 comments</div><h2 class="entry-title">Sean Hayes revives oddball, indie comedy in his new movie &#8216;Lazy Susan&#8217;&#8230;as a woman</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-553318" class="card card-small ">
<a href="https://www.queerty.com/timothee-chalamet-armie-hammer-will-lovers-goes-according-plan-20200403">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2018/03/call-me-by-your-name-sex.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Timothée Chalamet and Armie Hammer will be lovers again if all goes according to plan">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Peachy</div>
<div class="card-commentcount">42 comments</div><h2 class="entry-title">Timothée Chalamet and Armie Hammer will be lovers again if all goes according to plan</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div>
</div>
</div></div>
</div>
<div class="site-footer-holder">
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="footer-brand">
<span class="asterisk"> </span>
Free of an agenda (except that gay one)
</div>
<div class="tags-links">
<a href="//www.queerty.com/tag/adam-rippon">Adam Rippon</a> <a href="//www.queerty.com/tag/freddie-mercury">Freddie Mercury</a> <a href="//www.queerty.com/tag/gus-kenworthy">Gus Kenworthy</a> <a href="//www.queerty.com/tag/nick-jonas">Nick Jonas</a> <a href="//www.queerty.com/tag/nico-tortorella">Nico Tortorella</a> <a href="//www.queerty.com/tag/pietro-boselli">Pietro Boselli</a> <a href="//www.queerty.com/tag/ricky-martin">Ricky Martin</a> <a href="//www.queerty.com/tag/russell-tovey">Russell Tovey</a> <a href="//www.queerty.com/tag/zac-efron">Zac Efron</a> <div class="second-row">
<a href="//www.queerty.com/tag/donald-trump">Donald Trump</a> <a href="//www.queerty.com/tag/homophobia">Homophobia</a> <a href="//www.queerty.com/tag/coming-out">Coming Out</a> <a href="//www.queerty.com/tag/rupaul's-drag-race">Rupaul's Drag Race</a> <a href="//www.queerty.com/tag/scandal">Scandal</a> <a href="//www.queerty.com/tag/religion">Religion</a> <a href="//www.queerty.com/tag/relationships">Relationships</a> <a href="//www.queerty.com/tag/grindr">Grindr</a>
</div>
</div>
<div class="footer-links">
<ul class="main" id="footer-company-links">
<li><a href="http://www.q.digital"><img src="/assets/q-digital-blue-90x37.png" alt="Q.digital" width="90"></a></li>
<li><b>A Q.Digital Company</b></li>
<li>&copy; 2020 Queerty, Inc.</li>
<li><a href="http://www.q.digital">Advertise With Us</a></li>
</ul>
<ul class="main" id="footer-contact-links">
<li><h3>Contact</h3></li>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
<li><a href="https://www.queerty.com/queertys-comment-policy">Comments Policy</a>
<li><a href="https://www.queerty.com/privacy-policy">Privacy Statement</a>
<li><a href="https://www.queerty.com/terms-of-use">Terms of Use</a>
<li><a id="ccpaOptOut">Do Not Sell My Personal Information</a>
</ul>
<ul class="main" id="footer-follow-links">
<li><h3>Follow</h3></li>
<li><a href="https://www.facebook.com/Queerty/">Facebook</a></li>
<li><a href="https://www.twitter.com/Queerty/">Twitter</a></li>
<li><a href="https://www.instagram.com/Queerty/">Instagram</a></li>
<li><a href="https://www.youtube.com/user/QueertyTV/">YouTube</a></li>
</ul>
<ul class="main double" id="footer-gaycities-links">
<li><h3>GayCities: Your Gay Travel Guide:</h3></li>
<li><a href="https://newyork.gaycities.com/">New York</a></li>
<li><a href="https://london.gaycities.com/">London</a></li>
<li><a href="https://sanfrancisco.gaycities.com/">San Francisco</a></li>
<li><a href="https://chicago.gaycities.com/">Chicago</a></li>
<li><a href="https://losangeles.gaycities.com/">Los Angeles</a></li>
<li><a href="https://washingtondc.gaycities.com/">Washington DC</a></li>
<li><a href="https://dallas.gaycities.com/">Dallas</a></li>
<li><a href="https://saskatoon.gaycities.com/">Gay Saskatoon</a></li>
<li><a href="https://www.gaycities.com/places/"><b>See all 230+ cities...</b></a></li>
</ul>
</div>
</footer>
</div>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "32666898" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=32666898&cv=2.0&cj=1" alt="Comscore Measurement" />
</noscript>

<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '686853021424163');
  fbq('track', 'PageView');
</script>
<noscript><img height='1' width='1' style='display:none'
  src='https://www.facebook.com/tr?id=686853021424163&ev=PageView&noscript=1'
/></noscript>

<script>
  fbq('track', 'ViewContent');
</script>
<script>
	window.dataLayer = window.dataLayer || []
	dataLayer.push({
	   'event': 'Page Details',
	   'pageType': 'article',
	   'pageCategory': 'entertainment'
	   
	});
	</script>
<script type="text/javascript" src="https://s.skimresources.com/js/151843X1617499.skimlinks.js"></script><script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' async src='https://platform.twitter.com/widgets.js?ver=20161216'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js?ver=5.3.2'></script>
<script type='text/javascript' async src='https://www.queerty.com/content/themes/queerty_2017/js/min/queerty-nosticky-min.js?ver=20200120a'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.2' async='async'></script>
<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":553400,"object_key":"post","object_type":"post","term_ids":[69394,2215,6255,83896,86094,86095]};</script>
<script data-cfasync="false" id="parsely-cfg" data-parsely-site="queerty.com" src="https://cdn.parsely.com/keys/queerty.com/p.js"></script>
</body>
</html>