<!DOCTYPE html>
<html>
<head>
<link rel="stylesheet" href="https://use.typekit.net/cdb4vyt.css">
<meta name="viewport" content="width=device-width, initial-scale=1">

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
</script>

<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.2634970.min.js?cachebuster=1';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      // Return control to GPT if the AdBridg library fails to load.
      adb.onerror = function() {
        console.log('Fallback: ')
        if (AdBridg.exists) { return; }
        document.createElement('IMG').src = '//adspsp.com/pt/2634970/3/1/?e=0';
        var dq = [], es;
        dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
        AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
        AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
        AdBridg.destroySlots = function(s) { return googletag.destroySlots(s); }
        AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
        AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
        AdBridg.render = function() { }
        AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
        AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
        AdBridg.useSizeMapping = function() { }
        AdBridg.cmd.push = function(f) {
          if (typeof(f)=='object') {
            var api_fallback = function(o) {
              googletag.cmd.push(function() {
                var u=AdBridg.defineSlot(o.gpt_path,o.size||[],o.dom_id);
                if(o.size_map) {
                  var m = googletag.sizeMapping();
                  for(var oi=0;oi<o.size_map.length;oi++){m=m.addSize(o.size_map[oi].viewport, o.size_map[oi].sizes);}
                  u.defineSizeMapping(m.build());
                }
                if(o.events) {
                  if(o.events["gpt.defined"]){o.events["gpt.defined"](u);}
                  var fl = function(a,b){if(o.events[a]){googletag.pubads().addEventListener(b,function(e){if(e.slot===u){o.events[a](u,e)}})}}
                  fl("gpt.rendered",'slotRenderEnded');
                  fl("gpt.viewed",'impressionViewable');
                  fl("gpt.visibilityChanged",'slotVisibilityChanged');
                }
              });
            }
            if(f.length){for(var i=0;i<f.length;++i){api_fallback(f[i]);}}else{api_fallback(f);}
            f=function(){AdBridg.serve()}
          }
          return googletag.cmd.push(f);
        }
        while (AdBridg.cmd.length) { AdBridg.cmd.push(AdBridg.cmd.shift()); }
      }
  })();
</script>
<script>
AdBridg.cmd.push(function () {
	googletag.pubads().collapseEmptyDivs();
	googletag.pubads().setTargeting('articleid', ['574931']);
	googletag.pubads().setTargeting('Tag', ['articlepage','2021 queerties','giants','giants the series','james bland','ad friendly','entertainment','queerty']);
	googletag.pubads().setTargeting('UGC', ['no']);
	
  });
</script>
<script>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</script><title>WATCH: We chatted with James Bland, creator, director, and star of &#8216;Giants: The Series&#8217; / Queerty</title>
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//q-digital.videoplayerhub.com' />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Feed" href="https://www.queerty.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Comments Feed" href="https://www.queerty.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; WATCH: We chatted with James Bland, creator, director, and star of &#8216;Giants: The Series&#8217; Comments Feed" href="https://www.queerty.com/watch-chatted-james-bland-creator-director-star-giants-series-20210216/feed" />
<link rel='stylesheet' id='queerty_2017-style-css' href='https://www.queerty.com/content/themes/queerty_2017/style.css?ver=20210122a' type='text/css' media='all' />
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="canonical" href="https://www.queerty.com/watch-chatted-james-bland-creator-director-star-giants-series-20210216" />
<meta property="og:site_name" content="Queerty" /> <meta name="description" content="&quot;I felt like, most of my life, I hadn&#039;t seen myself on screen. I wanted desperately to, you know, see myself..." />
<meta property="og:description" content="&quot;I felt like, most of my life, I hadn&#039;t seen myself on screen. I wanted desperately to, you know, see myself...">
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.queerty.com/watch-chatted-james-bland-creator-director-star-giants-series-20210216" />
<meta property="og:title" content="WATCH: We chatted with James Bland, creator, director, and star of &#8216;Giants: The Series&#8217;" />
<meta property="og:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/01/Screen-Shot-2021-01-16-at-10.35.46-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=1024&h=576" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta name="twitter:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/01/Screen-Shot-2021-01-16-at-10.35.46-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=1024&h=576" />
<meta property="article:published_time" content="2021-02-16T17:15:02-05:00" />
<meta property="article:modified_time" content="2021-02-16T17:15:02-05:00" />
<meta name="twitter:url" content="https://www.queerty.com/watch-chatted-james-bland-creator-director-star-giants-series-20210216" />
<meta name="twitter:title" content="WATCH: We chatted with James Bland, creator, director, and star of &#8216;Giants: The Series&#8217;" />
<meta name="twitter:description" content="&quot;I felt like, most of my life, I hadn&#039;t seen myself on screen. I wanted desperately to, you know, see myself..." />
<meta name="news_keywords" content="2021 Queerties, giants, giants the series, james bland"><meta property="article:tags" content="2021 Queerties, giants, giants the series, james bland"><meta name="author" property="author" content="Editors" />

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@Queerty" />
<meta name="twitter:title" content="WATCH: We chatted with James Bland, creator, director, and star of &#8216;Giants: The Series&#8217;" />
<meta name="twitter:description" content="&quot;I felt like, most of my life, I hadn&#039;t seen myself on screen. I &hellip;" />
<meta name="twitter:image" content="https://queerty-prodweb.s3.amazonaws.com/2021/01/Screen-Shot-2021-01-16-at-10.35.46-AM.png">
<meta name="twitter:image:alt" content="">


<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KRQPBJR');</script>

<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.queerty.com/wp");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '2269d7e8-77de-42f4-85e0-e16c905e72b8';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Queerty";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing!";
oneSignal_options['welcomeNotification']['url'] = "https://www.queerty.com/";
oneSignal_options['path'] = "https://www.queerty.com/content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.32a023df-3e37-4c19-843f-3978a63a946e";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = "Queerty";
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = "Titles of Breaking Stories Will Appear Here";
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = "Queerty";
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
<link rel="amphtml" href="https://www.queerty.com/watch-chatted-james-bland-creator-director-star-giants-series-20210216/amp"> <link rel="preconnect" href="https://queerty-assets.s3.amazonaws.com">
<link rel="preload" href="https://www.googletagservices.com/tag/js/gpt.js">
<link rel="preconnect" href="https://www.googletagmanager.com">
<link rel="preconnect" href="https://queerty-prodweb.imgix.net">
<meta property="fb:app_id" content="153299894806318" />
<meta name="theme-color" content="#f43700" />
<meta name="apple-itunes-app" content="app-id=1046987164">
<meta property="fb:pages" content="33720334139" />
<meta name="apple-mobile-web-app-title" content="Queerty*">
<meta name="application-name" content="Queerty*">
<meta name="msapplication-config" content="/assets/q-2017/favicons/browserconfig.xml?v=lkgzj5W5Gl">
<link rel="apple-touch-icon" sizes="180x180" href="/assets/q-2017/favicons/apple-touch-icon.png?v=lkgzj5W5Gl">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-32x32.png?v=lkgzj5W5Gl" sizes="32x32">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-16x16.png?v=lkgzj5W5Gl" sizes="16x16">
<link rel="manifest" href="/assets/q-2017/favicons/manifest.json?v=20180829">
<link rel="mask-icon" href="/assets/q-2017/favicons/safari-pinned-tab.svg?v=lkgzj5W5Gl" color="#5bbad5">
<link rel="shortcut icon" href="/assets/q-2017/favicons/favicon.ico?v=lkgzj5W5Gl">
<meta property="article:publisher" content="https://www.facebook.com/queerty" />
<style>
.ad-leaderboard-header {
	background-color:transparent !important;
	position:relative;
	margin-top:10px;
}
.queerty-header {
	padding-top:10px !important;
}
@media screen and (max-height: 769px) {
	.queerty-header {
    	min-height: 4.688rem;
    	padding: 10px 0 10px !important;
	}
}
</style>
<script async src="https://powerad.ai/script.js"></script>
</head>
<body class="post-template-default single single-post postid-574931 single-format-standard category-ad-friendly category-entertainment category-queerty">
<div id="top-of-page" style="display:none;"></div>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRQPBJR"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="page" class="site">
<div class="ad-leaderboard-header" id="div-gpt-ad-leader1">
<script>
				AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-leader1'); });
				</script>
</div>

<div id="is-phone"></div>

<header id="masthead" class="queerty-header">
<div class="queerty-header-wrapper">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="js-header-main-menu" class="queerty-header-menu show">
<li class="nav-link "><a href="/">Latest</a>
</li>
<li class="nav-link navcat-life "><a class="scroll-on-page-link" data-scroll="category-life" href="https://www.queerty.com/life">Life</a></li>
<li class="nav-link navcat-entertainment selected"><a class="scroll-on-page-link" data-scroll="category-entertainment" href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li class="nav-link navcat-politics "><a class="scroll-on-page-link" data-scroll="category-politics" href="https://www.queerty.com/politics">Politics</a></li>
<li class="nav-link navcat-queerties"><a href="/Queerties2021/">Queerties</a></li>
</ul>
</nav>
<div class="logo-area">
<a href="/" class="queerty-logo"><!-- -->
<img src="/assets/q-2017/queerty-logo.svg" width="275" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo">
<img src="/assets/promos/pride/2019/queerty-pride.svg" width="275" alt="Queerty* Pride" class="queerty-header-pride-logo" style="display:none;">
</a>
</div>
<nav id="right-navigation" class="secondary-navigation" role="navigation">
<ul id="js-header-secondary-menu" class="queerty-header-menu show">
<li class="nav-link">
<a href="https://www.facebook.com/Queerty/"><img src="/assets/icons/facebook-f-icon.svg" height="19" aria-hidden="true" alt="Facebook"></a>
</li>
<li class="nav-link">
<a href="https://twitter.com/queerty"><img src="/assets/icons/twitter-icon.svg" height="19" aria-hidden="true" alt="Twitter"></a>
</li>
<li class="nav-link">
<a href="https://www.instagram.com/queerty/"><img src="/assets/icons/instagram-icon.svg" height="19" aria-hidden="true" alt="Instagram"></a>
</li>
<li class="nav-link">
<a href="https://eepurl.com/RrfMf"><img src="/assets/icons/envelope-regular.svg" height="19" aria-hidden="true" alt="newsletter"></a>
</li>
<li class="nav-link queerty-menu-button" id="more-menu">
<img src="/assets/icons/bars-solid.svg" height="19" aria-hidden="true" title="Open Menu" alt="Menu">
</li>
</ul>
</nav>
</div>
</header>
<nav class="queerty-menu-content">
<div class="queerty-menu-close"><img src="/assets/icons/times-solid.svg" height="19" aria-hidden="true" title="Close Menu" alt="Close"></i></div>
<div class="queerty-menu-logo"><img src="/assets/q-2017/queerty-logo.svg" width="100" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo"></div>
<div class="queerty-menu-searchbox">
<form role="search" method="get" class="search-form" action="https://www.queerty.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
<ul>
<li><a href="https://www.queerty.com/wp/wp-login.php?redirect_to=%2F%2Fwww.queerty.com%2Fwatch-chatted-james-bland-creator-director-star-giants-series-20210216" id="menu-login">Log in</a></li>
<li><a href="https://www.queerty.com/wp/wp-login.php?action=register" id="menu-register">Register</a></li>
</ul>
<div class="menu-now-on-queerty-container"><ul id="menu-now-on-queerty" class="menu"><li id="menu-item-574437" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-574437"><a href="https://www.queerty.com/Queerties2021/">The Queerties 2021</a></li>
<li id="menu-item-441445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441445"><a href="https://www.queerty.com/life">Life</a></li>
<li id="menu-item-441443" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-441443"><a href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li id="menu-item-441446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441446"><a href="https://www.queerty.com/politics">Politics</a></li>
<li id="menu-item-441444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441444"><a href="https://www.queerty.com/goods">Goods</a></li>
<li id="menu-item-574436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574436"><a href="https://www.queerty.com/podcast">Queerty Podcast</a></li>
<li id="menu-item-420168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-420168"><a href="//www.queerty.com/queerty-tv/">Video (Queerty TV)</a></li>
<li id="menu-item-504333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-504333"><a href="https://www.queerty.com/ever-after">Queerty Ever After</a></li>
<li id="menu-item-420166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-420166"><a href="https://www.queerty.com/dragaholic">Dragaholic</a></li>
<li id="menu-item-469065" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-469065"><a href="https://www.queerty.com/prepared">Prepared</a></li>
<li id="menu-item-573116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-573116"><a href="https://www.queerty.com/health">Health</a></li>
</ul></div>
<ul>
<li><a href="https://www.lgbtqnation.com/">LGBTQ Nation News</a></li>
<li><a href="https://www.gaycities.com/">GayCities Travel Guides</a></li>
</ul>
<ul>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
</ul>
</nav>
<div class="queerty-menu-fade-screen"></div>
<div id="content" class="site-content"> <div class="single-wrapper">
<div id="primary" class="content-area single-article ">
<main id="main" class="site-main" role="main">
<article id="post-574931" class="post-574931 post type-post status-publish format-standard has-post-thumbnail hentry category-ad-friendly category-entertainment category-queerty tag-2021-queerties tag-giants tag-giants-the-series tag-james-bland">
<header class="entry-header">
<div class="kicker ">#Queerties</div> <h1 class="entry-title"><a href="https://www.queerty.com/watch-chatted-james-bland-creator-director-star-giants-series-20210216"><span itemprop="headline">WATCH: We chatted with James Bland, creator, director, and star of &#8216;Giants: The Series&#8217;</span></a></h1>
<div class="entry-meta">
<span class="byline"> By <span itemprop="author"> <span class="author vcard">Editors</span></span></span> <time class="posted-on" itemprop="datePublished" datetime="2021-02-16T17:15:02-05:00">9 minutes ago</time> </div>
</header>
<div class="entry-content" itemprop="articleBody">

<div id="div-gpt-ad-textpromo1">
<script type='text/javascript'>
                    		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-textpromo1'); });
                    		</script>
</div>
<p><img loading="lazy" class="alignnone size-full wp-image-574932" src="https://queerty-prodweb.s3.amazonaws.com/2021/01/Screen-Shot-2021-01-16-at-10.35.46-AM.png" alt="" width="2736" height="1536" srcset="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/01/Screen-Shot-2021-01-16-at-10.35.46-AM.png?&amp;auto=format&amp;auto=compress&amp;w=2736 2736w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/01/Screen-Shot-2021-01-16-at-10.35.46-AM.png?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/01/Screen-Shot-2021-01-16-at-10.35.46-AM.png?&amp;auto=format&amp;auto=compress&amp;w=670 670w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/01/Screen-Shot-2021-01-16-at-10.35.46-AM.png?&amp;auto=format&amp;auto=compress&amp;w=1536 1536w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/01/Screen-Shot-2021-01-16-at-10.35.46-AM.png?&amp;auto=format&amp;auto=compress&amp;w=2048 2048w" sizes="(max-width: 2736px) 100vw, 2736px"></p>
<p>“I felt like, most of my life, I hadn’t seen myself on screen. I wanted desperately to, you know, see myself.”</p>
<p>James Bland wears many hats as the creator, director, writer, and star of Emmy-award winning Giants: The Series, now available on BET Plus. We chatted with the multi-hyphenate about how he arrived in Hollywood and set out to see himself on screen.</p>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="James Bland, The #Queerties INNOVATOR AWARD nominee" width="872" height="491" src="https://www.youtube.com/embed/UY4evqkmLrg?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>The INNOVATOR AWARD, at the Queerties celebrates talented individuals are multi-hyphenates who have worn many hats, and strived to evolve and innovate, to make their dreams a reality. <a href="https://www.queerty.com/Queerties2021/vote-2108" target="_blank" rel="noopener">Vote for James and all your LGBTQ favorites</a> once a day, per device, until voting closes on February 16th. Happy voting! 🏆</p><div class="ad-300 inline" id="div-gpt-ad-inarticle1"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle1"); });</script></div>

<div id="div-gpt-ad-textpromo2">
<script type='text/javascript'>
                    		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-textpromo2'); });
                    		</script>
</div>
</div>
<footer class="entry-footer">
<span class="tags-links"><a href="https://www.queerty.com/entertainment" rel="category">Entertainment</a> <a href="https://www.queerty.com/tag/2021-queerties" rel="tag">2021 Queerties</a> <a href="https://www.queerty.com/tag/giants" rel="tag">giants</a> <a href="https://www.queerty.com/tag/giants-the-series" rel="tag">giants the series</a> <a href="https://www.queerty.com/tag/james-bland" rel="tag">james bland</a></span><div class="comments-link-area"><a href="https://www.queerty.com/watch-chatted-james-bland-creator-director-star-giants-series-20210216#respond"><span class="comments-link">Add a comment</span></a></div> </footer>
</article>
</main>
<div class="article-email-prompt-red" id="queerty-article-email-prompt">
<h3><span class="asterisk"> </span>Get Queerty Daily</h3>
Subscribe to Queerty for a daily dose of #entertainment #2021queerties #giants stories and more
<form action="//queerty.us1.list-manage.com/subscribe/post?u=ecab442566f15d8d4dcf64b0d&amp;id=221c27272a" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank">
<input type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="Your email" autocomplete="email">
<input type="hidden" name="group[5437][16]" value="1">
<input type="hidden" value="2" name="group[5409][2]" id="mce-group[5409]-5409-0">
<input type="hidden" value="1" name="group[5409][1]" id="mce-group[5409]-5409-1">
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ecab442566f15d8d4dcf64b0d_221c27272a" tabindex="-1" value=""></div>
<input type="submit" value="Subscribe" name="submit" id="mc-embedded-subscribe" class="button">
</form>
</div>
<script>
!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>
<script id="63359461e10348e1843f01215f3c4ead">
  cnxps.cmd.push(function () {
    cnxps({
      playerId: "461d6acb-cbff-447a-b4e7-ee9ee29c9631"
    }).render("63359461e10348e1843f01215f3c4ead");
  });
</script>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Add your Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/watch-chatted-james-bland-creator-director-star-giants-series-20210216#respond" style="display:none;">Cancel reply</a></small></h3><p class="nocomments">Please <a href="https://www.queerty.com/wp/wp-login.php?redirect_to=https%3A%2F%2Fwww.queerty.com%2Fwatch-chatted-james-bland-creator-director-star-giants-series-20210216">log in</a> to add your comment<br>Need an account? <strong><a href="https://www.queerty.com/wp/wp-login.php?action=register">Register</a></strong> *It's free and easy.</p> </div>
</div>

<div id="div-gpt-ad-textpromo3">
<script type='text/javascript'>
                    		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-textpromo3'); });
                    		</script>
</div>
</div>
<script type="text/javascript" async="async" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-58640af04b28c97d"></script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.queerty.com\/watch-chatted-james-bland-creator-director-star-giants-series-20210216"},"headline":"WATCH: We chatted with James Bland, creator, director, and star of &#8216;Giants: The Series&#8217;","url":"https:\/\/www.queerty.com\/watch-chatted-james-bland-creator-director-star-giants-series-20210216","datePublished":"2021-02-16T17:15:02-05:00","dateModified":"2021-02-16T17:15:02-05:00","description":"\"I felt like, most of my life, I hadn't seen myself on screen. I wanted desperately to, you know, see myself.\"\u00a0","thumbnailUrl":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/01\/Screen-Shot-2021-01-16-at-10.35.46-AM-307x289.png","image":{"@type":"ImageObject","url":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/01\/Screen-Shot-2021-01-16-at-10.35.46-AM-307x289.png","height":670,"width":376},"creator":"Editors","author":{"@type":"Person","name":"Editors"},"articleSection":"Entertainment","keywords":["Ad Friendly","Queerty","2021 Queerties","giants","giants the series","james bland","[ Has: YouTube embed ]","[ Word count: <300 ]"],"publisher":{"@type":"NewsMediaOrganization","name":"Queerty","url":"https:\/\/www.queerty.com\/","logo":{"@type":"ImageObject","url":"https:\/\/www.queerty.com\/assets\/q-2017\/queerty-logo-225x60.png","height":"60","width":"225"},"address":{"@type":"PostalAddress","streetAddress":"584 Castro St. #623","addressLocality":"San Francisco","addressRegion":"CA","postalCode":"94114","addressCountry":"USA"},"sameAs":["https:\/\/en.wikipedia.org\/wiki\/Queerty","https:\/\/www.facebook.com\/queerty","https:\/\/www.twitter.com\/queerty","https:\/\/www.instagram.com\/queerty","https:\/\/www.youtube.com\/user\/queertyTV"]}}</script>
<aside id="secondary" class="article-sidebar" role="complementary">
<div class="sidebar-ad-1" id="div-gpt-ad-box1">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box1'); });
			</script>
</div>
<div id="civsci-id-1487938606" data-civicscience-widget="7e525d9d-2b18-3944-8162-270cab0eef2f"></div>
<script type="text/javascript" async src="https://www.civicscience.com/jspoll/4/civicscience-widget.js"></script>
<section class="sidebar-related">
<h3 class="category-heading">
More in Entertainment </h3>
<div class="cards-list">
<article id="post-576105" class="card card-small ">
<a href="https://www.queerty.com/hallmark-homophobes-gay-way-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/christmas-house-brad-jonathan.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Hallmark to homophobes: More gay is on the way">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Signed & Sealed</div>
<h2 class="entry-title">Hallmark to homophobes: More gay is on the way</h2> <div class="entry-meta">
<a href="https://www.queerty.com/hallmark-homophobes-gay-way-20210216" rel="bookmark"><time class="entry-date published updated" datetime="2021-02-16T16:52:06-05:00">32 minutes ago</time></a> </div>
</section>
</a>
</article>
<article id="post-576133" class="card card-small ">
<a href="https://www.queerty.com/tone-deaf-american-idol-audition-something-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/mario-adrion-american-idol-main-03152021.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="This tone deaf &#8216;American Idol&#8217; audition is&#8230;something">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Exit stage left</div>
<h2 class="entry-title">This tone deaf &#8216;American Idol&#8217; audition is&#8230;something</h2> <div class="entry-meta">
<a href="https://www.queerty.com/tone-deaf-american-idol-audition-something-20210216" rel="bookmark"><time class="entry-date published updated" datetime="2021-02-16T14:04:35-05:00">3 hours ago</time></a> </div>
</section>
</a>
</article>
<article id="post-576119" class="card card-small ">
<a href="https://www.queerty.com/watch-black-church-uncovers-secret-history-disco-amid-homophobia-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/sylvester-black-church.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="WATCH: &#8216;The Black Church&#8217; uncovers the secret history of disco amid homophobia">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Exclusive</div>
<h2 class="entry-title">WATCH: &#8216;The Black Church&#8217; uncovers the secret history of disco amid homophobia</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-576114" class="card card-small ">
<a href="https://www.queerty.com/love-victor-star-reveals-homophobic-bullying-shows-premiere-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/love-victor.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="&#8216;Love, Victor&#8217; star reveals homophobic bullying after the show&#8217;s premiere">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Aspects of 'Love'</div>
<h2 class="entry-title">&#8216;Love, Victor&#8217; star reveals homophobic bullying after the show&#8217;s premiere</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div>
</section>
<style>

.queerties-sidebar {
	background: url(/assets/promos/queerties2021/queerties-2021-backer.jpg) no-repeat;
	text-align: center;
	padding-top: 15px;
	width: 100%;
	max-width: 300px;
	margin-left: auto;
	margin-right: auto;
	background-size: cover
}

.queerties-sidebar .sidebar-logo {
	margin-bottom: 5px;
	width: 80%;
	margin-left: auto;
	margin-right: auto;
	height: auto
}

.queerties-sidebar #div-gpt-ad-sponsorship2 {
	margin: 10px 0
}

.queerties-sidebar .sidebar-title {
	width: 96%;
	border-radius: 4px;
	overflow: hidden;
	float: left;
	margin: 2% 1.5%;
	text-transform: uppercase;
	background: linear-gradient(rgba(226, 72, 37, 0.5), rgba(226, 72, 37, 0.5));
	margin-bottom: 0;
	font-family: "balboa", sans-serif;
	padding: 8px 0
}

.queerties-sidebar .sidebar-title a {
	text-decoration: none
}

.queerties-sidebar .sidebar-title h1 {
	margin: -4px 0 0 0;
	color: #fff;
	font-family: "balboa", sans-serif
}

.queerties-sidebar form {
	margin: 0;
	padding: 10px 0;
	color: #000
}

.queerties-sidebar form::after {
	clear: both;
	content: "";
	display: block
}

.queerties-sidebar h4 {
	color: #000;
	margin: 0 auto 5px
}

.queerties-sidebar .sidebar-option {
	width: 96%;
	height: 50px;
	border-radius: 4px;
	overflow: hidden;
	float: left;
	margin: 2% 1.5%;
	position: relative;
	cursor: pointer
}

.queerties-sidebar .sidebar-option .option_text {
	position: absolute;
	width: 100%;
	height: 100%;
	top: 0;
	left: 0;
	right: 0;
	text-align: right;
	text-transform: uppercase;
	color: #fff;
	font-weight: bold;
	background: url("https://dxepcgbfdydik.cloudfront.net/assets/black_transparent.png") repeat;
	font-size: 16px;
	line-height: 50px;
	padding-right: 10px;
	display: block
}

.queerties-sidebar .sidebar-option span {
	border: 1px solid #db5130;
	border-radius: 4px;
	height: 16px;
	width: 16px;
	display: inline-block;
	position: absolute;
	left: 6px;
	top: 15px;
	background-color: #fff;
	z-index: 100
}

.queerties-sidebar .sidebar-option:hover {
	border-color: #db5130;
	color: #db5130
}

.queerties-sidebar .sidebar-option:hover .option_text {
	display: block;
	color: #db5130
}

.queerties-sidebar .sidebar-option:hover span {
	background-color: #db5130
}

.queerties-sidebar .sidebar-image-wrap {
	width: 100%;
	margin-top: -30%
}

.queerties-sidebar .sidebar-image-wrap img {
	width: 100%;
	height: auto
}
</style><section class="queerties-sidebar">
<a href="/Queerties2021/"><img class="sidebar-logo" src="/assets/promos/queerties2021/queerties-logo-2021-white.png" alt="The Queerties" width="260" /></a>
<div id='div-gpt-ad-sponsorship2'>
<script type="67250f9f639004e56c841d40-text/javascript">
			googletag.cmd.push(function() { googletag.display('div-gpt-ad-sponsorship2'); });
			</script>
</div>
<div class="sidebar-title">
<a href="/Queerties2021/vote-2113">
<h1>Studio Movie </h1>
</a>
</div>
<form id='poll' action="/promos/queerties-2021/poll.php" method="post" accept-charset="utf-8" class="clearfix ">
<input type="hidden" name="next_page" value="/Queerties2021/vote-2102">
<input type="hidden" name="multi_poll" value=1>
<input type="hidden" name="source" value="sidebar">
<input type="hidden" name="c" value="56781b22">
<div class="sidebar-option" id="3873">
<label for="poll2113_3873">
<div class="sidebar-image-wrap" style="margin-top:0;">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/09/Boys-in-the-Band-cast-Parsons-Rannells-Jesus-Washington-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=280&h=55" height=55 width=280 align=absmiddle> </div>
<span> </span>
<div class="option_text ">The Boys in the Band</div>
</label>
</div>
<div class="sidebar-option" id="3869">
<label for="poll2113_3869">
<div class="sidebar-image-wrap" style="margin-top:0;">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/11/DATING-AMBER-12.jpeg?&auto=format&auto=compress&crop=faces&fit=crop&w=280&h=55" height=55 width=280 align=absmiddle> </div>
<span> </span>
<div class="option_text ">Dating Amber</div>
</label>
</div>
<div class="sidebar-option" id="3870">
<label for="poll2113_3870">
<div class="sidebar-image-wrap" style="margin-top:0;">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/10/Friendsgiving_14.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=280&h=55" height=55 width=280 align=absmiddle> </div>
<span> </span>
<div class="option_text ">Friendsgiving</div>
</label>
</div>
<div class="sidebar-option" id="3874">
<label for="poll2113_3874">
<div class="sidebar-image-wrap" style="margin-top:0;">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/04/THOI_Unit_04613r-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=280&h=55" height=55 width=280 align=absmiddle> </div>
<span> </span>
<div class="option_text ">The Half of it</div>
</label>
</div>
<div class="sidebar-option" id="3868">
<label for="poll2113_3868">
<div class="sidebar-image-wrap" style="margin-top:0;">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/08/ammonite.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=280&h=55" height=55 width=280 align=absmiddle> </div>
<span> </span>
<div class="option_text ">Ammonite</div>
</label>
</div>
<div class="sidebar-option" id="3875">
<label for="poll2113_3875">
<div class="sidebar-image-wrap" style="margin-top:0;">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/06/TOG_09480_2019-06-29_AS_RC-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=280&h=55" height=55 width=280 align=absmiddle> </div>
<span> </span>
<div class="option_text ">The Old Guard</div>
</label>
</div>
<div class="sidebar-option" id="3877">
<label for="poll2113_3877">
<div class="sidebar-image-wrap" style="margin-top:0;">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/11/Uncle_Frank_BH_00775R_rgb-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=280&h=55" height=55 width=280 align=absmiddle> </div>
<span> </span>
<div class="option_text ">Uncle Frank</div>
</label>
</div>
<div class="sidebar-option" id="3876">
<label for="poll2113_3876">
<div class="sidebar-image-wrap" style="margin-top:0;">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/10/TP-22436RC-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=280&h=55" height=55 width=280 align=absmiddle> </div>
<span> </span>
<div class="option_text ">The Prom</div>
</label>
</div>
<div class="sidebar-option" id="3871">
<label for="poll2113_3871">
<div class="sidebar-image-wrap" style="margin-top:0;">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/11/df-00822rt-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=280&h=55" height=55 width=280 align=absmiddle> </div>
<span> </span>
<div class="option_text ">Happiest Season</div>
</label>
</div>
<div class="sidebar-option" id="3872">
<label for="poll2113_3872">
<div class="sidebar-image-wrap" style="margin-top:0;">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/12/ma-rainey.png?&auto=format&auto=compress&crop=faces&fit=crop&w=280&h=55" height=55 width=280 align=absmiddle> </div>
<span> </span>
<div class="option_text ">Ma Rainey's Black Bottom</div>
</label>
</div>
</form>
</section>
<script>
(function( $ ) {
	$('.sidebar-option').bind('click tap', function(e){
		var voted = false;
		voted = false;
		if (voted!=true && !$(e.target).hasClass('more_info')) {
			var input = $("<input>")
	               .attr("type", "hidden")
	               .attr("name", "poll_id_2113").val($(this).attr("id") );
		    $('form#poll').append($(input));
			$('form#poll').submit();
		}
	});
})( jQuery );
</script> <div class="sidebar-ad-2" id="div-gpt-ad-box2">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box2'); });
			</script>
</div>
<br>
</aside>
<br clear=all>
<div class="single-bottom-articles">
<h3>
Latest on Queerty </h3>
<div class="single-bottom-articles-slider slider slick-slider">
<div><article id="post-576105" class="card card-small ">
<a href="https://www.queerty.com/hallmark-homophobes-gay-way-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/christmas-house-brad-jonathan.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Hallmark to homophobes: More gay is on the way">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Signed & Sealed</div>
<h2 class="entry-title">Hallmark to homophobes: More gay is on the way</h2> <div class="entry-meta">
<a href="https://www.queerty.com/hallmark-homophobes-gay-way-20210216" rel="bookmark"><time class="entry-date published updated" datetime="2021-02-16T16:52:06-05:00">32 minutes ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-576154" class="card card-small ">
<a href="https://www.queerty.com/eric-trump-politely-informed-father-loser-writing-another-embarrassing-tweet-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/eric-trump-sean-hannity.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Eric Trump politely informed that his father is a loser after writing another embarrassing tweet">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">fact check</div>
<h2 class="entry-title">Eric Trump politely informed that his father is a loser after writing another embarrassing tweet</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-576140" class="card card-small ">
<a href="https://www.queerty.com/uh-oh-lindsey-graham-trouble-like-big-trouble-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/lindsey-graham-fox-screenshot-221.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Uh-oh! Lindsey Graham is in trouble&#8230; Like, BIG trouble">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">criminal investigation</div>
<h2 class="entry-title">Uh-oh! Lindsey Graham is in trouble&#8230; Like, BIG trouble</h2> <div class="entry-meta">
<a href="https://www.queerty.com/uh-oh-lindsey-graham-trouble-like-big-trouble-20210216" rel="bookmark"><time class="entry-date published updated" datetime="2021-02-16T14:59:15-05:00">2 hours ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-576146" class="card card-small ">
<a href="https://www.queerty.com/Queerties2021/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=Last+call%21+Here%26%238217%3Bs+your+final+chance+to+vote+in+the+2021+Queerties.">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/Screen-Shot-2021-02-16-at-11.07.05-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Last call! Here&#8217;s your final chance to vote in the 2021 Queerties.">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">#Queerties</div>
<h2 class="entry-title">Last call! Here&#8217;s your final chance to vote in the 2021 Queerties.</h2> <div class="entry-meta">
<a href="https://www.queerty.com/last-call-heres-final-chance-vote-2021-queerties-20210216" rel="bookmark"><time class="entry-date published updated" datetime="2021-02-16T14:09:35-05:00">3 hours ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-576133" class="card card-small ">
<a href="https://www.queerty.com/tone-deaf-american-idol-audition-something-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/mario-adrion-american-idol-main-03152021.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="This tone deaf &#8216;American Idol&#8217; audition is&#8230;something">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Exit stage left</div>
<h2 class="entry-title">This tone deaf &#8216;American Idol&#8217; audition is&#8230;something</h2> <div class="entry-meta">
<a href="https://www.queerty.com/tone-deaf-american-idol-audition-something-20210216" rel="bookmark"><time class="entry-date published updated" datetime="2021-02-16T14:04:35-05:00">3 hours ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-576106" class="card card-small ">
<a href="https://www.queerty.com/melania-launches-weird-new-twitter-page-respond-negative-reports-spa-treatments-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/melania-shutterstock-21621-e1613498472620.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Melania launches weird new Twitter page to respond to negative reports about her spa treatments">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<h2 class="entry-title">Melania launches weird new Twitter page to respond to negative reports about her spa treatments</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-576119" class="card card-small ">
<a href="https://www.queerty.com/watch-black-church-uncovers-secret-history-disco-amid-homophobia-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/sylvester-black-church.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="WATCH: &#8216;The Black Church&#8217; uncovers the secret history of disco amid homophobia">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Exclusive</div>
<h2 class="entry-title">WATCH: &#8216;The Black Church&#8217; uncovers the secret history of disco amid homophobia</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-576114" class="card card-small ">
<a href="https://www.queerty.com/love-victor-star-reveals-homophobic-bullying-shows-premiere-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/love-victor.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="&#8216;Love, Victor&#8217; star reveals homophobic bullying after the show&#8217;s premiere">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Aspects of 'Love'</div>
<h2 class="entry-title">&#8216;Love, Victor&#8217; star reveals homophobic bullying after the show&#8217;s premiere</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-576110" class="card card-small ">
<a href="https://www.queerty.com/rare-180-conservative-politician-blames-shocking-antigay-past-intellectual-laziness-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/sir-desmond-swayne.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="In rare 180, conservative politician blames &#8220;shocking&#8221; antigay past on &#8220;intellectual laziness&#8221;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">About face</div>
<h2 class="entry-title">In rare 180, conservative politician blames &#8220;shocking&#8221; antigay past on &#8220;intellectual laziness&#8221;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-574775" class="card card-small queerty-interview-link">
<a href="https://www.queerty.com/supernovas-harry-mcqueen-addresses-queer-casting-quandary-writing-two-men-love-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/SN-07814-670x447-1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="&#8216;Supernova&#8217;s Harry McQueen addresses queer casting quandary and writing for two men in love">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Stellar</div>
<h2 class="entry-title">&#8216;Supernova&#8217;s Harry McQueen addresses queer casting quandary and writing for two men in love</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-576099" class="card card-small ">
<a href="https://www.queerty.com/politician-attacked-sharing-photo-boyfriend-valentines-day-gets-last-laugh-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/Screen-Shot-2021-02-16-at-10.38.17-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Politician attacked for sharing photo of his boyfriend on Valentine&#8217;s Day gets the last laugh">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">love is love</div>
<div class="card-commentcount">12 comments</div><h2 class="entry-title">Politician attacked for sharing photo of his boyfriend on Valentine&#8217;s Day gets the last laugh</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-576091" class="card card-small ">
<a href="https://www.queerty.com/thank-president-trump-say-lgbtq-republicans-presidents-day-video-20210216">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/outspoken_presidents_day_video.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="‘Thank you, President Trump’ say LGBTQ Republicans in Presidents Day video">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">No words</div>
<div class="card-commentcount">18 comments</div><h2 class="entry-title">‘Thank you, President Trump’ say LGBTQ Republicans in Presidents Day video</h2> <div class="entry-meta">
<a href="https://www.queerty.com/thank-president-trump-say-lgbtq-republicans-presidents-day-video-20210216" rel="bookmark"><time class="entry-date published updated" datetime="2021-02-16T09:20:58-05:00"> Today at 9:02am</time></a> </div>
</section>
</a>
</article>
</div>
</div>
</div></div>
</div>
<div class="site-footer-holder">
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="footer-brand">
<span class="asterisk"> </span> Free of an agenda (except that gay one)
</div>
<div class="tags-links">
<a href="//www.queerty.com/tag/adam-rippon">Adam Rippon</a> <a href="//www.queerty.com/tag/freddie-mercury">Freddie Mercury</a> <a href="//www.queerty.com/tag/gus-kenworthy">Gus Kenworthy</a> <a href="//www.queerty.com/tag/nick-jonas">Nick Jonas</a> <a href="//www.queerty.com/tag/nico-tortorella">Nico Tortorella</a> <a href="//www.queerty.com/tag/pietro-boselli">Pietro Boselli</a> <a href="//www.queerty.com/tag/ricky-martin">Ricky Martin</a> <a href="//www.queerty.com/tag/russell-tovey">Russell Tovey</a> <a href="//www.queerty.com/tag/zac-efron">Zac Efron</a> <div class="second-row">
<a href="//www.queerty.com/tag/donald-trump">Donald Trump</a> <a href="//www.queerty.com/tag/homophobia">Homophobia</a> <a href="//www.queerty.com/tag/coming-out">Coming Out</a> <a href="//www.queerty.com/tag/rupaul's-drag-race">Rupaul's Drag Race</a> <a href="//www.queerty.com/tag/scandal">Scandal</a> <a href="//www.queerty.com/tag/religion">Religion</a> <a href="//www.queerty.com/tag/relationships">Relationships</a> <a href="//www.queerty.com/tag/grindr">Grindr</a>
</div>
</div>
<div class="footer-links">
<ul class="main" id="footer-company-links">
<li><a href="http://www.q.digital"><img src="/assets/q-digital-blue-90x37.png" alt="Q.digital" width="90"></a></li>
<li><b>A Q.Digital Company</b></li>
<li>&copy; 2021 Queerty, Inc.</li>
<li><a href="http://www.q.digital">Advertise With Us</a></li>
</ul>
<ul class="main" id="footer-contact-links">
<li><h3>Contact</h3></li>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
<li><a href="https://www.queerty.com/queertys-comment-policy">Comments Policy</a>
<li><a href="https://www.queerty.com/privacy-policy">Privacy Statement</a>
<li><a href="https://www.queerty.com/terms-of-use">Terms of Use</a>
<li><a id="ccpaOptOut">Do Not Sell My Personal Information</a>
</ul>
<ul class="main" id="footer-follow-links">
<li><h3>Follow</h3></li>
<li><a href="https://linktr.ee/queertypodcast">Podcast</a></li>
<li><a href="https://www.facebook.com/Queerty/">Facebook</a></li>
<li><a href="https://www.twitter.com/Queerty/">Twitter</a></li>
<li><a href="https://www.instagram.com/Queerty/">Instagram</a></li>
<li><a href="https://www.youtube.com/user/QueertyTV/">YouTube</a></li>
</ul>
<ul class="main double" id="footer-gaycities-links">
<li><h3>GayCities: Your Gay Travel Guide:</h3></li>
<li><a href="https://newyork.gaycities.com/">New York</a></li>
<li><a href="https://london.gaycities.com/">London</a></li>
<li><a href="https://sanfrancisco.gaycities.com/">San Francisco</a></li>
<li><a href="https://chicago.gaycities.com/">Chicago</a></li>
<li><a href="https://losangeles.gaycities.com/">Los Angeles</a></li>
<li><a href="https://washingtondc.gaycities.com/">Washington DC</a></li>
<li><a href="https://dallas.gaycities.com/">Dallas</a></li>
<li><a href="https://saskatoon.gaycities.com/">Gay Saskatoon</a></li>
<li><a href="https://www.gaycities.com/places/"><b>See all 230+ cities...</b></a></li>
</ul>
</div>
</footer>
</div>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "32666898" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=32666898&cv=2.0&cj=1" alt="Comscore Measurement" />
</noscript>

<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '686853021424163');
  fbq('track', 'PageView');
</script>
<noscript><img height='1' width='1' style='display:none'
  src='https://www.facebook.com/tr?id=686853021424163&ev=PageView&noscript=1'
/></noscript>

<script>
  fbq('track', 'ViewContent');
</script>
<script>
	window.dataLayer = window.dataLayer || []
	dataLayer.push({
	   'event': 'Page Details',
	   'pageType': 'article',
	   'pageCategory': 'entertainment'
	   
	});
	</script>
<script type="text/javascript" src="//b-code.liadm.com/a-04zq.min.js" async="true" charset="utf-8"></script><script src="//d2wy8f7a9ursnm.cloudfront.net/v7/bugsnag.min.js"></script><script type="text/javascript">var algolia = {"debug":false,"application_id":"6S92GABH7H","search_api_key":"cfd5e12cdf4a6106712391cbcf54f087","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"queerty_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true},{"index_id":"terms_category","index_name":"queerty_terms_category","label":"Categories","admin_name":"Categories","position":20,"max_suggestions":3,"tmpl_suggestion":"autocomplete-term-suggestion","enabled":true},{"index_id":"terms_post_tag","index_name":"queerty_terms_post_tag","label":"Tags","admin_name":"Tags","position":20,"max_suggestions":3,"tmpl_suggestion":"autocomplete-term-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"queerty_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]},"terms_category":{"name":"queerty_terms_category","id":"terms_category","enabled":true,"replicas":[]},"terms_post_tag":{"name":"queerty_terms_post_tag","id":"terms_post_tag","enabled":true,"replicas":[]}}};</script><script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/comment-reply.min.js?ver=5.6' id='comment-reply-js'></script>
<script type='text/javascript' async src='https://platform.twitter.com/widgets.js?ver=20161216' id='twitter-js-js'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js?ver=5.6' id='slick-js'></script>
<script type='text/javascript' async src='https://www.queerty.com/content/themes/queerty_2017/js/min/queerty-nosticky-min.js?ver=20200120a' id='queerty_2017-main-js'></script>
<script type='text/javascript' async src='https://q-digital.videoplayerhub.com/galleryplayer.js?ver=20201101' id='bt-js'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/wp-embed.min.js?ver=5.6' id='wp-embed-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.6' async='async' id='remote_sdk-js'></script>
<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":574931,"object_key":"post","object_type":"post","term_ids":[69394,2215,310,88142,63203,88331,87586]};</script>
<script data-cfasync="false" id="parsely-cfg" data-parsely-site="queerty.com" src="https://cdn.parsely.com/keys/queerty.com/p.js"></script>
</body>
</html>