<!DOCTYPE html>
<html>
<head>
<link rel="stylesheet" href="https://use.typekit.net/cdb4vyt.css">
<meta name="viewport" content="width=device-width, initial-scale=1">

<script type="text/javascript">
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function(){
       var gads = document.createElement("script");
        gads.async = true;
        gads.type = "text/javascript";
        var useSSL = "https:" == document.location.protocol;
        gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
        var node = document.getElementsByTagName("script")[0];
        node.parentNode.insertBefore(gads, node);
    })();
</script>

<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.2634970.min.js?cachebuster=1';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      // Return control to GPT if the AdBridg library fails to load.
      adb.onerror = function() {
        console.log('Fallback: ')
        if (AdBridg.exists) { return; }
        document.createElement('IMG').src = '//adspsp.com/pt/2634970/3/1/?e=0';
        var dq = [], es;
        dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
        AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
        AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
        AdBridg.destroySlots = function(s) { return googletag.destroySlots(s); }
        AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
        AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
        AdBridg.render = function() { }
        AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
        AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
        AdBridg.useSizeMapping = function() { }
        AdBridg.cmd.push = function(f) {
          if (typeof(f)=='object') {
            var api_fallback = function(o) {
              googletag.cmd.push(function() {
                var u=AdBridg.defineSlot(o.gpt_path,o.size||[],o.dom_id);
                if(o.size_map) {
                  var m = googletag.sizeMapping();
                  for(var oi=0;oi<o.size_map.length;oi++){m=m.addSize(o.size_map[oi].viewport, o.size_map[oi].sizes);}
                  u.defineSizeMapping(m.build());
                }
                if(o.events) {
                  if(o.events["gpt.defined"]){o.events["gpt.defined"](u);}
                  var fl = function(a,b){if(o.events[a]){googletag.pubads().addEventListener(b,function(e){if(e.slot===u){o.events[a](u,e)}})}}
                  fl("gpt.rendered",'slotRenderEnded');
                  fl("gpt.viewed",'impressionViewable');
                  fl("gpt.visibilityChanged",'slotVisibilityChanged');
                }
              });
            }
            if(f.length){for(var i=0;i<f.length;++i){api_fallback(f[i]);}}else{api_fallback(f);}
            f=function(){AdBridg.serve()}
          }
          return googletag.cmd.push(f);
        }
        while (AdBridg.cmd.length) { AdBridg.cmd.push(AdBridg.cmd.shift()); }
      }
  })();
</script>
<script>
AdBridg.cmd.push(function () {
	googletag.pubads().collapseEmptyDivs();
	googletag.pubads().setTargeting('articleid', ['556938']);
	googletag.pubads().setTargeting('Tag', ['articlepage','after forever','poz roz','shellys','sordid lives','the normal heart','entertainment','feature','queerty']);
	googletag.pubads().setTargeting('UGC', ['no']);
	
  });
</script>
<script>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</script><title>What to Watch: Leslie Jordan live, love after death, and a proud farewell to Larry Kramer / Queerty</title>
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Feed" href="https://www.queerty.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Comments Feed" href="https://www.queerty.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; What to Watch: Leslie Jordan live, love after death, and a proud farewell to Larry Kramer Comments Feed" href="https://www.queerty.com/watch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528/feed" />
<link rel='stylesheet' id='queerty_2017-style-css' href='https://www.queerty.com/content/themes/queerty_2017/style.css?ver=20200525' type='text/css' media='all' />
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' data-cfasync="false" id="omapi-script" async="async" src='https://a.omappapi.com/app/js/api.min.js'></script>
<link rel='prev' title='Olympian Guillaume Cizeron comes out by introducing his adorable boyfriend' href='https://www.queerty.com/olympian-guillaume-cizeron-comes-introducing-adorable-boyfriend-20200528' />
<link rel='next' title='GOP candidate stands behind deleted homophobic tweets, says he has tons of gay friends' href='https://www.queerty.com/gop-candidate-stands-behind-deleted-homophobic-tweets-says-tons-gay-friends-20200528' />
<link rel="canonical" href="https://www.queerty.com/watch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528" />
<meta property="og:site_name" content="Queerty" /> <meta name="description" content="Whatever your entertainment needs, we got your back (and hopefully your mind) with Queerty’s weekly “Culture Club” column with some of the highlights of new releases, streaming shows, classics worth revisiting, and what to drink while you watch. The Classy: Sordid Lives: Live https://www.youtube.com/watch?v=TwBV8LYFzMg Writer/director Del Shores..." />
<meta property="og:description" content="Whatever your entertainment needs, we got your back (and hopefully your mind) with Queerty’s weekly “Culture Club” column with some of the highlights of new releases, streaming shows, classics worth revisiting, and what to drink while you watch. The Classy: Sordid Lives: Live https://www.youtube.com/watch?v=TwBV8LYFzMg Writer/director Del Shores...">
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.queerty.com/watch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528" />
<meta property="og:title" content="What to Watch: Leslie Jordan live, love after death, and a proud farewell to Larry Kramer" />
<meta property="og:image" content="https://queerty-prodweb.imgix.net/2020/05/normal-heart2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=1024&h=576" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta name="twitter:image" content="https://queerty-prodweb.imgix.net/2020/05/normal-heart2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=1024&h=576" />
<meta property="article:published_time" content="2020-05-28T13:18:06-04:00" />
<meta property="article:modified_time" content="2020-05-28T13:18:06-04:00" />
<meta name="twitter:url" content="https://www.queerty.com/watch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528" />
<meta name="twitter:title" content="What to Watch: Leslie Jordan live, love after death, and a proud farewell to Larry Kramer" />
<meta name="twitter:description" content="Whatever your entertainment needs, we got your back (and hopefully your mind) with Queerty’s weekly “Culture Club” column with some of the highlights of new releases, streaming shows, classics worth revisiting, and what to drink while you watch. The Classy: Sordid Lives: Live https://www.youtube.com/watch?v=TwBV8LYFzMg Writer/director Del Shores..." />
<meta name="news_keywords" content="after forever, poz roz, shelly's, Sordid Lives, the normal heart"><meta property="article:tags" content="after forever, poz roz, shelly's, Sordid Lives, the normal heart"><meta name="author" property="author" content="David Reddish" /><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://markedmeasure.com/v2/0/usuN3x8i68_Z8gwS4SdT8eDT_Ad8WacFr9oPLapk9ssVTVpLlBZxNg",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://markedmeasure.com/v2/0/ctcel1hVo5PTOjGzO9r_VCnB26nnPExye9f6GitMktQniZ1gg1xESEtPGMrBIdYwIzCUVC_",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script>

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@Queerty" />
<meta name="twitter:url" content="https://www.queerty.com/watch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528" />
<meta name="twitter:title" content="What to Watch: Leslie Jordan live, love after death, and a proud farewell to Larry Kramer" />
<meta name="twitter:description" content="Whatever your entertainment needs, we got your back (and hopefully your mind) with Queerty’s &hellip;" />
<meta name="twitter:image" content="https://queerty-prodweb.s3.amazonaws.com/2020/05/normal-heart2.jpg"><meta name="twitter:image:alt" content="">

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KRQPBJR');</script>

<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.queerty.com/wp");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '2269d7e8-77de-42f4-85e0-e16c905e72b8';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Queerty";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing!";
oneSignal_options['welcomeNotification']['url'] = "https://www.queerty.com/";
oneSignal_options['path'] = "https://www.queerty.com/content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.32a023df-3e37-4c19-843f-3978a63a946e";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = 'Queerty';
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = 'Titles of Breaking Stories Will Appear Here';
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = 'Queerty';
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
<script type="text/javascript">var algolia = {"debug":false,"application_id":"6S92GABH7H","search_api_key":"cfd5e12cdf4a6106712391cbcf54f087","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"queerty_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true},{"index_id":"terms_category","index_name":"queerty_terms_category","label":"Categories","admin_name":"Categories","position":20,"max_suggestions":3,"tmpl_suggestion":"autocomplete-term-suggestion","enabled":true},{"index_id":"terms_post_tag","index_name":"queerty_terms_post_tag","label":"Tags","admin_name":"Tags","position":20,"max_suggestions":3,"tmpl_suggestion":"autocomplete-term-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"queerty_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]},"terms_category":{"name":"queerty_terms_category","id":"terms_category","enabled":true,"replicas":[]},"terms_post_tag":{"name":"queerty_terms_post_tag","id":"terms_post_tag","enabled":true,"replicas":[]}}};</script><link rel="amphtml" href="https://www.queerty.com/watch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528/amp"> <meta property="fb:app_id" content="153299894806318" />
<meta name="theme-color" content="#f43700" />
<meta name="apple-itunes-app" content="app-id=1046987164">
<meta property="fb:pages" content="33720334139" />
<meta name="apple-mobile-web-app-title" content="Queerty*">
<meta name="application-name" content="Queerty*">
<meta name="msapplication-config" content="/assets/q-2017/favicons/browserconfig.xml?v=lkgzj5W5Gl">
<link rel="apple-touch-icon" sizes="180x180" href="/assets/q-2017/favicons/apple-touch-icon.png?v=lkgzj5W5Gl">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-32x32.png?v=lkgzj5W5Gl" sizes="32x32">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-16x16.png?v=lkgzj5W5Gl" sizes="16x16">
<link rel="manifest" href="/assets/q-2017/favicons/manifest.json?v=20180829">
<link rel="mask-icon" href="/assets/q-2017/favicons/safari-pinned-tab.svg?v=lkgzj5W5Gl" color="#5bbad5">
<link rel="shortcut icon" href="/assets/q-2017/favicons/favicon.ico?v=lkgzj5W5Gl">
<meta property="article:publisher" content="https://www.facebook.com/queerty" />
<style>
.ad-leaderboard-header {
	background-color:transparent !important;
	position:relative;
	margin-top:10px;
}
.queerty-header {
	padding-top:10px !important;
}
@media screen and (max-height: 769px) {
	.queerty-header {
    	min-height: 4.688rem;
    	padding: 10px 0 10px !important;
	}
}
</style>
</head>
<body class="post-template-default single single-post postid-556938 single-format-standard category-entertainment category-feature category-queerty">
<div id="top-of-page" style="display:none;"></div>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRQPBJR"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="div-gpt-ad-skin" style="height:1px;width:1px;">
<script>
	AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-skin'); });
	</script>
</div>
<div id="page" class="site">
<div class="ad-leaderboard-header" id="div-gpt-ad-leader1">
<script>
				AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-leader1'); });
				</script>
</div>

<div id="is-phone"></div>

<header id="masthead" class="queerty-header">
<div class="queerty-header-wrapper">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="js-header-main-menu" class="queerty-header-menu show">
<li class="nav-link "><a href="/">Latest</a>
</li>
<li class="nav-link navcat-life "><a class="scroll-on-page-link" data-scroll="category-life" href="https://www.queerty.com/life">Life</a></li>
<li class="nav-link navcat-entertainment selected"><a class="scroll-on-page-link" data-scroll="category-entertainment" href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li class="nav-link navcat-politics "><a class="scroll-on-page-link" data-scroll="category-politics" href="https://www.queerty.com/politics">Politics</a></li>
<li class="nav-link navcat-pride"><a href="/pride">Pride</a></li>
</ul>
</nav>
<div class="logo-area">
<a href="/" class="queerty-logo">
<img src="/assets/q-2017/queerty-logo.svg" width="275" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo">
<img src="/assets/promos/pride/2019/queerty-pride.svg" width="275" alt="Queerty* Pride" class="queerty-header-pride-logo" style="display:none;">
</a>
</div>
<nav id="right-navigation" class="secondary-navigation" role="navigation">
<ul id="js-header-secondary-menu" class="queerty-header-menu show">
<li class="nav-link">
<a href="https://www.facebook.com/Queerty/"><img src="/assets/icons/facebook-f-icon.svg" height="19" aria-hidden="true" alt="Facebook"></a>
</li>
<li class="nav-link">
<a href="https://twitter.com/queerty"><img src="/assets/icons/twitter-icon.svg" height="19" aria-hidden="true" alt="Twitter"></a>
</li>
<li class="nav-link">
<a href="https://www.instagram.com/queerty/"><img src="/assets/icons/instagram-icon.svg" height="19" aria-hidden="true" alt="Instagram"></a>
</li>
<li class="nav-link">
<a href="https://eepurl.com/RrfMf"><img src="/assets/icons/envelope-regular.svg" height="19" aria-hidden="true" alt="newsletter"></a>
</li>
<li class="nav-link queerty-menu-button" id="more-menu">
<img src="/assets/icons/bars-solid.svg" height="19" aria-hidden="true" title="Open Menu" alt="Menu">
</li>
</ul>
</nav>
</div>
</header>
<nav class="queerty-menu-content">
<div class="queerty-menu-close"><img src="/assets/icons/times-solid.svg" height="19" aria-hidden="true" title="Close Menu" alt="Close"></i></div>
<div class="queerty-menu-searchbox">
<form role="search" method="get" class="search-form" action="https://www.queerty.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
<ul>
<li><a href="https://www.queerty.com/wp/wp-login.php?redirect_to=%2F%2Fwww.queerty.com%2Fwatch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528" id="menu-login">Log in</a></li>
<li><a href="https://www.queerty.com/wp/wp-login.php?action=register" id="menu-register">Register</a></li>
</ul>
<div class="menu-now-on-queerty-container"><ul id="menu-now-on-queerty" class="menu"><li id="menu-item-441445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441445"><a href="https://www.queerty.com/life">Life</a></li>
<li id="menu-item-441443" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-441443"><a href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li id="menu-item-441446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441446"><a href="https://www.queerty.com/politics">Politics</a></li>
<li id="menu-item-441444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441444"><a href="https://www.queerty.com/goods">Goods</a></li>
<li id="menu-item-555321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-555321"><a href="https://www.queerty.com/pride">Pride</a></li>
<li id="menu-item-504333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-504333"><a href="https://www.queerty.com/ever-after">Queerty Ever After</a></li>
<li id="menu-item-420166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-420166"><a href="https://www.queerty.com/dragaholic">Dragaholic</a></li>
<li id="menu-item-469065" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-469065"><a href="https://www.queerty.com/prepared">Prepared</a></li>
<li id="menu-item-420168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-420168"><a href="//www.queerty.com/queerty-tv/">Video (Queerty TV)</a></li>
</ul></div>
<ul>
<li><a href="https://www.lgbtqnation.com/">LGBTQ Nation News</a></li>
<li><a href="https://www.gaycities.com/">GayCities Travel Guides</a></li>
</ul>
<ul>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
</ul>
</nav>
<div class="queerty-menu-fade-screen"></div>
<div id="content" class="site-content"> <div class="single-wrapper">
<div id="primary" class="content-area single-article ">
<main id="main" class="site-main" role="main">
<article id="post-556938" class="post-556938 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-feature category-queerty tag-after-forever tag-poz-roz tag-shellys tag-sordid-lives tag-the-normal-heart">
<header class="entry-header">
<div class="kicker ">Culture Club</div> <h1 class="entry-title"><a href="https://www.queerty.com/watch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528"><span itemprop="headline">What to Watch: Leslie Jordan live, love after death, and a proud farewell to Larry Kramer</span></a></h1>
<div class="entry-meta">
<span class="byline"> By <span itemprop="author"> <a href="https://www.queerty.com/author/david-reddish" title="Posts by David Reddish" rel="author">David Reddish</a></span></span> <time class="posted-on" itemprop="datePublished" datetime="2020-05-28T13:18:06-04:00">34 minutes ago</time> </div>
</header>
<div class="entry-content" itemprop="articleBody">

<div id="div-gpt-ad-textpromo1">
<script type='text/javascript'>
                    		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-textpromo1'); });
                    		</script>
</div>
<figure id="attachment_556941" aria-describedby="caption-attachment-556941" style="width: 670px" class="wp-caption alignnone"><img class="size-large wp-image-556941" src="https://queerty-prodweb.s3.amazonaws.com/2020/05/sordid_lives-670x374.png" alt="" width="670" height="374" srcset="https://queerty-prodweb.imgix.net/2020/05/sordid_lives-670x374.png?&amp;auto=format&amp;auto=compress&amp;w=670 670w, https://queerty-prodweb.imgix.net/2020/05/sordid_lives-670x374.png?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://queerty-prodweb.imgix.net/2020/05/sordid_lives-670x374.png?&amp;auto=format&amp;auto=compress&amp;w=800 800w" sizes="(max-width: 670px) 100vw, 670px"><figcaption id="caption-attachment-556941" class="wp-caption-text"><em>Sordid Lives</em></figcaption></figure>
<p><em>Whatever your entertainment needs, we got your back (and hopefully your mind) with Queerty’s weekly “Culture Club” column with some of the highlights of new releases, streaming shows, classics worth revisiting, and what to drink while you watch.</em></p>
<p><strong>The Classy: Sordid Lives: Live</strong></p>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="Sordid Lives Trailer" width="872" height="491" src="https://www.youtube.com/embed/TwBV8LYFzMg?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>Writer/director <a href="http://del%20shores">Del Shores</a> brings his own COVID culture to the web with this special live reading of his cult play. <i>Sordid Lives</i> focuses on the family of a closeted gay Texan, who has escaped the wilderness for the wildness of West Hollywood. Meanwhile, his wacky Texas family struggles to cope with a scandalous death in the family, and with the suspicion that their golden boy is gay. Shores directs, and reunites a combination of the original stage and film version cast, including Bonnie Bedelia, Beth Grant, Beau Bridges, Caroline Rhea and national treasure Leslie Jordan. The live stream will also include a special appearance by Olivia Newton-John. The show is a must for fans of all things <i>Sordid</i>, or anyone that has experienced the clash between sissy and southern life.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle1"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle1"); });</script></div>
<p><em>Streams May 31 at 5pm Pacific/8pm Eastern on <a href="https://www.youtube.com/watch?v=aSMsK3gSutY">YouTube</a> and Facebook Live.</em></p>
<p><strong>The Golden: After Forever Season 2</strong></p>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="AFTER FOREVER the series --Trailer" width="872" height="491" src="https://www.youtube.com/embed/kyhFuza-1bA?start=1&amp;feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>Call it the little digital series that could: this tender, if soapy show just landed six Daytime Emmy Nominations, including nods for Best Supporting Actor, Best Actress and Best Digital Drama. <a href="https://www.queerty.com/amazons-forever-takes-intimate-look-older-gay-men-death-us-part-20180425"><i>After Forever</i></a> follows the plight of Brian (Kevin Spirtas), a middle-aged gay man reeling from the death of his husband, Jason (Mitchell Anderson). Season 1 ended with Jason’s parents setting Brian up on a date with the handsome David (Mike McGowan). Season 2 picks up with David and Brian trying to have a relationship without the spectre of Jason haunting both of them. <i>After Forever</i> looks at a little-discussed reality of queer love: that of the sudden loss of a spouse, and how recovery in the LGBTQ world has its own set of perils. Moreover, a talented cast lends urgency to the drama, even when the plot feels lifted from <i>Days of Our Lives</i>. Like that show, even at it silliest, it’s still addictive as Hell.</p>
<p><em>Streams on <a href="https://amzn.to/36CCnpd">Amazon</a>.</em></p><div class="ad-300 inline" id="div-gpt-ad-inarticle2"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle2"); });</script></div>
<p><strong>The Overlooked: Poz Roz</strong></p>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="POZ ROZ: SUPERTEASE" width="872" height="491" src="https://www.youtube.com/embed/iJhy83xMk8M?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>A reader email (yes, we do read them), tipped us off to this digital series which debuted last year. Quite simply, we’ve <i>never</i> seen anything like it anywhere else. <i>Poz Roz</i> tells the story of Rozzlyn Mayweather, a straight woman adjusting to her divorce from a gay man, and trying to understand LGBTQ life through the eyes of her gay bestie. When Roz tests positive for HIV, she finds a whole new comfort in the queer community as she wrestles with what her diagnosis means for the rest of her life. Series creator Carlton Jordan finds a delicate tone for the series, somehow teetering between outright hilarity and overwhelming sorrow. Even better, he’s also an inspired director, with unique shot compositions, and who blends live-action with animated overlays to get better insight into his characters. Though it focuses on a heterosexual woman, <i>Poz Roz</i> deals very directly with the queer African-American experience with special attention paid to the role of masculinity. The full first season landed on YouTube last summer. It makes for a great binge in the days of lockdown.</p>
<p><em>Streams on YouTube.</em></p><div class="ad-300 inline" id="div-gpt-ad-inarticle3"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle3"); });</script></div>
<p><strong>The Spin: Blimes &amp; Gab “Shelly’s (It’s Chill)”</strong></p>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="B.A.G. - " shelly at music tastes good in long beach ca width="872" height="491" src="https://www.youtube.com/embed/ITKGkUQwztY?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>Female hip hop duo Blimes &amp; Gab drop a new single this week, a throwback to 80s synthpop and the late 90s smooth jams of Sean Combs. “Shelly’s” meditates on meeting someone beautiful on the dance floor, and the kind of wild fantasies of bliss that follow. With our thirst for dancing and human contact ever-growing, “Shelly’s” at least allows us a fantasy of sensual contact with somebody special. The track is as a good as its title: it’s <i>chill.</i></p>
<p><em>Studio track available on <a href="https://promo.theorchard.com/J33nvKSf49O6YgnjCshg">The Orchard.</a></em></p><div class="ad-300 inline" id="div-gpt-ad-inarticle4"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle4"); });</script></div>
<p><strong>The Memorial: The Normal Heart</strong></p>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="The Normal Heart | official trailer (2014) HBO Mark Ruffalo Jim Parsons" width="872" height="491" src="https://www.youtube.com/embed/fZxR9XHS0H8?start=3&amp;feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>We continue to mourn the loss of writer <a href="https://www.queerty.com/breaking-larry-kramer-playwright-outspoken-aids-activist-dead-84-20200527">Larry Kramer</a>, a man who became an important voice for activism and art for LGBTQ people. In honor of his passing, we recommend revisiting the film version of <a href="https://www.queerty.com/heres-how-larry-kramer-came-to-trust-ryan-murphy-to-direct-the-normal-heart-20140801"><i>The Normal Heart</i>,</a> directed by fellow gay lion <a href="https://www.queerty.com/tag/ryan-murphy">Ryan Murphy</a>. Mark Ruffalo stars as Ned, a gay man witnessing the scourge of AIDS and who, in his sorrow, is driven to activism. The film portrays the decimation and alienation of queer people by political figures, the end of post-Stonewall euphoria, and the transformation of a community learning to defend itself. Taylor Kitch, <a href="https://www.queerty.com/tag/matt-bomer">Matt Bomer</a>, Jim Parsons, Alfred Molina and Julia Roberts also star. Much like Kramer himself, <i>The Normal Heart</i> can infuriate viewers at times, though, as with the man himself, it will also enrich and move audiences to come away with a better understanding of LGBTQ life and history. As with Larry Kramer, we’re better for having known it.</p>
<p><em>Streams on HBO, <a href="https://amzn.to/3d8TlOr">Amazon</a>, iTunes, Hulu, VUDU &amp; YouTube.</em></p><div class="ad-300 inline" id="div-gpt-ad-inarticle5"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle5"); });</script></div>
<p><strong>The Encore: Hairspray Live</strong></p>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="HAIRSPRAY Live! - FULL SHOW | The Shows Must Go On - Stay Home #WithMe" width="872" height="491" src="https://www.youtube.com/embed/q25CRGGiT8Q?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>This gem, part of NBC’s live theatrical productions (you know, the series that also produced <em>Jesus Christ Superstar, The Sound of Music </em>and <em>Peter Pan</em>), makes a return this week courtesy of the magic of YouTube. <em>Hairspray Live</em> features a cast that includes Maddie Baillio, Dove Cameron, Kristin Chenoweth, <a href="https://www.queerty.com/garrett-clayton-blake-knight-post-sweet-ninth-anniversary-messages-20200221">Garrett Clayton</a>, <a href="https://www.queerty.com/queer-renaissance-making-broadway-fabulous-20170507">Harvey Fierstein</a>, Ariana Grande, Derek Hough, <a href="https://www.queerty.com/this-prince-tribute-from-jennifer-hudson-and-color-purple-cast-will-wreck-you-20160421">Jennifer Hudson</a>, &amp; Martin Short, and for our money, is <em>far</em> more enjoyable than the feature film version. The reason boils down to the character Edna Turnblad. Whereas John Travolta’s Edna always felt one-note, Fierstein’s version of the character (he won a Tony for the original Broadway production) teems with passion, femininity, and maternal grace. Moreover, where Travolta’s Edna and her on-screen husband Wilbur (Christopher Walken) had no chemistry and barely touched each other, Firestein’s Edna and Martin Short’s Wilbur seem passionately in love. They also, despite their body types, have an obviously healthy sex life. Even with the foibles of live theatre on full display (such as when Jennifer Hudson reduces the cast to tears with one of her vocal renditions), <em>Hairspray Live</em> feels more natural and alive. Quite simply, it’s a ball.</p>
<p><em>Streams on <a href="https://www.youtube.com/watch?v=q25CRGGiT8Q">YouTube</a> starting Friday (5/29) at 11am PT / 2pm ET for 48 hours only. </em></p><div class="ad-300 inline" id="div-gpt-ad-inarticle6"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle6"); });</script></div>
<p><strong>The Sip: June Bug</strong></p>
<p><img class="alignnone size-large wp-image-547460" src="https://queerty-prodweb.s3.amazonaws.com/2020/01/Midori-sour-503x670.jpg" alt="" width="503" height="670" srcset="https://queerty-prodweb.imgix.net/2020/01/Midori-sour-503x670.jpg?&amp;auto=format&amp;auto=compress&amp;w=503 503w, https://queerty-prodweb.imgix.net/2020/01/Midori-sour-503x670.jpg?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://queerty-prodweb.imgix.net/2020/01/Midori-sour-503x670.jpg?&amp;auto=format&amp;auto=compress&amp;w=768 768w" sizes="(max-width: 503px) 100vw, 503px"></p>
<p>With June rapidly approaching on the horizon, we thought it best to theme this week’s sippage to the dawn of Pride. This sweet cocktail will put you in the mood for all kinds of things fruity. We wouldn’t have it any other way.</p>
<ul>
<li><span class="amount">1 part</span> <span class="ingredient">Melon liqueur</span><small class="text-muted"></small></li>
<li><span class="amount">½ part</span> <span class="ingredient">Coconut rum</span><small class="text-muted"></small></li>
<li><span class="amount">½ part</span> <span class="ingredient">Banana liqueur</span><small class="text-muted"></small></li>
<li><span class="amount">2 parts</span> <span class="ingredient">Pineapple juice</span><small class="text-muted"></small></li>
<li><span class="amount">1 part</span> <span class="ingredient">Lemon juice</span></li>
</ul>
<p><em>Mix over ice in a martini shaker. Shake well and serve.</em></p>

<div id="div-gpt-ad-textpromo2">
<script type='text/javascript'>
                    		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-textpromo2'); });
                    		</script>
</div>
</div>
<footer class="entry-footer">
<span class="tags-links"><a href="https://www.queerty.com/entertainment" rel="category">Entertainment</a> <a href="https://www.queerty.com/tag/after-forever" rel="tag">after forever</a> <a href="https://www.queerty.com/tag/poz-roz" rel="tag">poz roz</a> <a href="https://www.queerty.com/tag/shellys" rel="tag">shelly's</a> <a href="https://www.queerty.com/tag/sordid-lives" rel="tag">Sordid Lives</a> <a href="https://www.queerty.com/tag/the-normal-heart" rel="tag">the normal heart</a></span><div class="comments-link-area"><a href="https://www.queerty.com/watch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528#respond"><span class="comments-link">Add a comment</span></a></div> </footer>
</article>
</main>
<div class="article-email-prompt-red" id="queerty-article-email-prompt">
<h3><span class="asterisk"> </span>Get Queerty Daily</h3>
Subscribe to Queerty for a daily dose of #entertainment #afterforever #pozroz stories and more
<form action="//queerty.us1.list-manage.com/subscribe/post?u=ecab442566f15d8d4dcf64b0d&amp;id=221c27272a" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank">
<input type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="Your email" autocomplete="email">
<input type="hidden" name="group[5437][16]" value="1">
<input type="hidden" value="2" name="group[5409][2]" id="mce-group[5409]-5409-0">
<input type="hidden" value="1" name="group[5409][1]" id="mce-group[5409]-5409-1">
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ecab442566f15d8d4dcf64b0d_221c27272a" tabindex="-1" value=""></div>
<input type="submit" value="Subscribe" name="submit" id="mc-embedded-subscribe" class="button">
</form>
</div>
<div id="esb-embed"><script src="//embed.egamiplatform.tv/embed-nxlfz.js"></script></div>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Add your Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/watch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528#respond" style="display:none;">Cancel reply</a></small></h3><p class="nocomments">Please <a href="https://www.queerty.com/wp/wp-login.php?redirect_to=https%3A%2F%2Fwww.queerty.com%2Fwatch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528">log in</a> to add your comment<br>Need an account? <strong><a href="https://www.queerty.com/wp/wp-login.php?action=register">Register</a></strong> *It's free and easy.</p> </div>
</div>

<div id="div-gpt-ad-textpromo3">
<script type='text/javascript'>
                    		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-textpromo3'); });
                    		</script>
</div>
</div>
<script type="text/javascript" async="async" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-58640af04b28c97d"></script>
<script async data-cfasync="false" src="https://embed.air.tv/v1/twoview_bootstrap.js?organization=836XtBNIR-WS8sis907b8w"></script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.queerty.com\/watch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528"},"headline":"What to Watch: Leslie Jordan live, love after death, and a proud farewell to Larry Kramer","url":"https:\/\/www.queerty.com\/watch-leslie-jordan-live-love-death-proud-farewell-larry-kramer-20200528","datePublished":"2020-05-28T13:18:06-04:00","dateModified":"2020-05-28T13:18:06-04:00","description":"Whatever your entertainment needs, we got your back (and hopefully your mind) with Queerty\u2019s weekly \u201cCulture Club\u201d column with some of the highlights of new releases, streaming shows, classics worth revisiting, and what to drink while you watch. The Classy: Sordid Lives: Live Writer\/director Del Shores brings his own COVID culture to the web with [...]","thumbnailUrl":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2020\/05\/normal-heart2-307x270.jpg","image":{"@type":"ImageObject","url":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2020\/05\/normal-heart2-307x270.jpg","height":480,"width":270},"creator":"David Reddish","author":{"@type":"Person","name":"David Reddish"},"articleSection":"Entertainment","keywords":["Feature","Queerty","after forever","poz roz","shelly's","Sordid Lives","the normal heart","[ Has: YouTube embed ]","[ Has: YouTube embed (5+) ]","[ Word count: 1000+ ]"],"publisher":{"@type":"NewsMediaOrganization","name":"Queerty","url":"https:\/\/www.queerty.com\/","logo":{"@type":"ImageObject","url":"https:\/\/www.queerty.com\/assets\/q-2017\/queerty-logo-225x60.png","height":"60","width":"225"},"address":{"@type":"PostalAddress","streetAddress":"584 Castro St. #623","addressLocality":"San Francisco","addressRegion":"CA","postalCode":"94114","addressCountry":"USA"},"sameAs":["https:\/\/en.wikipedia.org\/wiki\/Queerty","https:\/\/www.facebook.com\/queerty","https:\/\/www.twitter.com\/queerty","https:\/\/www.instagram.com\/queerty","https:\/\/www.youtube.com\/user\/queertyTV"]}}</script>
<aside id="secondary" class="article-sidebar" role="complementary">
<div class="sidebar-ad-1" id="div-gpt-ad-box1">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box1'); });
			</script>
</div>
<div id="civsci-id-1487938606" data-civicscience-widget="7e525d9d-2b18-3944-8162-270cab0eef2f"></div>
<script type="text/javascript" async src="https://www.civicscience.com/jspoll/4/civicscience-widget.js"></script>
<section class="sidebar-related">
<h3 class="category-heading">
More in Entertainment </h3>
<div class="cards-list">
<article id="post-556786" class="card card-small ">
<a href="https://www.queerty.com/daily-dose-thrilling-adventure-underrated-queer-hero-20200527">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/girl-with-the-dragon-tattoo.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Daily Dose: A thrilling adventure with an underrated queer hero">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Queerantined</div>
<h2 class="entry-title">Daily Dose: A thrilling adventure with an underrated queer hero</h2> <div class="entry-meta">
<a href="https://www.queerty.com/daily-dose-thrilling-adventure-underrated-queer-hero-20200527" rel="bookmark"><time class="entry-date published updated" datetime="2020-05-27T15:59:16-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-556918" class="card card-small ">
<a href="https://www.queerty.com/gay-twitter-war-lady-gagas-song-rain-getting-vicious-20200527">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/lady-gaga-rain-on-me.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Gay Twitter is at war over Lady Gaga&#8217;s song &#8220;Rain on Me&#8221; and it&#8217;s getting vicious">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">deep divide</div>
<div class="card-commentcount">9 comments</div><h2 class="entry-title">Gay Twitter is at war over Lady Gaga&#8217;s song &#8220;Rain on Me&#8221; and it&#8217;s getting vicious</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-556776" class="card card-small queerty-interview-link">
<a href="https://www.queerty.com/rob-eric-david-collins-michael-williams-bringing-ballroom-refuge-tv-legendary-20200527">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/legendary_5.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Rob Eric, David Collins &#038; Michael Williams on bringing ballroom refuge to TV in &#8216;Legendary&#8217;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Strictly Ballroom</div>
<h2 class="entry-title">Rob Eric, David Collins &#038; Michael Williams on bringing ballroom refuge to TV in &#8216;Legendary&#8217;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-556899" class="card card-small ">
<a href="https://www.queerty.com/watch-trailer-love-simon-spinoff-love-victor-us-feeling-queer-fuzzy-20200527">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/04/Love-victor.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="WATCH: The trailer for the &#8216;Love, Simon&#8217; spinoff &#8216;Love, Victor&#8217; has us feeling queer &#038; fuzzy">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Trailer Park</div>
<h2 class="entry-title">WATCH: The trailer for the &#8216;Love, Simon&#8217; spinoff &#8216;Love, Victor&#8217; has us feeling queer &#038; fuzzy</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-2" id="div-gpt-ad-box2">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box2'); });
			</script>
</div>
<br>
<section class="sidebar-related">
<h3 class="category-heading">
Popular on Queerty
</h3>
<div class="cards-list">
<article id="post-557022" class="card card-small ">
<a href="https://www.queerty.com/olympian-guillaume-cizeron-comes-introducing-adorable-boyfriend-20200528">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/Screen-Shot-2020-05-28-at-9.44.27-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Olympian Guillaume Cizeron comes out by introducing his adorable boyfriend">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Closet Door Bustdown</div>
<h2 class="entry-title">Olympian Guillaume Cizeron comes out by introducing his adorable boyfriend</h2> <div class="entry-meta">
<a href="https://www.queerty.com/olympian-guillaume-cizeron-comes-introducing-adorable-boyfriend-20200528" rel="bookmark"><time class="entry-date published updated" datetime="2020-05-28T12:46:00-04:00">1 hour ago</time></a> </div>
</section>
</a>
</article>
<article id="post-556667" class="card card-small ">
<a href="https://www.queerty.com/national-treasure-leslie-jordan-dishes-rumored-will-grace-feud-20200522">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/will-and-grace-costars-unfollow-each-other-amid-rumors-of-a-feud__491836_-670x447-1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="National treasure Leslie Jordan dishes on the rumored &#8216;Will &#038; Grace&#8217; feud">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">TV time</div>
<div class="card-commentcount">25 comments</div><h2 class="entry-title">National treasure Leslie Jordan dishes on the rumored &#8216;Will &#038; Grace&#8217; feud</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-556680" class="card card-small ">
<a href="https://www.queerty.com/daily-dose-rural-farmers-uncut-20200523">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2018/01/gods-own-country.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Daily Dose: Rural farmers, uncut">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Queerantined</div>
<div class="card-commentcount">11 comments</div><h2 class="entry-title">Daily Dose: Rural farmers, uncut</h2> <div class="entry-meta">
<a href="https://www.queerty.com/daily-dose-rural-farmers-uncut-20200523" rel="bookmark"><time class="entry-date published updated" datetime="2020-05-23T16:40:09-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-556708" class="card card-small ">
<a href="https://www.queerty.com/brian-jordan-alvarezs-home-gym-michael-turchins-chest-keiynan-lonsdales-calvins-20200523">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/Daniel-Matsunaga-Keiynan-Lonsdale-Keegan-Whicker-seth-g-instastuds.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Brian Jordan Alvarez&#8217;s home gym, Michael Turchin&#8217;s chest, &#038; Keiynan Lonsdale&#8217;s Calvins">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Instastuds</div>
<div class="card-commentcount">11 comments</div><h2 class="entry-title">Brian Jordan Alvarez&#8217;s home gym, Michael Turchin&#8217;s chest, &#038; Keiynan Lonsdale&#8217;s Calvins</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-556687" class="card card-small ">
<a href="https://www.queerty.com/watch-ser-anzoategui-saying-goodbye-beloved-queer-series-vida-20200523">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/Ser1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="WATCH: Ser Anzoategui on saying goodbye to beloved queer series &#8220;Vida&#8221;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Talk It Out</div>
<h2 class="entry-title">WATCH: Ser Anzoategui on saying goodbye to beloved queer series &#8220;Vida&#8221;</h2> <div class="entry-meta">
<a href="https://www.queerty.com/watch-ser-anzoategui-saying-goodbye-beloved-queer-series-vida-20200523" rel="bookmark"><time class="entry-date published updated" datetime="2020-05-23T12:34:46-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</section>
</aside>
<br clear=all>
<div class="single-bottom-articles">
<h3>
Latest on Queerty </h3>
<div class="single-bottom-articles-slider slider slick-slider">
<div><article id="post-557033" class="card card-small ">
<a href="https://www.queerty.com/gop-candidate-stands-behind-deleted-homophobic-tweets-says-tons-gay-friends-20200528">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/TerrySchillingFoxBusinessScreenshot.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="GOP candidate stands behind deleted homophobic tweets, says he has tons of gay friends">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">no regrets</div>
<h2 class="entry-title">GOP candidate stands behind deleted homophobic tweets, says he has tons of gay friends</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-557022" class="card card-small ">
<a href="https://www.queerty.com/olympian-guillaume-cizeron-comes-introducing-adorable-boyfriend-20200528">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/Screen-Shot-2020-05-28-at-9.44.27-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Olympian Guillaume Cizeron comes out by introducing his adorable boyfriend">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Closet Door Bustdown</div>
<h2 class="entry-title">Olympian Guillaume Cizeron comes out by introducing his adorable boyfriend</h2> <div class="entry-meta">
<a href="https://www.queerty.com/olympian-guillaume-cizeron-comes-introducing-adorable-boyfriend-20200528" rel="bookmark"><time class="entry-date published updated" datetime="2020-05-28T12:46:00-04:00">1 hour ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-557014" class="card card-small ">
<a href="https://www.queerty.com/schoolgirls-squeal-sheer-delight-watch-gay-couple-kiss-viral-video-20200528">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/gay-kiss-school-kids-delight.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Schoolgirls squeal with sheer delight as they watch gay couple kiss in viral video">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">love is love</div>
<h2 class="entry-title">Schoolgirls squeal with sheer delight as they watch gay couple kiss in viral video</h2> <div class="entry-meta">
<a href="https://www.queerty.com/schoolgirls-squeal-sheer-delight-watch-gay-couple-kiss-viral-video-20200528" rel="bookmark"><time class="entry-date published updated" datetime="2020-05-28T12:12:35-04:00">1 hour ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-557008" class="card card-small ">
<a href="https://www.queerty.com/brian-sims-accuses-gop-covering-lawmakers-covid-19-diagnosis-epic-profanity-laden-rant-20200528">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/Screen-Shot-2020-05-28-at-10.29.57-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Brian Sims accuses GOP of covering up lawmaker’s COVID-19 diagnosis in epic, profanity-laden rant">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">outraged</div>
<h2 class="entry-title">Brian Sims accuses GOP of covering up lawmaker’s COVID-19 diagnosis in epic, profanity-laden rant</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-556997" class="card card-small ">
<a href="https://www.queerty.com/watch-gagas-rain-routine-almost-ends-tragedy-one-fan-20200528">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/andres_q_castro_instagram_twitter.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="WATCH: Gaga&#8217;s &#8216;Rain On Me&#8217; routine almost ends in tragedy for one fan">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Narrow escape</div>
<h2 class="entry-title">WATCH: Gaga&#8217;s &#8216;Rain On Me&#8217; routine almost ends in tragedy for one fan</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-556786" class="card card-small ">
<a href="https://www.queerty.com/daily-dose-thrilling-adventure-underrated-queer-hero-20200527">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/girl-with-the-dragon-tattoo.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Daily Dose: A thrilling adventure with an underrated queer hero">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Queerantined</div>
<h2 class="entry-title">Daily Dose: A thrilling adventure with an underrated queer hero</h2> <div class="entry-meta">
<a href="https://www.queerty.com/daily-dose-thrilling-adventure-underrated-queer-hero-20200527" rel="bookmark"><time class="entry-date published updated" datetime="2020-05-27T15:59:16-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-556932" class="card card-small ">
<a href="https://www.queerty.com/trumps-homophobic-press-secretary-kayleigh-mcenany-just-got-caught-another-ridiculous-lie-20200527">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/kayleigh-press-conf-2.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Trump&#8217;s homophobic press secretary Kayleigh McEnany just got caught in another ridiculous lie">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">pants on fire</div>
<div class="card-commentcount">24 comments</div><h2 class="entry-title">Trump&#8217;s homophobic press secretary Kayleigh McEnany just got caught in another ridiculous lie</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-556930" class="card card-small ">
<a href="https://www.queerty.com/watch-hollywood-hills-house-parties-covid-getting-control-20200527">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/Screen-Shot-2020-05-27-at-11.51.17-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="WATCH: Hollywood Hills house parties under COVID are getting &#8216;out of control&#8217;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Pent up</div>
<div class="card-commentcount">33 comments</div><h2 class="entry-title">WATCH: Hollywood Hills house parties under COVID are getting &#8216;out of control&#8217;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-556918" class="card card-small ">
<a href="https://www.queerty.com/gay-twitter-war-lady-gagas-song-rain-getting-vicious-20200527">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/lady-gaga-rain-on-me.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Gay Twitter is at war over Lady Gaga&#8217;s song &#8220;Rain on Me&#8221; and it&#8217;s getting vicious">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">deep divide</div>
<div class="card-commentcount">9 comments</div><h2 class="entry-title">Gay Twitter is at war over Lady Gaga&#8217;s song &#8220;Rain on Me&#8221; and it&#8217;s getting vicious</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-556776" class="card card-small queerty-interview-link">
<a href="https://www.queerty.com/rob-eric-david-collins-michael-williams-bringing-ballroom-refuge-tv-legendary-20200527">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/legendary_5.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Rob Eric, David Collins &#038; Michael Williams on bringing ballroom refuge to TV in &#8216;Legendary&#8217;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Strictly Ballroom</div>
<h2 class="entry-title">Rob Eric, David Collins &#038; Michael Williams on bringing ballroom refuge to TV in &#8216;Legendary&#8217;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-556899" class="card card-small ">
<a href="https://www.queerty.com/watch-trailer-love-simon-spinoff-love-victor-us-feeling-queer-fuzzy-20200527">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/04/Love-victor.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="WATCH: The trailer for the &#8216;Love, Simon&#8217; spinoff &#8216;Love, Victor&#8217; has us feeling queer &#038; fuzzy">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Trailer Park</div>
<h2 class="entry-title">WATCH: The trailer for the &#8216;Love, Simon&#8217; spinoff &#8216;Love, Victor&#8217; has us feeling queer &#038; fuzzy</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-556902" class="card card-small ">
<a href="https://www.queerty.com/woman-convinced-men-dates-gay-told-maybe-problem-isnt-20200527">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/05/shutterstock_496267222.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Woman convinced all the men she dates are gay told that maybe the problem isn&#8217;t them&#8230; it&#8217;s her">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">common denominator</div>
<div class="card-commentcount">17 </div><h2 class="entry-title">Woman convinced all the men she dates are gay told that maybe the problem isn&#8217;t them&#8230; it&#8217;s her</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div>
</div>
</div></div>
</div>
<div class="site-footer-holder">
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="footer-brand">
<span class="asterisk"> </span>
Free of an agenda (except that gay one)
</div>
<div class="tags-links">
<a href="//www.queerty.com/tag/adam-rippon">Adam Rippon</a> <a href="//www.queerty.com/tag/freddie-mercury">Freddie Mercury</a> <a href="//www.queerty.com/tag/gus-kenworthy">Gus Kenworthy</a> <a href="//www.queerty.com/tag/nick-jonas">Nick Jonas</a> <a href="//www.queerty.com/tag/nico-tortorella">Nico Tortorella</a> <a href="//www.queerty.com/tag/pietro-boselli">Pietro Boselli</a> <a href="//www.queerty.com/tag/ricky-martin">Ricky Martin</a> <a href="//www.queerty.com/tag/russell-tovey">Russell Tovey</a> <a href="//www.queerty.com/tag/zac-efron">Zac Efron</a> <div class="second-row">
<a href="//www.queerty.com/tag/donald-trump">Donald Trump</a> <a href="//www.queerty.com/tag/homophobia">Homophobia</a> <a href="//www.queerty.com/tag/coming-out">Coming Out</a> <a href="//www.queerty.com/tag/rupaul's-drag-race">Rupaul's Drag Race</a> <a href="//www.queerty.com/tag/scandal">Scandal</a> <a href="//www.queerty.com/tag/religion">Religion</a> <a href="//www.queerty.com/tag/relationships">Relationships</a> <a href="//www.queerty.com/tag/grindr">Grindr</a>
</div>
</div>
<div class="footer-links">
<ul class="main" id="footer-company-links">
<li><a href="http://www.q.digital"><img src="/assets/q-digital-blue-90x37.png" alt="Q.digital" width="90"></a></li>
<li><b>A Q.Digital Company</b></li>
<li>&copy; 2020 Queerty, Inc.</li>
<li><a href="http://www.q.digital">Advertise With Us</a></li>
</ul>
<ul class="main" id="footer-contact-links">
<li><h3>Contact</h3></li>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
<li><a href="https://www.queerty.com/queertys-comment-policy">Comments Policy</a>
<li><a href="https://www.queerty.com/privacy-policy">Privacy Statement</a>
<li><a href="https://www.queerty.com/terms-of-use">Terms of Use</a>
<li><a id="ccpaOptOut">Do Not Sell My Personal Information</a>
</ul>
<ul class="main" id="footer-follow-links">
<li><h3>Follow</h3></li>
<li><a href="https://www.facebook.com/Queerty/">Facebook</a></li>
<li><a href="https://www.twitter.com/Queerty/">Twitter</a></li>
<li><a href="https://www.instagram.com/Queerty/">Instagram</a></li>
<li><a href="https://www.youtube.com/user/QueertyTV/">YouTube</a></li>
</ul>
<ul class="main double" id="footer-gaycities-links">
<li><h3>GayCities: Your Gay Travel Guide:</h3></li>
<li><a href="https://newyork.gaycities.com/">New York</a></li>
<li><a href="https://london.gaycities.com/">London</a></li>
<li><a href="https://sanfrancisco.gaycities.com/">San Francisco</a></li>
<li><a href="https://chicago.gaycities.com/">Chicago</a></li>
<li><a href="https://losangeles.gaycities.com/">Los Angeles</a></li>
<li><a href="https://washingtondc.gaycities.com/">Washington DC</a></li>
<li><a href="https://dallas.gaycities.com/">Dallas</a></li>
<li><a href="https://saskatoon.gaycities.com/">Gay Saskatoon</a></li>
<li><a href="https://www.gaycities.com/places/"><b>See all 230+ cities...</b></a></li>
</ul>
</div>
</footer>
</div>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "32666898" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=32666898&cv=2.0&cj=1" alt="Comscore Measurement" />
</noscript>

<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '686853021424163');
  fbq('track', 'PageView');
</script>
<noscript><img height='1' width='1' style='display:none'
  src='https://www.facebook.com/tr?id=686853021424163&ev=PageView&noscript=1'
/></noscript>

<script>
  fbq('track', 'ViewContent');
</script>
<script>
	window.dataLayer = window.dataLayer || []
	dataLayer.push({
	   'event': 'Page Details',
	   'pageType': 'article',
	   'pageCategory': 'entertainment'
	   
	});
	</script>
<script type="text/javascript" src="https://s.skimresources.com/js/151843X1617499.skimlinks.js"></script><script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/comment-reply.min.js?ver=5.4.1'></script>
<script type='text/javascript' async src='https://platform.twitter.com/widgets.js?ver=20161216'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js?ver=5.4.1'></script>
<script type='text/javascript' async src='https://www.queerty.com/content/themes/queerty_2017/js/min/queerty-nosticky-min.js?ver=20200120a'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.4.1' async='async'></script>
<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":556938,"object_key":"post","object_type":"post","term_ids":[2215,6255,310,81990,86524,86525,8254,14521]};</script>
<script data-cfasync="false" id="parsely-cfg" data-parsely-site="queerty.com" src="https://cdn.parsely.com/keys/queerty.com/p.js"></script>
</body>
</html>