<!DOCTYPE html>
<html>
<head>
<script type="text/javascript" src="//digg7anmcfked.cloudfront.net/script.js"></script>
<link rel="stylesheet" href="https://use.typekit.net/cdb4vyt.css">
<meta name="viewport" content="width=device-width, initial-scale=1">

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
</script>

<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.2634970.min.js?cachebuster=1';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      // Return control to GPT if the AdBridg library fails to load.
      adb.onerror = function() {
        console.log('Fallback: ')
        if (AdBridg.exists) { return; }
        document.createElement('IMG').src = '//adspsp.com/pt/2634970/3/1/?e=0';
        var dq = [], es;
        dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
        AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
        AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
        AdBridg.destroySlots = function(s) { return googletag.destroySlots(s); }
        AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
        AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
        AdBridg.render = function() { }
        AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
        AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
        AdBridg.useSizeMapping = function() { }
        AdBridg.cmd.push = function(f) {
          if (typeof(f)=='object') {
            var api_fallback = function(o) {
              googletag.cmd.push(function() {
                var u=AdBridg.defineSlot(o.gpt_path,o.size||[],o.dom_id);
                if(o.size_map) {
                  var m = googletag.sizeMapping();
                  for(var oi=0;oi<o.size_map.length;oi++){m=m.addSize(o.size_map[oi].viewport, o.size_map[oi].sizes);}
                  u.defineSizeMapping(m.build());
                }
                if(o.events) {
                  if(o.events["gpt.defined"]){o.events["gpt.defined"](u);}
                  var fl = function(a,b){if(o.events[a]){googletag.pubads().addEventListener(b,function(e){if(e.slot===u){o.events[a](u,e)}})}}
                  fl("gpt.rendered",'slotRenderEnded');
                  fl("gpt.viewed",'impressionViewable');
                  fl("gpt.visibilityChanged",'slotVisibilityChanged');
                }
              });
            }
            if(f.length){for(var i=0;i<f.length;++i){api_fallback(f[i]);}}else{api_fallback(f);}
            f=function(){AdBridg.serve()}
          }
          return googletag.cmd.push(f);
        }
        while (AdBridg.cmd.length) { AdBridg.cmd.push(AdBridg.cmd.shift()); }
      }
  })();
AdBridg.cmd.push({
	action: 'spa_pv_initialize',
	config: {
		footer_sticky: false,
		qd_path: '/4564944/queerty/politics/article'
	}
});
</script>
<script>
AdBridg.cmd.push(function () {
	googletag.pubads().collapseEmptyDivs();
	googletag.pubads().setTargeting('articleid', ['590906']);
	googletag.pubads().setTargeting('Tag', ['articlepage','britney spears','matt gaetz','ad friendly','politics','queerty']);
	googletag.pubads().setTargeting('UGC', ['no']);
  });
</script>
<script>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</script>
<title>Matt Gaetz doesn’t think he’s getting due thanks for helping Britney Spears / Queerty</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//powerad.ai' />
<link rel='dns-prefetch' href='//q-digital.videoplayerhub.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Feed" href="https://www.queerty.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Comments Feed" href="https://www.queerty.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Matt Gaetz doesn’t think he’s getting due thanks for helping Britney Spears Comments Feed" href="https://www.queerty.com/matt-gaetz-doesnt-think-hes-getting-due-thanks-helping-britney-spears-20210930/feed" />
<link rel='stylesheet' id='queerty_2017-style-css' href='https://www.queerty.com/content/themes/queerty_2017/style.css?ver=20210819a' type='text/css' media='all' />
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://powerad.ai/script.js?ver=20201101' id='nxtm-js'></script>
<link rel="canonical" href="https://www.queerty.com/matt-gaetz-doesnt-think-hes-getting-due-thanks-helping-britney-spears-20210930" />
<meta property="og:site_name" content="Queerty" /><meta name="twitter:card" content="summary_large_image"> <meta name="description" content="Gaetz wants the world to know that he’s the one helping to #freebritney..." />
<meta property="og:description" content="Gaetz wants the world to know that he’s the one helping to #freebritney...">
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.queerty.com/matt-gaetz-doesnt-think-hes-getting-due-thanks-helping-britney-spears-20210930" />
<meta property="og:title" content="Matt Gaetz doesn’t think he’s getting due thanks for helping Britney Spears" />
<meta property="og:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/britney_spears_matt_gaetz_shutterstock_c_span-1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=1200&h=630&wat=1&wat_gravity=southeast&wat_pad=70" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta name="twitter:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/britney_spears_matt_gaetz_shutterstock_c_span-1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=1200&h=630&wat=1&wat_gravity=southeast&wat_pad=70" />
<meta name="publish_date" property="article:published_time" content="2021-09-30T09:55:57-04:00" />
<meta property="article:modified_time" content="2021-09-30T09:39:27-04:00" />
<meta name="twitter:url" content="https://www.queerty.com/matt-gaetz-doesnt-think-hes-getting-due-thanks-helping-britney-spears-20210930" />
<meta name="twitter:title" content="Matt Gaetz doesn’t think he’s getting due thanks for helping Britney Spears" />
<meta name="twitter:description" content="Gaetz wants the world to know that he’s the one helping to #freebritney..." />
<meta name="news_keywords" content="Britney Spears, Matt Gaetz"><meta property="article:tags" content="Britney Spears, Matt Gaetz"><meta name="author" property="author" content="David Hudson" /><meta name="twitter:label1" content="By"><meta name="twitter:data1" content="David Hudson"> <style>
            #tps_carousel_container ._button,
            #tps_carousel_container ._button svg {
                color: #f08100;
                fill: #f08100;
            }

            #tps_carousel_container ._button {
                font-size: 32px;
                line-height: 32px;
            }

            #tps_carousel_container ._button svg {
                width: 32px;
                height: 32px;
            }

            #tps_carousel_container ._button:hover,
            #tps_carousel_container ._button:focus,
            #tps_carousel_container ._button:hover svg,
            #tps_carousel_container ._button:focus svg {
                color: #ffa338;
                fill: #ffa338;
            }

            #tps_carousel_container ._disabled,
            #tps_carousel_container ._disabled svg {
                color: #777777 !important;
                fill: #777777 !important;
            }

            #tps_carousel_container ._carousel {
                margin: 0 42px;
            }

            #tps_carousel_container ._prev {
                margin-right: 10px;
            }

            #tps_carousel_container ._next {
                margin-left: 10px;
            }
        </style>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KRQPBJR');</script>

<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
<link rel="preconnect" href="https://queerty-assets.s3.amazonaws.com">
<link rel="preload" href="https://www.googletagservices.com/tag/js/gpt.js">
<link rel="preconnect" href="https://www.googletagmanager.com">
<link rel="preconnect" href="https://queerty-prodweb.imgix.net">
<meta property="fb:app_id" content="153299894806318" />
<meta name="theme-color" content="#f43700" />
<meta name="apple-itunes-app" content="app-id=1046987164">
<meta property="fb:pages" content="33720334139" />
<meta name="apple-mobile-web-app-title" content="Queerty*">
<meta name="application-name" content="Queerty*">
<meta name="msapplication-config" content="/assets/q-2017/favicons/browserconfig.xml?v=lkgzj5W5Gl">
<link rel="apple-touch-icon" sizes="180x180" href="/assets/q-2017/favicons/apple-touch-icon.png?v=lkgzj5W5Gl">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-32x32.png?v=lkgzj5W5Gl" sizes="32x32">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-16x16.png?v=lkgzj5W5Gl" sizes="16x16">
<link rel="manifest" href="/assets/q-2017/favicons/manifest.json?v=20180829">
<link rel="mask-icon" href="/assets/q-2017/favicons/safari-pinned-tab.svg?v=lkgzj5W5Gl" color="#5bbad5">
<link rel="shortcut icon" href="/assets/q-2017/favicons/favicon.ico?v=lkgzj5W5Gl">
<meta property="article:publisher" content="https://www.facebook.com/queerty" />
<style>
.ad-leaderboard-header {
	background-color:transparent !important;
	position:relative;
	margin-top:10px;
}
.queerty-header {
	padding-top:10px !important;
}
@media screen and (max-height: 769px) {
	.queerty-header {
    	min-height: 4.688rem;
    	padding: 10px 0 10px !important;
	}
}
</style>
</head>
<body class="post-template-default single single-post postid-590906 single-format-standard category-ad-friendly category-politics category-queerty">
<div id="top-of-page" style="display:none;"></div>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRQPBJR"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="div-gpt-ad-skin" style="height:1px;width:1px;">
<script>
		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-skin'); });
		</script>
</div>
<div id="div-gpt-ad-sidebarvideoplayer" style="height:1px;width:1px;">
<script>
		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-sidebarvideoplayer'); });
		</script>
</div>
<div id="page" class="site">
<div class="ad-leaderboard-header" id="div-gpt-ad-leader1">
<script>
				AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-leader1'); });
				</script>
</div>

<div id="is-phone"></div>

<header id="masthead" class="queerty-header">
<div class="queerty-header-wrapper">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="js-header-main-menu" class="queerty-header-menu show">
<li class="nav-link selected"> <a href="/">Latest</a>
</li>
<li class="nav-link navcat-life "><a class="scroll-on-page-link" data-scroll="category-life" href="https://www.queerty.com/life">Life</a></li>
<li class="nav-link navcat-entertainment "><a class="scroll-on-page-link" data-scroll="category-entertainment" href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li class="nav-link navcat-politics "><a class="scroll-on-page-link" data-scroll="category-politics" href="https://www.queerty.com/politics">Politics</a></li>
<li class="nav-link navcat-goods "><a class="scroll-on-page-link" data-scroll="category-goods" href="https://www.queerty.com/goods">Goods</a></li>
</ul>
</nav>
<div class="logo-area">
<a href="/" class="queerty-logo"><!-- -->
<img src="/assets/q-2017/queerty-logo.svg" width="275" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo">
<img src="/assets/promos/pride/2019/queerty-pride.svg" width="275" alt="Queerty* Pride" class="queerty-header-pride-logo" style="display:none;">
</a>
</div>
<nav id="right-navigation" class="secondary-navigation" role="navigation">
<ul id="js-header-secondary-menu" class="queerty-header-menu show">
<li class="nav-link">
<a href="https://www.facebook.com/Queerty/"><img src="/assets/icons/facebook-f-icon.svg" height="19" aria-hidden="true" alt="Facebook"></a>
</li>
<li class="nav-link">
<a href="https://twitter.com/queerty"><img src="/assets/icons/twitter-icon.svg" height="19" aria-hidden="true" alt="Twitter"></a>
</li>
<li class="nav-link">
<a href="https://www.instagram.com/queerty/"><img src="/assets/icons/instagram-icon.svg" height="19" aria-hidden="true" alt="Instagram"></a>
</li>
<li class="nav-link">
<a href="https://www.youtube.com/queerty/"><img src="/assets/icons/youtube-icon.svg" height="19" aria-hidden="true" alt="YouTube"></a>
</li>
<li class="nav-link">
<a href="https://eepurl.com/RrfMf"><img src="/assets/icons/envelope-regular.svg" height="19" aria-hidden="true" alt="newsletter"></a>
</li>
<li class="nav-link queerty-menu-button" id="more-menu">
<img src="/assets/icons/bars-solid.svg" height="19" aria-hidden="true" title="Open Menu" alt="Menu">
</li>
</ul>
</nav>
</div>
</header>
<nav class="queerty-menu-content">
<div class="queerty-menu-close"><img src="/assets/icons/times-solid.svg" height="19" aria-hidden="true" title="Close Menu" alt="Close"></i></div>
<div class="queerty-menu-logo"><img src="/assets/q-2017/queerty-logo.svg" width="100" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo"></div>
<div class="queerty-menu-searchbox">
<form role="search" method="get" class="search-form" action="https://www.queerty.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
<ul>
<li><a href="https://www.queerty.com/wp/wp-login.php?redirect_to=%2F%2Fwww.queerty.com%2Fmatt-gaetz-doesnt-think-hes-getting-due-thanks-helping-britney-spears-20210930" id="menu-login">Log in</a></li>
<li><a href="https://www.queerty.com/wp/wp-login.php?action=register" id="menu-register">Register</a></li>
</ul>
<div class="menu-now-on-queerty-container"><ul id="menu-now-on-queerty" class="menu"><li id="menu-item-581679" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-581679"><a href="https://www.queerty.com/pride50/">Pride50 2021</a></li>
<li id="menu-item-441445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441445"><a href="https://www.queerty.com/life">Life</a></li>
<li id="menu-item-441443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441443"><a href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li id="menu-item-441446" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-441446"><a href="https://www.queerty.com/politics">Politics</a></li>
<li id="menu-item-441444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441444"><a href="https://www.queerty.com/goods">Goods</a></li>
<li id="menu-item-574436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574436"><a href="https://www.queerty.com/podcast">Queerty Podcast</a></li>
<li id="menu-item-420168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-420168"><a href="//www.queerty.com/queerty-tv/">Video (Queerty TV)</a></li>
<li id="menu-item-504333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-504333"><a href="https://www.queerty.com/ever-after">Queerty Ever After</a></li>
<li id="menu-item-420166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-420166"><a href="https://www.queerty.com/dragaholic">Dragaholic</a></li>
<li id="menu-item-469065" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-469065"><a href="https://www.queerty.com/prepared">Prepared</a></li>
<li id="menu-item-573116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-573116"><a href="https://www.queerty.com/health">Health</a></li>
</ul></div>
<ul>
<li><a href="https://www.lgbtqnation.com/">LGBTQ Nation News</a></li>
<li><a href="https://www.gaycities.com/">GayCities Travel Guides</a></li>
</ul>
<ul>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
</ul>
<ul><li><a href="#" id="toggle-dark-mode">Toggle Dark Mode</a></li></ul>
</nav>
<div class="queerty-menu-fade-screen"></div>
<div id="content" class="site-content"> <div class="single-wrapper">
<div id="primary" class="content-area single-article ">
<main id="main" class="site-main" role="main">
<article id="post-590906" class="post-590906 post type-post status-publish format-standard has-post-thumbnail hentry category-ad-friendly category-politics category-queerty tag-britney-spears tag-matt-gaetz">
<header class="entry-header">
<div class="kicker ">priorities</div> <h1 class="entry-title"><a href="https://www.queerty.com/matt-gaetz-doesnt-think-hes-getting-due-thanks-helping-britney-spears-20210930"><span itemprop="headline">Matt Gaetz doesn’t think he’s getting due thanks for helping Britney Spears</span></a></h1>
<div class="entry-meta">
<span class="byline"> By <span itemprop="author"> <a href="https://www.queerty.com/author/david-hudson" title="Posts by David Hudson" rel="author">David Hudson</a></span></span> <time class="posted-on" itemprop="datePublished" datetime="2021-09-30T09:55:57-04:00">9 minutes ago</time> </div>
</header>
<div class="entry-content" itemprop="articleBody">
<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/13536/tag"></script><figure id="attachment_590910" aria-describedby="caption-attachment-590910" style="width: 670px" class="wp-caption aligncenter"><img loading="lazy" class="wp-image-590910 size-large" src="https://queerty-prodweb.s3.amazonaws.com/2021/09/britney_spears_matt_gaetz_shutterstock_c_span-1-670x355.jpg" alt="Britney Spears and Matt Gaetz" width="670" height="355" srcset="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/britney_spears_matt_gaetz_shutterstock_c_span-1-670x355.jpg?&amp;auto=format&amp;auto=compress&amp;w=670 670w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/britney_spears_matt_gaetz_shutterstock_c_span-1-670x355.jpg?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/britney_spears_matt_gaetz_shutterstock_c_span-1-670x355.jpg?&amp;auto=format&amp;auto=compress&amp;w=900 900w" sizes="(max-width: 670px) 100vw, 670px"><figcaption id="caption-attachment-590910" class="wp-caption-text">Britney Spears and <a href="https://www.queerty.com/tag/matt-gaetz">Matt Gaetz</a> (Photos: Shutterstock/YouTube)</figcaption></figure>
<p>Yesterday, a Los Angeles judge <a href="https://www.theguardian.com/music/2021/sep/29/britney-spears-father-removed-conservatorship-ruling-latest" target="_blank" rel="noopener">suspended Britney Spears’ father</a>, Jamie Spears, from his role in the singer’s ongoing conservatorship.</p>
<p>It’s the latest step in Britney’s attempts to end the legal arrangement that has controlled her life for the past 13 years.</p>
<p>Another hearing has been scheduled for November 12 which could see the conservatorship terminated completely.</p><div class="inline-ad-holder"><div id="div-gpt-ad-inarticle1"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle1"); });</script></div></div>
<p>Who should take credit for helping to extricate Britney for her guardianship? Well, Florida rep. Matt Gaetz would like to remind everyone that he’s been 100% behind Britney all the way.</p>
<p><strong>Related: <a href="https://www.queerty.com/matt-gaetzs-public-obsession-britney-spears-getting-legit-creepy-20210318">Matt Gaetz’s very public obsession with Britney Spears is getting legit creepy</a></strong></p>
<p>Yesterday, the Twitter account of a right-wing, Florida-based political rally, AmpFest, <a href="https://twitter.com/AMPFEST_USA/status/1443349793133244417?s=20" target="_blank" rel="noopener">tweeted</a>: “Great news! Jamie Spears suspended from @britneyspears’s conservatorship. #FreeBritney movement scored a strategic win today. When will the media and pop-culture gatekeepers thank @mattgaetz for drawing attention to this injustice?”</p>
<p>Gaetz himself was quick the re-tweet that message to the 1.1million people who follow his personal Twitter account.</p><div class="inline-ad-holder"><div id="div-gpt-ad-inarticle2"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle2"); });</script></div></div>
<figure id="attachment_590907" aria-describedby="caption-attachment-590907" style="width: 670px" class="wp-caption aligncenter"><img loading="lazy" class="wp-image-590907 size-large" src="https://queerty-prodweb.s3.amazonaws.com/2021/09/matt_gaetz_britney_tweet-670x187.jpg" alt="" width="670" height="187" srcset="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/matt_gaetz_britney_tweet-670x187.jpg?&amp;auto=format&amp;auto=compress&amp;w=670 670w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/matt_gaetz_britney_tweet-670x187.jpg?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/matt_gaetz_britney_tweet-670x187.jpg?&amp;auto=format&amp;auto=compress&amp;w=900 900w" sizes="(max-width: 670px) 100vw, 670px"><figcaption id="caption-attachment-590907" class="wp-caption-text">(Screenshot)</figcaption></figure>
<p>Back in March, Gaetz told Newsmax that as a “Millennial and a huge Britney Spears fan,” he felt compelled to highlight her plight. On Twitter, he urged his followers to call Rep. Jerry Nadler of New York, who serves as Chair of the House Judiciary, to tell him to #FreeBritney.</p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Call <a href="https://twitter.com/RepJerryNadler?ref_src=twsrc%5Etfw">@RepJerryNadler</a></p>
<p>We need a hearing on this. <a href="https://twitter.com/hashtag/FreeBritney?src=hash&amp;ref_src=twsrc%5Etfw">#FreeBritney</a> <a href="https://t.co/f7sjjGb3Nh">https://t.co/f7sjjGb3Nh</a></p>
<p>— Matt Gaetz (@mattgaetz) <a href="https://twitter.com/mattgaetz/status/1372517760069156874?ref_src=twsrc%5Etfw">March 18, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><br>
He also <a href="https://www.independent.co.uk/news/world/americas/us-politics/matt-gaetz-britney-spears-congress-b1876723.html" target="_blank" rel="noopener">sent a letter to Britney</a> inviting her to speak to Congress about the issue of conservatorships (she did not take him up on the offer) and posted several tweets <a href="https://twitter.com/mattgaetz/status/1369734852736585728?s=20" target="_blank" rel="noopener">attacking her father, Jamie Spears</a>.</p>
<p>At the same time, fans of the singer have been waging a #FreeBritney campaign in recent years, concerned that she did not have control over her own life and finances.</p><div class="inline-ad-holder"><div id="div-gpt-ad-inarticle3"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle3"); });</script></div></div>
<p>Until recently, Britney herself declined to publicly criticize the arrangement, but that has all changed in recent months. Yesterday’s decision comes three months after the singer pleaded with the court to remove her father.</p>
<p>This year, Britney was allowed to appoint her own attorney, who has been fighting on her behalf to make this happen. There have been also been two high-profile documentaries that have also highlighted her situation, alongside masses of media coverage.</p>
<p>In short, it’s highly likely that Britney would be winning her legal battles with or without Gaetz’s minor contribution: a point many on Twitter were quick to highlight.</p><div class="inline-ad-holder"><div id="div-gpt-ad-inarticle4"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle4"); });</script></div></div>
<blockquote class="twitter-tweet" data-conversation="none">
<p dir="ltr" lang="en">Um what? Britney’s fans have been fighting for her and bringing awareness to this for years. Also the documentary that was recently released helped bring mainstream attention. Gaetz had zero to do with it.</p>
<p>— CoCo🏳️‍🌈AbortionIsHealthcare (@SlaveFor_Jesus) <a href="https://twitter.com/SlaveFor_Jesus/status/1443355377882517513?ref_src=twsrc%5Etfw">September 29, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-conversation="none">
<p dir="ltr" lang="en">This has nothing to do with Matt Gaetz are you fucking joking? This is because of the fans. Period.</p>
<p>— Jaime Hageman (@JaimeHageman) <a href="https://twitter.com/JaimeHageman/status/1443353042808680451?ref_src=twsrc%5Etfw">September 29, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-conversation="none">
<p dir="ltr" lang="en">Matt, she’s not going to date you. This fawning is not unexpected, but yikes, bro.</p>
<p>— Christie Octavia (@christieoctave) <a href="https://twitter.com/christieoctave/status/1443352571767308294?ref_src=twsrc%5Etfw">September 29, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Related: <a href="https://www.queerty.com/matt-gaetz-wants-people-forget-teen-sex-scandal-really-stop-20210702">If Matt Gaetz wants people to forget about his teen sex scandal then he should really stop doing this</a></strong></p>
<p>Besides hyping up his role in the #FreeBritney movement, Gaetz had a busy day yesterday. He put on a big show of attempting to grill the military’s top advisers when they appeared before a hearing of the House Armed Services Committee.</p>
<p>Gaetz attempted to take Gen Mark Milley, Gen Frank McKenzie and Defense Secretary Lloyd Austin to task over the Afghanistan withdrawal: “If we didn’t have a president that was so addled, you all would be fired, because that is what you deserve.”</p><div class="inline-ad-holder"><div id="div-gpt-ad-inarticle5"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle5"); });</script></div></div>
<p>He also waved a copy of the book <em>Peril</em>, by journalists Bob Woodward and Robert Costa, in Milley’s face, saying, “You spent more time with Bob Woodward on this book than you spent analyzing the very likely prospect that the Afghanistan government was very likely to fall.”</p>
<p>Milley’s corrected him, saying, “not even close.” Regardless, Gaetz spent much of the afternoon retweeting messages congratulating himself on his performance.</p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">BREAKING: Rep. Matt Gaetz SLAMS Woke Generals Mark Milley, Lloyd Austin, and Kenneth McKenzie for Their Total Failure as the Leaders of the Armed Forces</p>
<p>“If we didn’t have a president that was so addled, you all would be fired. Because that is what you deserve.” <a href="https://t.co/09CSv3k5Rv">pic.twitter.com/09CSv3k5Rv</a></p>
<p>— Rep. Matt Gaetz (@RepMattGaetz) <a href="https://twitter.com/RepMattGaetz/status/1443258680825327617?ref_src=twsrc%5Etfw">September 29, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
</div>
<footer class="entry-footer">
<span class="tags-links"><a href="https://www.queerty.com/politics" rel="category">Politics</a> <a href="https://www.queerty.com/tag/britney-spears" rel="tag">Britney Spears</a> <a href="https://www.queerty.com/tag/matt-gaetz" rel="tag">Matt Gaetz</a></span><div class="comments-link-area"><a href="https://www.queerty.com/matt-gaetz-doesnt-think-hes-getting-due-thanks-helping-britney-spears-20210930#respond"><span class="comments-link">Add a comment</span></a></div> </footer>
</article>
</main>
<div class="article-email-prompt-red" id="queerty-article-email-prompt">
<h3><span class="asterisk"> </span>Get Queerty Daily</h3>
Subscribe to Queerty for a daily dose of #politics #britneyspears #mattgaetz stories and more
<form action="//queerty.us1.list-manage.com/subscribe/post?u=ecab442566f15d8d4dcf64b0d&amp;id=221c27272a" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank">
<input type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="Your email" autocomplete="email">
<input type="hidden" name="group[5437][16]" value="1">
<input type="hidden" value="2" name="group[5409][2]" id="mce-group[5409]-5409-0">
<input type="hidden" value="1" name="group[5409][1]" id="mce-group[5409]-5409-1">
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ecab442566f15d8d4dcf64b0d_221c27272a" tabindex="-1" value=""></div>
<input type="submit" value="Subscribe" name="submit" id="mc-embedded-subscribe" class="button">
</form>
</div>
<div style="width:90%; margin-left:auto; margin-right:auto;">
<h3 style="margin-bottom:4px;">Featured on Queerty TV</h3>
<script>
!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>
<script id="63359461e10348e1843f01215f3c4ead">
  cnxps.cmd.push(function () {
    cnxps({
      playerId: "461d6acb-cbff-447a-b4e7-ee9ee29c9631"
    }).render("63359461e10348e1843f01215f3c4ead");
  });
</script>
</div>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Add your Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/matt-gaetz-doesnt-think-hes-getting-due-thanks-helping-britney-spears-20210930#respond" style="display:none;">Cancel reply</a></small></h3><p class="nocomments">Please <a href="https://www.queerty.com/wp/wp-login.php?redirect_to=https%3A%2F%2Fwww.queerty.com%2Fmatt-gaetz-doesnt-think-hes-getting-due-thanks-helping-britney-spears-20210930">log in</a> to add your comment<br>Need an account? <strong><a href="https://www.queerty.com/wp/wp-login.php?action=register">Register</a></strong> *It's free and easy.</p> </div>
</div>
</div>
<script type="text/javascript" async="async" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-58640af04b28c97d"></script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.queerty.com\/matt-gaetz-doesnt-think-hes-getting-due-thanks-helping-britney-spears-20210930"},"headline":"Matt Gaetz doesn\u2019t think he\u2019s getting due thanks for helping Britney Spears","url":"https:\/\/www.queerty.com\/matt-gaetz-doesnt-think-hes-getting-due-thanks-helping-britney-spears-20210930","datePublished":"2021-09-30T09:55:57-04:00","dateModified":"2021-09-30T09:39:27-04:00","description":"Gaetz wants the world to know that he\u2019s the one helping to #freebritney.","thumbnailUrl":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/09\/britney_spears_matt_gaetz_shutterstock_c_span-1-307x289.jpg","image":{"@type":"ImageObject","url":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/09\/britney_spears_matt_gaetz_shutterstock_c_span-1-307x289.jpg","height":670,"width":355},"creator":"David Hudson","author":{"@type":"Person","name":"David Hudson"},"articleSection":"Politics","keywords":["Ad Friendly","Queerty","Britney Spears","Matt Gaetz","[ Has: Twitter embed ]","[ Has: Twitter embed (10+) ]","[ Word count: 600-1000 ]"],"publisher":{"@type":"NewsMediaOrganization","name":"Queerty","url":"https:\/\/www.queerty.com\/","logo":{"@type":"ImageObject","url":"https:\/\/www.queerty.com\/assets\/q-2017\/queerty-logo-225x60.png","height":"60","width":"225"},"address":{"@type":"PostalAddress","streetAddress":"584 Castro St. #623","addressLocality":"San Francisco","addressRegion":"CA","postalCode":"94114","addressCountry":"USA"},"sameAs":["https:\/\/en.wikipedia.org\/wiki\/Queerty","https:\/\/www.facebook.com\/queerty","https:\/\/www.twitter.com\/queerty","https:\/\/www.instagram.com\/queerty","https:\/\/www.youtube.com\/user\/queertyTV"]}}</script>
<aside id="secondary" class="article-sidebar" role="complementary">
<div class="sidebar-ad-1" id="div-gpt-ad-box1">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box1'); });
			</script>
</div>
<div id="q-video-player" style="display:none;"></div>
<section class="sidebar-related">
<h3 class="category-heading">
More in Politics </h3>
<div class="cards-list">
<article id="post-590872" class="card card-small ">
<a href="https://www.queerty.com/kristi-noem-super-craptastic-day-seems-getting-worse-20210929">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/03/kristi-noem-screenshot.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Kristi Noem is having a super craptastic day and it only seems to be getting worse">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">uh oh!</div>
<div class="card-commentcount">10 comments</div><h2 class="entry-title">Kristi Noem is having a super craptastic day and it only seems to be getting worse</h2> <div class="entry-meta">
<a href="https://www.queerty.com/kristi-noem-super-craptastic-day-seems-getting-worse-20210929" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-29T14:22:28-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-590842" class="card card-small ">
<a href="https://www.queerty.com/melania-used-hot-military-aides-make-trump-jealous-obsessed-self-care-scrapbooking-20210929">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/Screen-Shot-2021-09-29-at-10.50.07-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Melania used hot military aides to make Trump jealous, was obsessed with self-care and scrapbooking">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">a woman scorned</div>
<div class="card-commentcount">23 comments</div><h2 class="entry-title">Melania used hot military aides to make Trump jealous, was obsessed with self-care and scrapbooking</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-590771" class="card card-small ">
<a href="https://www.queerty.com/way-ivanka-tried-unsuccessfully-elbow-meeting-queen-elizabeth-peak-ivanka-20210928">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/07/ivanka-goya.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="The way Ivanka tried to unsuccessfully elbow a meeting with Queen Elizabeth is peak Ivanka">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">daddy's girl</div>
<div class="card-commentcount">7 comments</div><h2 class="entry-title">The way Ivanka tried to unsuccessfully elbow a meeting with Queen Elizabeth is peak Ivanka</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-590748" class="card card-small ">
<a href="https://www.queerty.com/new-tell-reveals-scarring-details-trumps-personal-habits-ew-ew-ew-ew-ew-20210928">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2018/02/donald-trump-mouthy.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="New tell-all reveals more scarring details about Trump&#8217;s personal habits and ew, ew, ew, ew, ew">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">reader discretion advised</div>
<div class="card-commentcount">32 </div><h2 class="entry-title">New tell-all reveals more scarring details about Trump&#8217;s personal habits and ew, ew, ew, ew, ew</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-2" id="div-gpt-ad-box2">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box2'); });
			</script>
</div>
<br>
<section class="sidebar-related">
<h3 class="category-heading">
Popular on Queerty
</h3>
<div class="cards-list">
<article id="post-590513" class="card card-small ">
<a href="https://www.queerty.com/billy-porter-just-paid-emotional-tribute-screen-legend-20210923">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/shutterstock_1583382004-1-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Billy Porter just paid an emotional tribute to this screen legend&#8230;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">in quotes</div>
<div class="card-commentcount">1.7K shares</div><h2 class="entry-title">Billy Porter just paid an emotional tribute to this screen legend&#8230;</h2> <div class="entry-meta">
<a href="https://www.queerty.com/billy-porter-just-paid-emotional-tribute-screen-legend-20210923" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-23T13:09:58-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-590558" class="card card-small gaycities-link">
<a target="_blank" href="https://www.gaycities.com/outthere/55395/sex-u-s-couples-married-abroad-share-beautiful-wedding-photos/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=Same-sex%2C+U.S.+couples+who+married+abroad+share+their+beautiful+wedding+photos">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/dennis_ronnie_-auroraphotoatl_1200_kiss.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Same-sex, U.S. couples who married abroad share their beautiful wedding photos">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">wanderlust</div>
<h2 class="entry-title">Same-sex, U.S. couples who married abroad share their beautiful wedding photos</h2> <div class="entry-meta">
<a href="https://www.queerty.com/sex-u-s-couples-married-abroad-share-beautiful-wedding-photos-20210924" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-24T09:35:47-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-590602" class="card card-small ">
<a href="https://www.queerty.com/absolutely-terrible-day-name-chris-pratt-belong-homophobic-church-20210924">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/10/chris-pratt-shutterstock.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="It&#8217;s an absolutely terrible day if your name is Chris Pratt and you belong to a homophobic church">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">not super</div>
<div class="card-commentcount">38 comments</div><h2 class="entry-title">It&#8217;s an absolutely terrible day if your name is Chris Pratt and you belong to a homophobic church</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-590508" class="card card-small ">
<a href="https://www.queerty.com/madison-cawthorns-openly-gay-challenger-just-released-damning-new-attack-ad-wow-20210923">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/10/madison-cawthorn-racist.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Madison Cawthorn&#8217;s openly gay challenger just released a damning new attack ad against him and, wow">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">claws out</div>
<div class="card-commentcount">45 comments</div><h2 class="entry-title">Madison Cawthorn&#8217;s openly gay challenger just released a damning new attack ad against him and, wow</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-590482" class="card card-small ">
<a href="https://www.queerty.com/leslie-jordan-shares-another-vintage-thirst-trap-time-70s-20210923">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/leslie_jordan_1977_shutterstock_instagram.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Leslie Jordan shares another vintage thirst trap &#8211; this time from the 70s">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">hunk</div>
<div class="card-commentcount">7 comments</div><h2 class="entry-title">Leslie Jordan shares another vintage thirst trap &#8211; this time from the 70s</h2> <div class="entry-meta">
<a href="https://www.queerty.com/leslie-jordan-shares-another-vintage-thirst-trap-time-70s-20210923" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-23T09:20:00-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-3" id="div-gpt-ad-box3">
<script>
		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box3'); });
		</script>
</div>
</aside>
<br clear=all>
<div class="single-bottom-articles">
<h3>
Latest on Queerty </h3>
<div class="single-bottom-articles-slider slider slick-slider">
<div><article id="post-590902" class="card card-small ">
<a href="https://www.queerty.com/dolly-parton-reacts-lil-nas-xs-version-jolene-20210930">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/dolly_parton_lil_nas_x_shutterstock_youtube.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Dolly Parton reacts to Lil Nas X’s version of ‘Jolene’">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">iconic</div>
<h2 class="entry-title">Dolly Parton reacts to Lil Nas X’s version of ‘Jolene’</h2> <div class="entry-meta">
<a href="https://www.queerty.com/dolly-parton-reacts-lil-nas-xs-version-jolene-20210930" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-30T09:45:33-04:00">19 minutes ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-590295" class="card card-small out-for-good-link">
<a href="https://www.queerty.com/people-around-world-celebrating-baseball-pro-bryan-ruby-coming-gay-20210930">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/bryan-ruby-1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="People around the world are celebrating baseball pro Bryan Ruby coming out as gay">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">home run</div>
<h2 class="entry-title">People around the world are celebrating baseball pro Bryan Ruby coming out as gay</h2> <div class="entry-meta">
<a href="https://www.queerty.com/people-around-world-celebrating-baseball-pro-bryan-ruby-coming-gay-20210930" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-30T09:00:55-04:00">1 hour ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-590894" class="card card-small ">
<a href="https://www.queerty.com/hedwig-creators-john-cameron-mitchell-stephen-trask-release-first-song-together-20-years-20210929">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/john-cameron-mitchell.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="&#8216;Hedwig&#8217; creators John Cameron Mitchell and Stephen Trask release first song together in 20 years">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">new american dream</div>
<h2 class="entry-title">&#8216;Hedwig&#8217; creators John Cameron Mitchell and Stephen Trask release first song together in 20 years</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-590882" class="card card-small ">
<a href="https://www.queerty.com/least-qualified-man-earth-just-rushed-r-kellys-defense-20210929">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/r.kelly_.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="The least qualified man on earth just rushed to R. Kelly&#8217;s defense">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">yikes</div>
<div class="card-commentcount">7 comments</div><h2 class="entry-title">The least qualified man on earth just rushed to R. Kelly&#8217;s defense</h2> <div class="entry-meta">
<a href="https://www.queerty.com/least-qualified-man-earth-just-rushed-r-kellys-defense-20210929" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-29T15:34:57-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-590872" class="card card-small ">
<a href="https://www.queerty.com/kristi-noem-super-craptastic-day-seems-getting-worse-20210929">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/03/kristi-noem-screenshot.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Kristi Noem is having a super craptastic day and it only seems to be getting worse">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">uh oh!</div>
<div class="card-commentcount">10 comments</div><h2 class="entry-title">Kristi Noem is having a super craptastic day and it only seems to be getting worse</h2> <div class="entry-meta">
<a href="https://www.queerty.com/kristi-noem-super-craptastic-day-seems-getting-worse-20210929" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-29T14:22:28-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-590401" class="card card-small lgbtqnation-link">
<a target="_blank" href="https://www.lgbtqnation.com/LGBTQ-Heroes-2021/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=Vote+now+for+your+LGBTQ+Hero+of+2021">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/lgbtq-nation-heroes-composite.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Vote now for your LGBTQ Hero of 2021">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">who made you proud?</div>
<h2 class="entry-title">Vote now for your LGBTQ Hero of 2021</h2> <div class="entry-meta">
<a href="https://www.queerty.com/vote-now-lgbtq-hero-2021-20210929" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-29T13:40:03-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-590861" class="card card-small ">
<a href="https://www.queerty.com/venom-sequel-director-teases-films-big-coming-scene-20210929">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/tom-hardy-venom.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="&#8216;Venom&#8217; sequel director teases the film&#8217;s big &#8220;coming out&#8221; scene">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">say what?</div>
<div class="card-commentcount">9 comments</div><h2 class="entry-title">&#8216;Venom&#8217; sequel director teases the film&#8217;s big &#8220;coming out&#8221; scene</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-590862" class="card card-small into-link">
<a href="https://www.intomore.com/tv/american-crime-story-impeachment-gets-toxic-90s-diet-culture-right/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=How+%26%238220%3BAmerican+Crime+Story%3A+Impeachment%26%238221%3B+gets+toxic+90s+diet+culture+right">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/pre_a337a5c154e2e6d6d4ae1ff123e2bacb.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="How &#8220;American Crime Story: Impeachment&#8221; gets toxic 90s diet culture right">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">tv dinner</div>
<h2 class="entry-title">How &#8220;American Crime Story: Impeachment&#8221; gets toxic 90s diet culture right</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-590850" class="card card-small dragaholic-link">
<a href="https://www.queerty.com/comedian-jose-antonio-badia-comes-bisexual-reveals-fabulous-new-drag-persona-20210929">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/Screen-Shot-2021-09-29-at-11.57.32-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Comedian José Antonio Badía comes out as bisexual and reveals his fabulous new drag persona">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Closet door bustdown</div>
<h2 class="entry-title">Comedian José Antonio Badía comes out as bisexual and reveals his fabulous new drag persona</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-590848" class="card card-small ">
<a href="https://www.queerty.com/ben-whishaw-wants-gay-james-bond-knows-just-right-actors-job-20210929">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/La-Perla-Swimming-Trunks-640x277-1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Ben Whishaw wants a gay James Bond and knows just the right actors for the job">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">in quotes</div>
<div class="card-commentcount">36 comments</div><h2 class="entry-title">Ben Whishaw wants a gay James Bond and knows just the right actors for the job</h2> <div class="entry-meta">
<a href="https://www.queerty.com/ben-whishaw-wants-gay-james-bond-knows-just-right-actors-job-20210929" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-29T12:33:55-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-590842" class="card card-small ">
<a href="https://www.queerty.com/melania-used-hot-military-aides-make-trump-jealous-obsessed-self-care-scrapbooking-20210929">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/Screen-Shot-2021-09-29-at-10.50.07-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Melania used hot military aides to make Trump jealous, was obsessed with self-care and scrapbooking">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">a woman scorned</div>
<div class="card-commentcount">23 comments</div><h2 class="entry-title">Melania used hot military aides to make Trump jealous, was obsessed with self-care and scrapbooking</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-590835" class="card card-small ">
<a href="https://www.queerty.com/watch-marching-band-pays-amazing-tribute-universitys-lgbtq-center-20210929">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/michigan_marching_band_twitter.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="WATCH: Marching band pays amazing tribute to university’s LGBTQ center">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">marching together</div>
<h2 class="entry-title">WATCH: Marching band pays amazing tribute to university’s LGBTQ center</h2> <div class="entry-meta">
<a href="https://www.queerty.com/watch-marching-band-pays-amazing-tribute-universitys-lgbtq-center-20210929" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-29T09:50:42-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</div>
</div></div>
</div>
<div class="site-footer-holder">
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="footer-brand">
<span class="asterisk"> </span> Free of an agenda (except that gay one)
</div>
<div class="tags-links">
<a href="//www.queerty.com/tag/andy-cohen">Andy Cohen</a> <a href="//www.queerty.com/tag/bowen-yang">Bowen Yang</a> <a href="//www.queerty.com/tag/colton-underwood">Colton Underwood</a> <a href="//www.queerty.com/tag/conrad-rocha">Conrad Rocha</a> <a href="//www.queerty.com/tag/gus-kenworthy">Gus Kenworthy</a> <a href="//www.queerty.com/tag/janet-mock">Janet Mock</a> <a href="//www.queerty.com/tag/lil-nas-x">Lil Nas X</a> <a href="//www.queerty.com/tag/ricky-martin">Ricky Martin</a> <a href="//www.queerty.com/tag/russell-tovey">Russell Tovey</a> <a href="//www.queerty.com/tag/ryan-murphy">Ryan Murphy</a> <div class="second-row">
<a href="//www.queerty.com/tag/homophobia">Homophobia</a> <a href="//www.queerty.com/tag/racism">Racism</a> <a href="//www.queerty.com/tag/rupaul's-drag-race">Rupaul's Drag Race</a> <a href="//www.queerty.com/tag/matt-gaetz">Matt Gaetz</a> <a href="//www.queerty.com/tag/transphobia">Transphobia</a> <a href="//www.queerty.com/tag/relationships">Relationships</a> <a href="//www.queerty.com/tag/grindr">Grindr</a>
</div>
</div>
<div class="footer-links">
<ul class="main" id="footer-company-links">
<li><a href="http://www.q.digital"><img src="/assets/q-digital-blue-90x37.png" alt="Q.digital" width="90"></a></li>
<li><b>A Q.Digital Company</b></li>
<li>&copy; 2021 Queerty, Inc.</li>
<li><a href="http://www.q.digital">Advertise With Us</a></li>
</ul>
<ul class="main" id="footer-contact-links">
<li><h3>Contact</h3></li>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
<li><a href="https://www.queerty.com/queertys-comment-policy">Comments Policy</a>
<li><a href="https://www.queerty.com/privacy-policy">Privacy Statement</a>
<li><a href="https://www.queerty.com/terms-of-use">Terms of Use</a>
<li><a id="ccpaOptOut">Do Not Sell My Personal Information</a>
</ul>
<ul class="main" id="footer-follow-links">
<li><h3>Follow</h3></li>
<li><a href="https://www.facebook.com/Queerty/">Facebook</a></li>
<li><a href="https://www.twitter.com/Queerty/">Twitter</a></li>
<li><a href="https://www.instagram.com/Queerty/">Instagram</a></li>
<li><a href="https://www.youtube.com/user/QueertyTV/">YouTube</a></li>
</ul>
<ul class="main double" id="footer-gaycities-links">
<li><h3>GayCities: Your Gay Travel Guide:</h3></li>
<li><a href="https://newyork.gaycities.com/">New York</a></li>
<li><a href="https://london.gaycities.com/">London</a></li>
<li><a href="https://sanfrancisco.gaycities.com/">San Francisco</a></li>
<li><a href="https://chicago.gaycities.com/">Chicago</a></li>
<li><a href="https://losangeles.gaycities.com/">Los Angeles</a></li>
<li><a href="https://washingtondc.gaycities.com/">Washington DC</a></li>
<li><a href="https://dallas.gaycities.com/">Dallas</a></li>
<li><a href="https://saskatoon.gaycities.com/">Gay Saskatoon</a></li>
<li><a href="https://www.gaycities.com/places/"><b>See all 230+ cities...</b></a></li>
</ul>
</div>
</footer>
</div>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "32666898" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=32666898&cv=2.0&cj=1" alt="Comscore Measurement" />
</noscript>

<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '686853021424163');
  fbq('track', 'PageView');
</script>
<noscript><img height='1' width='1' style='display:none'
  src='https://www.facebook.com/tr?id=686853021424163&ev=PageView&noscript=1'
/></noscript>

<script>
  fbq('track', 'ViewContent');
</script>
<script>
	window.dataLayer = window.dataLayer || []
	dataLayer.push({
	   'event': 'Page Details',
	   'pageType': 'article',
	   'pageCategory': 'politics'
	   
	});
	</script>
<script type="text/javascript">var algolia = {"debug":false,"application_id":"6S92GABH7H","search_api_key":"cfd5e12cdf4a6106712391cbcf54f087","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"queerty_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"queerty_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]}}};</script><script type='text/javascript' src='https://q-digital.videoplayerhub.com/galleryplayer.js?ver=20201101' id='bt-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/comment-reply.min.js?ver=5.8.1' id='comment-reply-js'></script>
<script type='text/javascript' async src='https://platform.twitter.com/widgets.js?ver=20161216' id='twitter-js-js'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js?ver=5.8.1' id='slick-js'></script>
<script type='text/javascript' async src='https://www.queerty.com/content/themes/queerty_2017/js/min/queerty-nosticky-min.js?ver=20210712a' id='queerty_2017-main-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/wp-embed.min.js?ver=5.8.1' id='wp-embed-js'></script>
<script data-cfasync="false" id="parsely-cfg" data-parsely-site="queerty.com" src="https://cdn.parsely.com/keys/queerty.com/p.js"></script>
</body>
</html>