<!DOCTYPE html>
<html>
<head>
<script type="text/javascript" src="//digg7anmcfked.cloudfront.net/script.js"></script>
<link rel="stylesheet" href="https://use.typekit.net/cdb4vyt.css">
<meta name="viewport" content="width=device-width, initial-scale=1">

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
</script>

<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.2634970.min.js?cachebuster=1';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      // Return control to GPT if the AdBridg library fails to load.
      adb.onerror = function() {
        console.log('Fallback: ')
        if (AdBridg.exists) { return; }
        document.createElement('IMG').src = '//adspsp.com/pt/2634970/3/1/?e=0';
        var dq = [], es;
        dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
        AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
        AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
        AdBridg.destroySlots = function(s) { return googletag.destroySlots(s); }
        AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
        AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
        AdBridg.render = function() { }
        AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
        AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
        AdBridg.useSizeMapping = function() { }
        AdBridg.cmd.push = function(f) {
          if (typeof(f)=='object') {
            var api_fallback = function(o) {
              googletag.cmd.push(function() {
                var u=AdBridg.defineSlot(o.gpt_path,o.size||[],o.dom_id);
                if(o.size_map) {
                  var m = googletag.sizeMapping();
                  for(var oi=0;oi<o.size_map.length;oi++){m=m.addSize(o.size_map[oi].viewport, o.size_map[oi].sizes);}
                  u.defineSizeMapping(m.build());
                }
                if(o.events) {
                  if(o.events["gpt.defined"]){o.events["gpt.defined"](u);}
                  var fl = function(a,b){if(o.events[a]){googletag.pubads().addEventListener(b,function(e){if(e.slot===u){o.events[a](u,e)}})}}
                  fl("gpt.rendered",'slotRenderEnded');
                  fl("gpt.viewed",'impressionViewable');
                  fl("gpt.visibilityChanged",'slotVisibilityChanged');
                }
              });
            }
            if(f.length){for(var i=0;i<f.length;++i){api_fallback(f[i]);}}else{api_fallback(f);}
            f=function(){AdBridg.serve()}
          }
          return googletag.cmd.push(f);
        }
        while (AdBridg.cmd.length) { AdBridg.cmd.push(AdBridg.cmd.shift()); }
      }
  })();
AdBridg.cmd.push({
	action: 'spa_pv_initialize',
	config: {
		footer_sticky: false,
		qd_path: '/4564944/queerty/life/article'
	}
});
</script>
<script>
AdBridg.cmd.push(function () {
	googletag.pubads().collapseEmptyDivs();
	googletag.pubads().setTargeting('articleid', ['584862']);
	googletag.pubads().setTargeting('Tag', ['articlepage','pastor','preacher','wilton manors','ad friendly','life','queerty']);
	googletag.pubads().setTargeting('UGC', ['no']);
  });
</script>
<script>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</script>
<title>Texas, Baptist preacher celebrates gay man’s death at Wilton Manors Pride / Queerty</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//powerad.ai' />
<link rel='dns-prefetch' href='//q-digital.videoplayerhub.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Feed" href="https://www.queerty.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Comments Feed" href="https://www.queerty.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Texas, Baptist preacher celebrates gay man’s death at Wilton Manors Pride Comments Feed" href="https://www.queerty.com/texas-baptist-preacher-celebrates-gay-mans-death-wilton-manors-pride-20210623/feed" />
<link rel='stylesheet' id='queerty_2017-style-css' href='https://www.queerty.com/content/themes/queerty_2017/style.css?ver=20210608a' type='text/css' media='all' />
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://powerad.ai/script.js?ver=20201101' id='nxtm-js'></script>
<link rel="canonical" href="https://www.queerty.com/texas-baptist-preacher-celebrates-gay-mans-death-wilton-manors-pride-20210623" />
<meta property="og:site_name" content="Queerty" /><meta name="twitter:card" content="summary_large_image"> <meta name="description" content="“You say, ‘Are you sad when f*gs die?’ No, I think it’s great..." />
<meta property="og:description" content="“You say, ‘Are you sad when f*gs die?’ No, I think it’s great...">
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.queerty.com/texas-baptist-preacher-celebrates-gay-mans-death-wilton-manors-pride-20210623" />
<meta property="og:title" content="Texas, Baptist preacher celebrates gay man’s death at Wilton Manors Pride" />
<meta property="og:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/stedfast_church_you_tube.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=1200&h=630&wat=1&wat_gravity=southeast&wat_pad=70" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta name="twitter:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/stedfast_church_you_tube.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=1200&h=630&wat=1&wat_gravity=southeast&wat_pad=70" />
<meta name="publish_date" property="article:published_time" content="2021-06-23T09:50:47-04:00" />
<meta property="article:modified_time" content="2021-06-23T06:54:51-04:00" />
<meta name="twitter:url" content="https://www.queerty.com/texas-baptist-preacher-celebrates-gay-mans-death-wilton-manors-pride-20210623" />
<meta name="twitter:title" content="Texas, Baptist preacher celebrates gay man’s death at Wilton Manors Pride" />
<meta name="twitter:description" content="“You say, ‘Are you sad when f*gs die?’ No, I think it’s great..." />
<meta name="news_keywords" content="pastor, preacher, wilton manors"><meta property="article:tags" content="pastor, preacher, wilton manors"><meta name="author" property="author" content="David Hudson" /><meta name="twitter:label1" content="By"><meta name="twitter:data1" content="David Hudson"> <style>
            #tps_carousel_container ._button,
            #tps_carousel_container ._button svg {
                color: #f08100;
                fill: #f08100;
            }

            #tps_carousel_container ._button {
                font-size: 32px;
                line-height: 32px;
            }

            #tps_carousel_container ._button svg {
                width: 32px;
                height: 32px;
            }

            #tps_carousel_container ._button:hover,
            #tps_carousel_container ._button:focus,
            #tps_carousel_container ._button:hover svg,
            #tps_carousel_container ._button:focus svg {
                color: #ffa338;
                fill: #ffa338;
            }

            #tps_carousel_container ._disabled,
            #tps_carousel_container ._disabled svg {
                color: #777777 !important;
                fill: #777777 !important;
            }

            #tps_carousel_container ._carousel {
                margin: 0 42px;
            }

            #tps_carousel_container ._prev {
                margin-right: 10px;
            }

            #tps_carousel_container ._next {
                margin-left: 10px;
            }
        </style>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KRQPBJR');</script>

<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://www.queerty.com/wp");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '2269d7e8-77de-42f4-85e0-e16c905e72b8';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Queerty";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing!";
oneSignal_options['welcomeNotification']['url'] = "https://www.queerty.com/";
oneSignal_options['path'] = "https://www.queerty.com/content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.32a023df-3e37-4c19-843f-3978a63a946e";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = "Queerty";
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = "Titles of Breaking Stories Will Appear Here";
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = "Queerty";
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
<link rel="preconnect" href="https://queerty-assets.s3.amazonaws.com">
<link rel="preload" href="https://www.googletagservices.com/tag/js/gpt.js">
<link rel="preconnect" href="https://www.googletagmanager.com">
<link rel="preconnect" href="https://queerty-prodweb.imgix.net">
<meta property="fb:app_id" content="153299894806318" />
<meta name="theme-color" content="#f43700" />
<meta name="apple-itunes-app" content="app-id=1046987164">
<meta property="fb:pages" content="33720334139" />
<meta name="apple-mobile-web-app-title" content="Queerty*">
<meta name="application-name" content="Queerty*">
<meta name="msapplication-config" content="/assets/q-2017/favicons/browserconfig.xml?v=lkgzj5W5Gl">
<link rel="apple-touch-icon" sizes="180x180" href="/assets/q-2017/favicons/apple-touch-icon.png?v=lkgzj5W5Gl">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-32x32.png?v=lkgzj5W5Gl" sizes="32x32">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-16x16.png?v=lkgzj5W5Gl" sizes="16x16">
<link rel="manifest" href="/assets/q-2017/favicons/manifest.json?v=20180829">
<link rel="mask-icon" href="/assets/q-2017/favicons/safari-pinned-tab.svg?v=lkgzj5W5Gl" color="#5bbad5">
<link rel="shortcut icon" href="/assets/q-2017/favicons/favicon.ico?v=lkgzj5W5Gl">
<meta property="article:publisher" content="https://www.facebook.com/queerty" />
<style>
.ad-leaderboard-header {
	background-color:transparent !important;
	position:relative;
	margin-top:10px;
}
.queerty-header {
	padding-top:10px !important;
}
@media screen and (max-height: 769px) {
	.queerty-header {
    	min-height: 4.688rem;
    	padding: 10px 0 10px !important;
	}
}
</style>
</head>
<body class="post-template-default single single-post postid-584862 single-format-standard category-ad-friendly category-life category-queerty">
<div id="top-of-page" style="display:none;"></div>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRQPBJR"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="div-gpt-ad-sidebarvideoplayer" style="height:1px;width:1px;">
<script>
		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-sidebarvideoplayer'); });
		</script>
</div>
<div id="page" class="site">
<div class="ad-leaderboard-header" id="div-gpt-ad-leader1">
<script>
				AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-leader1'); });
				</script>
</div>

<div id="is-phone"></div>

<header id="masthead" class="queerty-header">
<div class="queerty-header-wrapper">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="js-header-main-menu" class="queerty-header-menu show">
<li class="nav-link "><a href="/">Latest</a>
</li>
<li class="nav-link navcat-life selected"><a class="scroll-on-page-link" data-scroll="category-life" href="https://www.queerty.com/life">Life</a></li>
<li class="nav-link navcat-entertainment "><a class="scroll-on-page-link" data-scroll="category-entertainment" href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li class="nav-link navcat-politics "><a class="scroll-on-page-link" data-scroll="category-politics" href="https://www.queerty.com/politics">Politics</a></li>
<li class="nav-link navcat-pride"><a href="/pride50">Pride50</a></li>
</ul>
</nav>
<div class="logo-area">
<a href="/" class="queerty-logo"><!-- -->
<img src="/assets/q-2017/queerty-logo.svg" width="275" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo">
<img src="/assets/promos/pride/2019/queerty-pride.svg" width="275" alt="Queerty* Pride" class="queerty-header-pride-logo" style="display:none;">
</a>
</div>
<nav id="right-navigation" class="secondary-navigation" role="navigation">
<ul id="js-header-secondary-menu" class="queerty-header-menu show">
<li class="nav-link">
<a href="https://www.facebook.com/Queerty/"><img src="/assets/icons/facebook-f-icon.svg" height="19" aria-hidden="true" alt="Facebook"></a>
</li>
<li class="nav-link">
<a href="https://twitter.com/queerty"><img src="/assets/icons/twitter-icon.svg" height="19" aria-hidden="true" alt="Twitter"></a>
</li>
<li class="nav-link">
<a href="https://www.instagram.com/queerty/"><img src="/assets/icons/instagram-icon.svg" height="19" aria-hidden="true" alt="Instagram"></a>
</li>
<li class="nav-link">
<a href="https://www.youtube.com/queerty/"><img src="/assets/icons/youtube-icon.svg" height="19" aria-hidden="true" alt="YouTube"></a>
</li>
<li class="nav-link">
<a href="https://www.queerty.com/podcast/"><img src="/assets/icons/podcast-icon.svg" height="19" aria-hidden="true" alt="YouTube"></a>
</li>
<li class="nav-link">
<a href="https://eepurl.com/RrfMf"><img src="/assets/icons/envelope-regular.svg" height="19" aria-hidden="true" alt="newsletter"></a>
</li>
<li class="nav-link queerty-menu-button" id="more-menu">
<img src="/assets/icons/bars-solid.svg" height="19" aria-hidden="true" title="Open Menu" alt="Menu">
</li>
</ul>
</nav>
</div>
</header>
<nav class="queerty-menu-content">
<div class="queerty-menu-close"><img src="/assets/icons/times-solid.svg" height="19" aria-hidden="true" title="Close Menu" alt="Close"></i></div>
<div class="queerty-menu-logo"><img src="/assets/q-2017/queerty-logo.svg" width="100" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo"></div>
<div class="queerty-menu-searchbox">
<form role="search" method="get" class="search-form" action="https://www.queerty.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
<ul>
<li><a href="https://www.queerty.com/wp/wp-login.php?redirect_to=%2F%2Fwww.queerty.com%2Ftexas-baptist-preacher-celebrates-gay-mans-death-wilton-manors-pride-20210623" id="menu-login">Log in</a></li>
<li><a href="https://www.queerty.com/wp/wp-login.php?action=register" id="menu-register">Register</a></li>
</ul>
<div class="menu-now-on-queerty-container"><ul id="menu-now-on-queerty" class="menu"><li id="menu-item-581679" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-581679"><a href="https://www.queerty.com/pride50/">Pride50 2021</a></li>
<li id="menu-item-441445" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-441445"><a href="https://www.queerty.com/life">Life</a></li>
<li id="menu-item-441443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441443"><a href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li id="menu-item-441446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441446"><a href="https://www.queerty.com/politics">Politics</a></li>
<li id="menu-item-441444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441444"><a href="https://www.queerty.com/goods">Goods</a></li>
<li id="menu-item-574436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574436"><a href="https://www.queerty.com/podcast">Queerty Podcast</a></li>
<li id="menu-item-420168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-420168"><a href="//www.queerty.com/queerty-tv/">Video (Queerty TV)</a></li>
<li id="menu-item-504333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-504333"><a href="https://www.queerty.com/ever-after">Queerty Ever After</a></li>
<li id="menu-item-420166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-420166"><a href="https://www.queerty.com/dragaholic">Dragaholic</a></li>
<li id="menu-item-469065" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-469065"><a href="https://www.queerty.com/prepared">Prepared</a></li>
<li id="menu-item-573116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-573116"><a href="https://www.queerty.com/health">Health</a></li>
</ul></div>
<ul>
<li><a href="https://www.lgbtqnation.com/">LGBTQ Nation News</a></li>
<li><a href="https://www.gaycities.com/">GayCities Travel Guides</a></li>
</ul>
<ul>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
</ul>
</nav>
<div class="queerty-menu-fade-screen"></div>
<div id="content" class="site-content"> <div class="single-wrapper">
<div id="primary" class="content-area single-article ">
<main id="main" class="site-main" role="main">
<article id="post-584862" class="post-584862 post type-post status-publish format-standard has-post-thumbnail hentry category-ad-friendly category-life category-queerty tag-pastor tag-preacher tag-wilton-manors">
<header class="entry-header">
<div class="kicker ">vile</div> <h1 class="entry-title"><a href="https://www.queerty.com/texas-baptist-preacher-celebrates-gay-mans-death-wilton-manors-pride-20210623"><span itemprop="headline">Texas, Baptist preacher celebrates gay man’s death at Wilton Manors Pride</span></a></h1>
<div class="entry-meta">
<span class="byline"> By <span itemprop="author"> <a href="https://www.queerty.com/author/david-hudson" title="Posts by David Hudson" rel="author">David Hudson</a></span></span> <time class="posted-on" itemprop="datePublished" datetime="2021-06-23T09:50:47-04:00">6 minutes ago</time> </div>
</header>
<div class="entry-content" itemprop="articleBody">
<figure id="attachment_584863" aria-describedby="caption-attachment-584863" style="width: 670px" class="wp-caption aligncenter"><img loading="lazy" class="wp-image-584863 size-large" src="https://queerty-prodweb.s3.amazonaws.com/2021/06/stedfast_church_you_tube-670x355.jpg" alt="Pastor Jonathan Shelley gives a sermon celebrating people being killed at Pride parades" width="670" height="355" srcset="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/stedfast_church_you_tube-670x355.jpg?&amp;auto=format&amp;auto=compress&amp;w=670 670w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/stedfast_church_you_tube-670x355.jpg?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/stedfast_church_you_tube-670x355.jpg?&amp;auto=format&amp;auto=compress&amp;w=900 900w" sizes="(max-width: 670px) 100vw, 670px"><figcaption id="caption-attachment-584863" class="wp-caption-text">Pastor Jonathan Shelley (Photo: Twitter)</figcaption></figure>
<p>Video of a Baptist preacher in Texas welcoming the death of a man last weekend at Wilton Manors Pride has appeared online.</p>
<p>The video was originally posted by Stedfast Baptist Church in Hurst, near Fort Worth. Its pastor is named Jonathan Shelley. The church’s YouTube channel carries a wealth of videos denouncing LGBTQ people and Pride Month, with some claiming the Bible prescribes the death penalty for homosexuals.</p>
<p><strong>Related: <a href="https://www.queerty.com/wilton-manors-pride-truck-tragedy-victims-driver-77-members-gay-mens-chorus-20210621">Wilton Manors Pride truck tragedy: Victims and driver, 77, all members of Gay Men’s Chorus</a></strong></p><div class="ad-300 inline" id="div-gpt-ad-inarticle1"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle1"); });</script></div>
<p>In this particular video, Shelley says, “It is going beyond just saying you do all this wicked stuff. It’s saying you <em>enjoy</em> it. You enjoy murder. You enjoy malignity. You enjoy hating God.</p>
<p>“Look, there’s only one group that enjoys that: It’s the Pride parades going up and down the street.</p>
<p>“And, you know, it’s great when trucks accidentally go through those, you know, parades. I think only one person died. So hopefully we can hope for more in the future.</p>
<p>“You say, ‘Well, that’s <em>mean</em>.’ Yeah, but the Bible says that they’re worthy of death! You say, ‘Are you sad when fags die?’ No, I think it’s <em>great</em>!</p><div class="ad-300 inline" id="div-gpt-ad-inarticle2"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle2"); });</script></div>
<p>“I hope they <em>all</em> die! I would love it if every fag would die right now. And you say, ‘Well, I don’t think that’s what you really mean.’ That’s <em>exactly</em> what I mean. I <em>really</em> mean it!”</p>
<p>The Stedfast Church video, which appears to have now been deleted from YouTube, was captured and posted to Twitter by Hemant Mehta of <a href="https://friendlyatheist.patheos.com/2021/06/21/hate-preacher-celebrates-death-of-gay-man-at-pride-parade-i-hope-they-all-die/" target="_blank" rel="noopener">The Friendly Atheist</a>.</p>
<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Yesterday, a Christian hate-preacher from Texas celebrated a gay man’s death at a Pride parade.</p>
<p>“It’s great when trucks accidentally go through those… parades… We can hope for more in the future… I think it’s great! I hope they all die!”</p>
<p>(Warning: The language gets worse) <a href="https://t.co/3VsYC8KmjA">pic.twitter.com/3VsYC8KmjA</a></p>
<p>— Hemant Mehta (@hemantmehta) <a href="https://twitter.com/hemantmehta/status/1407022458595643392?ref_src=twsrc%5Etfw">June 21, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>According to Mehta, Shelley’s church is affiliated with the infamous “death to gays” Pastor Steven Anderson.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle3"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle3"); });</script></div>
<p><strong>Related: <a href="https://www.queerty.com/antigay-pastor-steven-anderson-says-victims-of-paris-attacks-worshipped-death-and-therefore-deserved-to-die-20151117">Antigay Pastor Steven Anderson says victims of Paris attacks worshipped death and therefore deserved to die</a></strong></p>
<p>At Wilton Manors Stonewall Parade on Saturday, a man lost control of his truck. It accelerated and hit others in the parade. Two men were rushed to hospital, where one was pronounced dead. It was later revealed that both driver and victims were members of the Fort Lauderdale Gay Men’s Chorus.</p>
<p>The man who died has been identified as James Fahy, aged 75. The driver has been named by police as Fred Johnson Jr, 77. Johnson released a statement Monday evening saying, “This was a horrible accident and I offer my sincere regrets to all those who were impacted by this tragic event.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle4"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle4"); });</script></div>
<p>“I love my Chorus family and the community and would never do anything to intentionally harm anyone.</p>
<p>“Please know that I hold my fellow Chorus member, Jim Fahy, in my heart forever and offer my condolences to his friends and family.’</p>
<p>Johnson continues to assist the police with their investigation.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle5"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle5"); });</script></div>
<p>Although Shelley’s so-called sermon appears to have now been deleted from YouTube, the Stedfast church’s channel, which has almost 10k subscribers, continues to host videos denouncing Pride Month. It posted <a href="https://www.youtube.com/watch?v=DB_e56dz7P4" target="_blank" rel="noopener">another one</a> yesterday. The historic news clip showed one of the church’s other pastors saying that the murders that took place at Pulse in Orlando in 2016 shouldn’t be considered a tragedy.</p>
<p> </p>
<p> </p>
</div>
<footer class="entry-footer">
<span class="tags-links"><a href="https://www.queerty.com/life" rel="category">Life</a> <a href="https://www.queerty.com/tag/pastor" rel="tag">pastor</a> <a href="https://www.queerty.com/tag/preacher" rel="tag">preacher</a> <a href="https://www.queerty.com/tag/wilton-manors" rel="tag">wilton manors</a></span><div class="comments-link-area"><a href="https://www.queerty.com/texas-baptist-preacher-celebrates-gay-mans-death-wilton-manors-pride-20210623#respond"><span class="comments-link">Add a comment</span></a></div> </footer>
</article>
</main>
<div class="article-email-prompt-red" id="queerty-article-email-prompt">
<h3><span class="asterisk"> </span>Get Queerty Daily</h3>
Subscribe to Queerty for a daily dose of #life #pastor #preacher stories and more
<form action="//queerty.us1.list-manage.com/subscribe/post?u=ecab442566f15d8d4dcf64b0d&amp;id=221c27272a" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank">
<input type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="Your email" autocomplete="email">
<input type="hidden" name="group[5437][16]" value="1">
<input type="hidden" value="2" name="group[5409][2]" id="mce-group[5409]-5409-0">
<input type="hidden" value="1" name="group[5409][1]" id="mce-group[5409]-5409-1">
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ecab442566f15d8d4dcf64b0d_221c27272a" tabindex="-1" value=""></div>
<input type="submit" value="Subscribe" name="submit" id="mc-embedded-subscribe" class="button">
</form>
</div>
<div style="margin-left:auto; margin-right:auto; text-align: center;" id="div-gpt-ad-box5">
<script>
	AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box5'); });
	</script>
</div>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Add your Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/texas-baptist-preacher-celebrates-gay-mans-death-wilton-manors-pride-20210623#respond" style="display:none;">Cancel reply</a></small></h3><p class="nocomments">Please <a href="https://www.queerty.com/wp/wp-login.php?redirect_to=https%3A%2F%2Fwww.queerty.com%2Ftexas-baptist-preacher-celebrates-gay-mans-death-wilton-manors-pride-20210623">log in</a> to add your comment<br>Need an account? <strong><a href="https://www.queerty.com/wp/wp-login.php?action=register">Register</a></strong> *It's free and easy.</p> </div>
</div>
</div>
<script type="text/javascript" async="async" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-58640af04b28c97d"></script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.queerty.com\/texas-baptist-preacher-celebrates-gay-mans-death-wilton-manors-pride-20210623"},"headline":"Texas, Baptist preacher celebrates gay man\u2019s death at Wilton Manors Pride","url":"https:\/\/www.queerty.com\/texas-baptist-preacher-celebrates-gay-mans-death-wilton-manors-pride-20210623","datePublished":"2021-06-23T09:50:47-04:00","dateModified":"2021-06-23T06:54:51-04:00","description":"\u201cYou say, \u2018Are you sad when f*gs die?\u2019 No, I think it\u2019s great!\u201d","thumbnailUrl":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/06\/stedfast_church_you_tube-307x289.jpg","image":{"@type":"ImageObject","url":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/06\/stedfast_church_you_tube-307x289.jpg","height":670,"width":355},"creator":"David Hudson","author":{"@type":"Person","name":"David Hudson"},"articleSection":"Life","keywords":["Ad Friendly","Queerty","pastor","preacher","wilton manors","[ Has: YouTube embed ]","[ Has: Twitter embed ]","[ Word count: 300-600 ]"],"publisher":{"@type":"NewsMediaOrganization","name":"Queerty","url":"https:\/\/www.queerty.com\/","logo":{"@type":"ImageObject","url":"https:\/\/www.queerty.com\/assets\/q-2017\/queerty-logo-225x60.png","height":"60","width":"225"},"address":{"@type":"PostalAddress","streetAddress":"584 Castro St. #623","addressLocality":"San Francisco","addressRegion":"CA","postalCode":"94114","addressCountry":"USA"},"sameAs":["https:\/\/en.wikipedia.org\/wiki\/Queerty","https:\/\/www.facebook.com\/queerty","https:\/\/www.twitter.com\/queerty","https:\/\/www.instagram.com\/queerty","https:\/\/www.youtube.com\/user\/queertyTV"]}}</script>
<aside id="secondary" class="article-sidebar" role="complementary">
<div class="sidebar-ad-1" id="div-gpt-ad-box1">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box1'); });
			</script>
</div>
<section class="sidebar-related">
<h3 class="category-heading">
More in Life </h3>
<div class="cards-list">
<article id="post-584857" class="card card-small ">
<a href="https://www.queerty.com/president-biden-posts-message-newly-athletes-carl-nassib-kumi-yokoyama-20210623">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/01/joe_biden_july_2020_670_355.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="President Biden posts message to newly-out athletes Carl Nassib and Kumi Yokoyama">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">inspiring</div>
<h2 class="entry-title">President Biden posts message to newly-out athletes Carl Nassib and Kumi Yokoyama</h2> <div class="entry-meta">
<a href="https://www.queerty.com/president-biden-posts-message-newly-athletes-carl-nassib-kumi-yokoyama-20210623" rel="bookmark"><time class="entry-date published updated" datetime="2021-06-23T09:15:55-04:00">41 minutes ago</time></a> </div>
</section>
</a>
</article>
<article id="post-584777" class="card card-small ">
<a href="https://www.queerty.com/im-young-black-guy-mean-fetish-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2018/11/black-man-torso-670x447.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="I’m into a young black guy. Does that mean I have a fetish?">
<div class="card-thumb-gradient"> </div>
</section>
 <section class="card-content">
<div class="kicker">Ask Jake</div>
<div class="card-commentcount">12 comments</div><h2 class="entry-title">I’m into a young black guy. Does that mean I have a fetish?</h2> <div class="entry-meta">
<a href="https://www.queerty.com/im-young-black-guy-mean-fetish-20210622" rel="bookmark"><time class="entry-date published updated" datetime="2021-06-22T14:49:47-04:00"></time></a> </div>
</section>
</a>
</article>
<div class="sidebar-ad-4" id="div-gpt-ad-box4">
<script type="text/javascript">
											AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box4'); });
											</script>
</div>
<article id="post-584759" class="card card-small ">
<a href="https://www.queerty.com/12-year-old-boy-slapped-tormented-family-instagram-live-gay-sparking-outrage-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/Devin-Barrington-Ward-3.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="12-year-old boy slapped, tormented by family on Instagram Live for being gay, sparking outrage">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Disgusting</div>
<div class="card-commentcount">13 comments</div><h2 class="entry-title">12-year-old boy slapped, tormented by family on Instagram Live for being gay, sparking outrage</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-584745" class="card card-small ">
<a href="https://www.queerty.com/exactly-michael-sam-fit-nfl-star-carl-nassibs-historic-coming-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/Screen-Shot-2021-06-22-at-11.17.37-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Exactly where does Michael Sam fit into NFL star Carl Nassib&#8217;s historic coming out?">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">sport sensation</div>
<div class="card-commentcount">12 comments</div><h2 class="entry-title">Exactly where does Michael Sam fit into NFL star Carl Nassib&#8217;s historic coming out?</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-2" id="div-gpt-ad-box2">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box2'); });
			</script>
</div>
<br>
<div style="width:300px; border:1px solid #EFEFEF; text-align:left; padding:10px; margin-left:auto; margin-right:auto;">
<a href="https://www.queerty.com/podcast/" style="float:left; margin-right:10px;"><img src="https://content.production.cdn.art19.com/images/77/87/4f/6c/77874f6c-6d73-4253-9fa0-1a10f85c198d/50a1b9d1711a394dd18db7a4127889370b188aba2cb38148d2fcfbfb98d2787b4ed3d50cf06d6e6c5a500456feef79e168f7676d7286162d85fa116e0cb6d86d.jpeg" alt="Thumbnail" height="80" width="80" border="0"></a>
<a href="https://www.queerty.com/podcast/" style="color:#000; font-family: proxima-nova, sans-serif; font-size:15px; padding-bottom:5px; text-decoration:none;">LISTEN: Bring Back My Gays (w/ Big Dipper)</a>
<br> <small>Listen at: <a href="https://podcasts.apple.com/us/podcast/queerty/id1544558907">Apple</a> &middot; <a href="https://open.spotify.com/show/7DAZbVOmbLkDHJnM7VtTJV">Spotify</a> &middot; <a href="https://podcasts.google.com/feed/aHR0cHM6Ly9yc3MuYXJ0MTkuY29tL3F1ZWVydHk=">Google </a> &middot; <a href="https://www.stitcher.com/show/queerty">Stitcher</a></small>
</div> <style>
.pridefinder-sidebar img {
	width:100%;
	height:auto;
}
.pf-event {
	color: white;
	padding: 10px 15px;
	font-family: sans-serif;
}
.pf-event .more {
	background-color: #fff;
	color: #a15fbb;
	font-size: 11px;
	display: inline-block;
	padding: 4px;
	margin-top: 8px;
}
.pf-header {
	position: relative;
}

.pf-event .what {
	font-size: 14px;
	margin-bottom: 5px;
}
.pf-event .when {
	font-size: 10px;
	margin-bottom: 5px;
}
.pf-event .where {
	font-size: 10px;
	text-transform: uppercase;
}
.pf-event img {
	flex-grow: 0;
	width: 100px;
}
.pf-event .pf-event-holder {
	width: 100%;
	border-radius: 10px;
	overflow: hidden;
	display: flex;
	background: rgb(0,0,0);
	background: linear-gradient(90deg, rgba(0,0,0,0) 0%, rgba(0,0,0,0.2) 65%, rgba(0,0,0,0.3) 100%);	
}
.pf-event-holder .data {
	flex-grow:2;
	margin: 10px;
}
a.pf-event-url, a.pf-event-url:hover {
	text-decoration: none;
	color: #fff;
}
.pf-event1 {
	background: url('https://www.queerty.com/assets/promos/pride/2021/pridefinder/pf-event-1.jpg');
	background-size: cover;
}
.pf-event2 {
	background: url('https://www.queerty.com/assets/promos/pride/2021/pridefinder/pf-event-2.jpg');
	background-size: cover;
}
.pf-event3 {
	background: url('https://www.queerty.com/assets/promos/pride/2021/pridefinder/pf-event-3.jpg');
	background-size: cover;
}

.pf-event2 .more {
	color: #41a7d8;
}

.pf-event3 .more {
	color: #33b271;
}
</style>
<div class="pridefinder-sidebar" style="width:300px;margin-bottom:20px; margin-top: 10px; margin-left:auto; margin-right:auto;">
<div class="pf-header"><a href="https://www.gaycities.com/events/pride/"><img src="https://www.queerty.com/assets/promos/pride/2021/pridefinder/pf-header.jpg"></a>
<div id="div-gpt-ad-sponsorship2" style="position:absolute; top:129px;right: 113px; width:100%; height:155px;"><script>AdBridg.cmd.push(function(){ AdBridg.display('div-gpt-ad-sponsorship2'); });</script></div>
</div>
<a class="pf-event-url" href="https://newyork.gaycities.com/events/1030485-nyc-pride-human-rights-conference" style="height:100px;">
<div class="pf-event pf-event1">
<div class="pf-event-holder">
<img src="https://gaycities-featured-images-production.s3.amazonaws.com/events/t/sm/sm_1030485_Fletcher-sitecrop-01.jpeg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=100&h=100">
<div class="data">
<div class="what">NYC Pride 2021: Human Rights Conference</div>
<div class="when">Jun 21-23, 2021</div>
<div class="where">New York</div>
<div class="more">LEARN MORE</div>
</div>
</div>
</div>
</a>
<a class="pf-event-url" href="https://newyork.gaycities.com/events/1030554-protect-black-trans-women-rally" style="height:100px;">
<div class="pf-event pf-event2">
<div class="pf-event-holder">
<img src="https://gaycities-featured-images-production.s3.amazonaws.com/events/t/sm/sm_1030554_ProtectBlkTransWRally.jpeg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=100&h=100">
<div class="data">
<div class="what">Protect Black Trans Women Rally</div>
<div class="when">Jun 24</div>
<div class="where">New York</div>
<div class="more">LEARN MORE</div>
</div>
</div>
</div>
</a>
<a class="pf-event-url" href="https://eastbay.gaycities.com/events/1030576-inclusive-economics-centering-bipoc-lgbtqia-busin" style="height:100px;">
<div class="pf-event pf-event3">
<div class="pf-event-holder">
<img src="https://gaycities-featured-images-production.s3.amazonaws.com/events/t/sm/sm_eb_7aa24c094700cf28cefed13567ea0bc4?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=100&h=100">
<div class="data">
<div class="what">Inclusive Economics: Centering BIPOC LGBTQIA+ Businesses - 6/24 @ 3PM ZOOM</div>
<div class="when">Jun 24</div>
<div class="where">Oakland / East Bay</div>
<div class="more">LEARN MORE</div>
</div>
</div>
</div>
</a>
<div style="position: relative;">
<img src="https://www.queerty.com/assets/promos/pride/2021/pridefinder/pf-pride-central.jpg">
<a style="position:absolute; bottom: 0; left: 0; height:50px; width:30%;" href="https://www.queerty.com/pride50/" title="Pride50"> </a>
<a style="position:absolute; bottom: 0; left: 31%; height:50px; width:33%;" href="https://www.lgbtqnation.com/pride-in-pictures/" title="Pride in Pictures"> </a>
<a style="position:absolute; bottom: 0; left:66%; height:50px; width:33%;" href="https://www.gaycities.com/pride-in-places/" title="Pride in Places"> </a>
</div></div> <div class="sidebar-ad-3" id="div-gpt-ad-box3">
<script>
		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box3'); });
		</script>
</div>
</aside>
<br clear=all>
<div class="single-bottom-articles">
<h3>
Latest on Queerty </h3>
<div class="single-bottom-articles-slider slider slick-slider">
<div><article id="post-584857" class="card card-small ">
<a href="https://www.queerty.com/president-biden-posts-message-newly-athletes-carl-nassib-kumi-yokoyama-20210623">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/01/joe_biden_july_2020_670_355.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="President Biden posts message to newly-out athletes Carl Nassib and Kumi Yokoyama">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">inspiring</div>
<h2 class="entry-title">President Biden posts message to newly-out athletes Carl Nassib and Kumi Yokoyama</h2> <div class="entry-meta">
<a href="https://www.queerty.com/president-biden-posts-message-newly-athletes-carl-nassib-kumi-yokoyama-20210623" rel="bookmark"><time class="entry-date published updated" datetime="2021-06-23T09:15:55-04:00">41 minutes ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-584853" class="card card-small branded-content">
<a target="_blank" href="https://www.gaycities.com/outthere/54255/joe-phillips-san-diego-witch-boy-art-libido-bubbles/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=Joe+Phillips+on+San+Diego%2C+sexy+witch+boy+art+and+libido+bubbles">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/Screen-Shot-2021-06-22-at-8.52.40-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Joe Phillips on San Diego, sexy witch boy art and libido bubbles">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">wanderlust</div>
<h2 class="entry-title">Joe Phillips on San Diego, sexy witch boy art and libido bubbles</h2><span class="branded-content-brand">Presented by https://www.gaycities.com/outthere/54255/joe-phillips-san-diego-witch-boy-art-libido-bubbles/</span> <div class="entry-meta">
<span class="branded-content-label">SPONSORED</span> </div>
</section>
</a>
</article>
</div><div><article id="post-584801" class="card card-small ">
<a href="https://www.queerty.com/photos-twitter-shook-tyler-oakleys-undie-clad-transformation-full-fledged-twunk-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/tyler-oakley.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="PHOTOS: Twitter shook by Tyler Oakley&#8217;s undie-clad transformation to full-fledged twunk">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Bedhead</div>
<h2 class="entry-title">PHOTOS: Twitter shook by Tyler Oakley&#8217;s undie-clad transformation to full-fledged twunk</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-584789" class="card card-small ">
<a href="https://www.queerty.com/straight-white-politician-says-pride-unfair-straight-white-men-says-hes-crucified-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/mike-mcbride-city-council.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Straight white politician says Pride is unfair to straight white men, says he&#8217;s being &#8220;crucified&#8221;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">drama queen</div>
<div class="card-commentcount">14 comments</div><h2 class="entry-title">Straight white politician says Pride is unfair to straight white men, says he&#8217;s being &#8220;crucified&#8221;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-584777" class="card card-small ">
<a href="https://www.queerty.com/im-young-black-guy-mean-fetish-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2018/11/black-man-torso-670x447.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="I’m into a young black guy. Does that mean I have a fetish?">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Ask Jake</div>
<div class="card-commentcount">12 comments</div><h2 class="entry-title">I’m into a young black guy. Does that mean I have a fetish?</h2> <div class="entry-meta">
<a href="https://www.queerty.com/im-young-black-guy-mean-fetish-20210622" rel="bookmark"><time class="entry-date published updated" datetime="2021-06-22T14:49:47-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-584762" class="card card-small ">
<a href="https://www.queerty.com/gay-candidate-responds-homophobic-caller-inviting-spaghetti-dinner-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/matt-putorti-homophobic-voicemail.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Gay candidate responds to homophobic caller by inviting him over for a spaghetti dinner">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">dinner date?</div>
<h2 class="entry-title">Gay candidate responds to homophobic caller by inviting him over for a spaghetti dinner</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-584759" class="card card-small ">
<a href="https://www.queerty.com/12-year-old-boy-slapped-tormented-family-instagram-live-gay-sparking-outrage-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/Devin-Barrington-Ward-3.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="12-year-old boy slapped, tormented by family on Instagram Live for being gay, sparking outrage">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Disgusting</div>
<div class="card-commentcount">13 comments</div><h2 class="entry-title">12-year-old boy slapped, tormented by family on Instagram Live for being gay, sparking outrage</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-584756" class="card card-small ">
<a href="https://www.queerty.com/heights-hunk-anthony-ramos-shows-off-agility-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/anthony-ramos-ck.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="&#8216;In The Heights&#8217; hunk Anthony Ramos shows off his&#8230; agility">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Showstopper</div>
<div class="card-commentcount">10 comments</div><h2 class="entry-title">&#8216;In The Heights&#8217; hunk Anthony Ramos shows off his&#8230; agility</h2> <div class="entry-meta">
<a href="https://www.queerty.com/heights-hunk-anthony-ramos-shows-off-agility-20210622" rel="bookmark"><time class="entry-date published updated" datetime="2021-06-22T13:23:03-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-584752" class="card card-small ">
<a href="https://www.queerty.com/lady-gaga-olly-alexander-just-teamed-omg-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/shutterstock_1297118890-1-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Lady Gaga and Olly Alexander just teamed up and OMG">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Mash-Up</div>
<h2 class="entry-title">Lady Gaga and Olly Alexander just teamed up and OMG</h2> <div class="entry-meta">
<a href="https://www.queerty.com/lady-gaga-olly-alexander-just-teamed-omg-20210622" rel="bookmark"><time class="entry-date published updated" datetime="2021-06-22T12:58:49-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-584745" class="card card-small ">
<a href="https://www.queerty.com/exactly-michael-sam-fit-nfl-star-carl-nassibs-historic-coming-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/Screen-Shot-2021-06-22-at-11.17.37-AM.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Exactly where does Michael Sam fit into NFL star Carl Nassib&#8217;s historic coming out?">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">sport sensation</div>
<div class="card-commentcount">12 comments</div><h2 class="entry-title">Exactly where does Michael Sam fit into NFL star Carl Nassib&#8217;s historic coming out?</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-584344" class="card card-small gaycities-link">
<a target="_blank" href="https://www.gaycities.com/outthere/51488/favorite-celebrity-sex-weddings-married/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=Our+favorite+celebrity+same-sex+weddings+and+where+they+married">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/david_burtka_nph_wedding_day_pic.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Our favorite celebrity same-sex weddings and where they married">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">wanderlust</div>
<h2 class="entry-title">Our favorite celebrity same-sex weddings and where they married</h2> <div class="entry-meta">
<a href="https://www.queerty.com/favorite-celebrity-sex-weddings-married-2-20210622" rel="bookmark"><time class="entry-date published updated" datetime="2021-06-22T10:40:33-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-584734" class="card card-small ">
<a href="https://www.queerty.com/donald-trump-blames-mike-pence-not-president-anymore-20210622">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/06/donald_trump_mike_pence_public_domain.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Donald Trump blames Mike Pence for not being President anymore">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">still raging</div>
<div class="card-commentcount">21 comments</div><h2 class="entry-title">Donald Trump blames Mike Pence for not being President anymore</h2> <div class="entry-meta">
<a href="https://www.queerty.com/donald-trump-blames-mike-pence-not-president-anymore-20210622" rel="bookmark"><time class="entry-date published updated" datetime="2021-06-22T10:15:09-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</div>
</div></div>
</div>
<div class="site-footer-holder">
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="footer-brand">
<span class="asterisk"> </span> Free of an agenda (except that gay one)
</div>
<div class="tags-links">
<a href="//www.queerty.com/tag/andy-cohen">Andy Cohen</a> <a href="//www.queerty.com/tag/bowen-yang">Bowen Yang</a> <a href="//www.queerty.com/tag/colton-underwood">Colton Underwood</a> <a href="//www.queerty.com/tag/conrad-rocha">Conrad Rocha</a> <a href="//www.queerty.com/tag/gus-kenworthy">Gus Kenworthy</a> <a href="//www.queerty.com/tag/janet-mock">Janet Mock</a> <a href="//www.queerty.com/tag/lil-nas-x">Lil Nas X</a> <a href="//www.queerty.com/tag/ricky-martin">Ricky Martin</a> <a href="//www.queerty.com/tag/russell-tovey">Russell Tovey</a> <a href="//www.queerty.com/tag/ryan-murphy">Ryan Murphy</a> <div class="second-row">
<a href="//www.queerty.com/tag/homophobia">Homophobia</a> <a href="//www.queerty.com/tag/racism">Racism</a> <a href="//www.queerty.com/tag/rupaul's-drag-race">Rupaul's Drag Race</a> <a href="//www.queerty.com/tag/matt-gaetz">Matt Gaetz</a> <a href="//www.queerty.com/tag/transphobia">Transphobia</a> <a href="//www.queerty.com/tag/relationships">Relationships</a> <a href="//www.queerty.com/tag/grindr">Grindr</a>
</div>
</div>
<div class="footer-links">
<ul class="main" id="footer-company-links">
<li><a href="http://www.q.digital"><img src="/assets/q-digital-blue-90x37.png" alt="Q.digital" width="90"></a></li>
<li><b>A Q.Digital Company</b></li>
<li>&copy; 2021 Queerty, Inc.</li>
<li><a href="http://www.q.digital">Advertise With Us</a></li>
</ul>
<ul class="main" id="footer-contact-links">
<li><h3>Contact</h3></li>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
<li><a href="https://www.queerty.com/queertys-comment-policy">Comments Policy</a>
<li><a href="https://www.queerty.com/privacy-policy">Privacy Statement</a>
<li><a href="https://www.queerty.com/terms-of-use">Terms of Use</a>
<li><a id="ccpaOptOut">Do Not Sell My Personal Information</a>
</ul>
<ul class="main" id="footer-follow-links">
<li><h3>Follow</h3></li>
<li><a href="https://linktr.ee/queertypodcast">Podcast</a></li>
<li><a href="https://www.facebook.com/Queerty/">Facebook</a></li>
<li><a href="https://www.twitter.com/Queerty/">Twitter</a></li>
<li><a href="https://www.instagram.com/Queerty/">Instagram</a></li>
<li><a href="https://www.youtube.com/user/QueertyTV/">YouTube</a></li>
</ul>
<ul class="main double" id="footer-gaycities-links">
<li><h3>GayCities: Your Gay Travel Guide:</h3></li>
<li><a href="https://newyork.gaycities.com/">New York</a></li>
<li><a href="https://london.gaycities.com/">London</a></li>
<li><a href="https://sanfrancisco.gaycities.com/">San Francisco</a></li>
<li><a href="https://chicago.gaycities.com/">Chicago</a></li>
<li><a href="https://losangeles.gaycities.com/">Los Angeles</a></li>
<li><a href="https://washingtondc.gaycities.com/">Washington DC</a></li>
<li><a href="https://dallas.gaycities.com/">Dallas</a></li>
<li><a href="https://saskatoon.gaycities.com/">Gay Saskatoon</a></li>
<li><a href="https://www.gaycities.com/places/"><b>See all 230+ cities...</b></a></li>
</ul>
</div>
</footer>
</div>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "32666898" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=32666898&cv=2.0&cj=1" alt="Comscore Measurement" />
</noscript>

<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '686853021424163');
  fbq('track', 'PageView');
</script>
<noscript><img height='1' width='1' style='display:none'
  src='https://www.facebook.com/tr?id=686853021424163&ev=PageView&noscript=1'
/></noscript>

<script>
  fbq('track', 'ViewContent');
</script>
<script>
	window.dataLayer = window.dataLayer || []
	dataLayer.push({
	   'event': 'Page Details',
	   'pageType': 'article',
	   'pageCategory': 'life'
	   
	});
	</script>
<script type="text/javascript">var algolia = {"debug":false,"application_id":"6S92GABH7H","search_api_key":"cfd5e12cdf4a6106712391cbcf54f087","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"queerty_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"queerty_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]}}};</script><script>(function(d){var s=d.createElement('script');s.type='text/javascript';s.src='https://a.omappapi.com/app/js/api.min.js';s.async=true;s.dataset.campaign='e0mfnzjpsutchxulkvrp';s.dataset.user='40711';d.getElementsByTagName('head')[0].appendChild(s);})(document);</script> <script type="text/javascript">
		var e0mfnzjpsutchxulkvrp_shortcode = true;		</script>
<script type='text/javascript' src='https://q-digital.videoplayerhub.com/galleryplayer.js?ver=20201101' id='bt-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' async src='https://platform.twitter.com/widgets.js?ver=20161216' id='twitter-js-js'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js?ver=5.7.2' id='slick-js'></script>
<script type='text/javascript' async src='https://www.queerty.com/content/themes/queerty_2017/js/min/queerty-nosticky-min.js?ver=20200120a' id='queerty_2017-main-js'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.7.2' async='async' id='remote_sdk-js'></script>
<script type='text/javascript' src='https://www.queerty.com/content/plugins/optinmonster/assets/js/helper.js?ver=2.3.3' id='optinmonster-wp-helper-js'></script>
<script type="text/javascript">var omapi_localized = { ajax: 'https://www.queerty.com/wp/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: '2697c7d5bf', slugs: {"e0mfnzjpsutchxulkvrp":{"slug":"e0mfnzjpsutchxulkvrp","mailpoet":false}} };</script>
<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":584862,"object_key":"post","object_type":"post","term_ids":[69394,69296,310,60530,68288,30408]};</script>
<script data-cfasync="false" id="parsely-cfg" data-parsely-site="queerty.com" src="https://cdn.parsely.com/keys/queerty.com/p.js"></script>
</body>
</html>