<!DOCTYPE html>
<html>
<head>
<script type="text/javascript" src="//digg7anmcfked.cloudfront.net/script.js"></script>
<link rel="stylesheet" href="https://use.typekit.net/cdb4vyt.css">
<meta name="viewport" content="width=device-width, initial-scale=1">

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
</script>

<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.2634970.min.js?cachebuster=1';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      // Return control to GPT if the AdBridg library fails to load.
      adb.onerror = function() {
        console.log('Fallback: ')
        if (AdBridg.exists) { return; }
        document.createElement('IMG').src = '//adspsp.com/pt/2634970/3/1/?e=0';
        var dq = [], es;
        dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
        AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
        AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
        AdBridg.destroySlots = function(s) { return googletag.destroySlots(s); }
        AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
        AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
        AdBridg.render = function() { }
        AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
        AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
        AdBridg.useSizeMapping = function() { }
        AdBridg.cmd.push = function(f) {
          if (typeof(f)=='object') {
            var api_fallback = function(o) {
              googletag.cmd.push(function() {
                var u=AdBridg.defineSlot(o.gpt_path,o.size||[],o.dom_id);
                if(o.size_map) {
                  var m = googletag.sizeMapping();
                  for(var oi=0;oi<o.size_map.length;oi++){m=m.addSize(o.size_map[oi].viewport, o.size_map[oi].sizes);}
                  u.defineSizeMapping(m.build());
                }
                if(o.events) {
                  if(o.events["gpt.defined"]){o.events["gpt.defined"](u);}
                  var fl = function(a,b){if(o.events[a]){googletag.pubads().addEventListener(b,function(e){if(e.slot===u){o.events[a](u,e)}})}}
                  fl("gpt.rendered",'slotRenderEnded');
                  fl("gpt.viewed",'impressionViewable');
                  fl("gpt.visibilityChanged",'slotVisibilityChanged');
                }
              });
            }
            if(f.length){for(var i=0;i<f.length;++i){api_fallback(f[i]);}}else{api_fallback(f);}
            f=function(){AdBridg.serve()}
          }
          return googletag.cmd.push(f);
        }
        while (AdBridg.cmd.length) { AdBridg.cmd.push(AdBridg.cmd.shift()); }
      }
  })();
AdBridg.cmd.push({
	action: 'spa_pv_initialize',
	config: {
		footer_sticky: false,
		qd_path: '/4564944/queerty/dragaholic/article'
	}
});
</script>
<script>
AdBridg.cmd.push(function () {
	googletag.pubads().collapseEmptyDivs();
	googletag.pubads().setTargeting('articleid', ['582753']);
	googletag.pubads().setTargeting('Tag', ['articlepage','all stars','drag race','rupauls drag race','ad friendly','dragaholic','entertainment','queerty']);
	googletag.pubads().setTargeting('UGC', ['no']);
  });
</script>
<script>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</script>
<title>&#8216;RuPaul&#8217;s Drag Race All Stars 6&#8217; cast, promo images appear to leak online / Dragaholic on Queerty</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//powerad.ai' />
<link rel='dns-prefetch' href='//q-digital.videoplayerhub.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Feed" href="https://www.queerty.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Comments Feed" href="https://www.queerty.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; &#8216;RuPaul&#8217;s Drag Race All Stars 6&#8217; cast, promo images appear to leak online Comments Feed" href="https://www.queerty.com/rupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526/feed" />
<link rel='stylesheet' id='queerty_2017-style-css' href='https://www.queerty.com/content/themes/queerty_2017/style.css?ver=20210525a' type='text/css' media='all' />
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://powerad.ai/script.js?ver=20201101' id='nxtm-js'></script>
<link rel="canonical" href="https://www.queerty.com/rupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526" />
<meta property="og:site_name" content="Queerty" /><meta name="twitter:card" content="summary_large_image"> <meta name="description" content="Start your engines..." />
<meta property="og:description" content="Start your engines...">
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.queerty.com/rupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526" />
<meta property="og:title" content="&#8216;RuPaul&#8217;s Drag Race All Stars 6&#8217; cast, promo images appear to leak online" />
<meta property="og:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/rupaul-shocked.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=1200&h=630&wat=1&wat_gravity=southeast&wat_pad=70" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta name="twitter:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/rupaul-shocked.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=1200&h=630&wat=1&wat_gravity=southeast&wat_pad=70" />
<meta name="image" property="og:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/rupaul-shocked.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=1200&h=630&wat=1&wat_gravity=southeast&wat_pad=70">
<meta name="publish_date" property="article:published_time" content="2021-05-26T12:47:49-04:00" />
<meta property="article:modified_time" content="2021-05-26T12:47:49-04:00" />
<meta name="twitter:url" content="https://www.queerty.com/rupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526" />
<meta name="twitter:title" content="&#8216;RuPaul&#8217;s Drag Race All Stars 6&#8217; cast, promo images appear to leak online" />
<meta name="twitter:description" content="Start your engines..." />
<meta name="news_keywords" content="all stars, drag race, RuPaul's Drag Race"><meta property="article:tags" content="all stars, drag race, RuPaul's Drag Race"><meta name="author" property="author" content="Daniel Tracer" /><meta name="twitter:label1" content="By"><meta name="twitter:data1" content="Daniel Tracer"> <style>
            #tps_carousel_container ._button,
            #tps_carousel_container ._button svg {
                color: #f08100;
                fill: #f08100;
            }

            #tps_carousel_container ._button {
                font-size: 32px;
                line-height: 32px;
            }

            #tps_carousel_container ._button svg {
                width: 32px;
                height: 32px;
            }

            #tps_carousel_container ._button:hover,
            #tps_carousel_container ._button:focus,
            #tps_carousel_container ._button:hover svg,
            #tps_carousel_container ._button:focus svg {
                color: #ffa338;
                fill: #ffa338;
            }

            #tps_carousel_container ._disabled,
            #tps_carousel_container ._disabled svg {
                color: #777777 !important;
                fill: #777777 !important;
            }

            #tps_carousel_container ._carousel {
                margin: 0 42px;
            }

            #tps_carousel_container ._prev {
                margin-right: 10px;
            }

            #tps_carousel_container ._next {
                margin-left: 10px;
            }
        </style>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KRQPBJR');</script>

<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://www.queerty.com/wp");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '2269d7e8-77de-42f4-85e0-e16c905e72b8';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Queerty";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing!";
oneSignal_options['welcomeNotification']['url'] = "https://www.queerty.com/";
oneSignal_options['path'] = "https://www.queerty.com/content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.32a023df-3e37-4c19-843f-3978a63a946e";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = "Queerty";
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = "Titles of Breaking Stories Will Appear Here";
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = "Queerty";
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
<link rel="amphtml" href="https://www.queerty.com/rupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526/amp"> <link rel="preconnect" href="https://queerty-assets.s3.amazonaws.com">
<link rel="preload" href="https://www.googletagservices.com/tag/js/gpt.js">
<link rel="preconnect" href="https://www.googletagmanager.com">
<link rel="preconnect" href="https://queerty-prodweb.imgix.net">
<meta property="fb:app_id" content="153299894806318" />
<meta name="theme-color" content="#f43700" />
<meta name="apple-itunes-app" content="app-id=1046987164">
<meta property="fb:pages" content="33720334139" />
<meta name="apple-mobile-web-app-title" content="Queerty*">
<meta name="application-name" content="Queerty*">
<meta name="msapplication-config" content="/assets/q-2017/favicons/browserconfig.xml?v=lkgzj5W5Gl">
<link rel="apple-touch-icon" sizes="180x180" href="/assets/q-2017/favicons/apple-touch-icon.png?v=lkgzj5W5Gl">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-32x32.png?v=lkgzj5W5Gl" sizes="32x32">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-16x16.png?v=lkgzj5W5Gl" sizes="16x16">
<link rel="manifest" href="/assets/q-2017/favicons/manifest.json?v=20180829">
<link rel="mask-icon" href="/assets/q-2017/favicons/safari-pinned-tab.svg?v=lkgzj5W5Gl" color="#5bbad5">
<link rel="shortcut icon" href="/assets/q-2017/favicons/favicon.ico?v=lkgzj5W5Gl">
<meta property="article:publisher" content="https://www.facebook.com/queerty" />
<style>
.ad-leaderboard-header {
	background-color:transparent !important;
	position:relative;
	margin-top:10px;
}
.queerty-header {
	padding-top:10px !important;
}
@media screen and (max-height: 769px) {
	.queerty-header {
    	min-height: 4.688rem;
    	padding: 10px 0 10px !important;
	}
}
</style>
</head>
<body class="post-template-default single single-post postid-582753 single-format-standard category-ad-friendly category-dragaholic category-entertainment category-queerty">
<div id="top-of-page" style="display:none;"></div>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRQPBJR"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="div-gpt-ad-sidebarvideoplayer" style="height:1px;width:1px;">
<script>
		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-sidebarvideoplayer'); });
		</script>
</div>
<div id="page" class="site">
<div class="ad-leaderboard-header" id="div-gpt-ad-leader1">
<script>
				AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-leader1'); });
				</script>
</div>

<div id="is-phone"></div>

<header id="masthead" class="queerty-header">
<div class="queerty-header-wrapper">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="js-header-main-menu" class="queerty-header-menu show">
<li class="nav-link "><a href="/">Latest</a>
</li>
<li class="nav-link navcat-life "><a class="scroll-on-page-link" data-scroll="category-life" href="https://www.queerty.com/life">Life</a></li>
<li class="nav-link navcat-entertainment selected"><a class="scroll-on-page-link" data-scroll="category-entertainment" href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li class="nav-link navcat-politics "><a class="scroll-on-page-link" data-scroll="category-politics" href="https://www.queerty.com/politics">Politics</a></li>
<li class="nav-link navcat-pride"><a href="/pride50">Pride50</a></li>
</ul>
</nav>
<div class="logo-area">
<a href="/" class="queerty-logo"><!-- -->
<img src="/assets/q-2017/queerty-logo.svg" width="275" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo">
<img src="/assets/promos/pride/2019/queerty-pride.svg" width="275" alt="Queerty* Pride" class="queerty-header-pride-logo" style="display:none;">
</a>
</div>
<nav id="right-navigation" class="secondary-navigation" role="navigation">
<ul id="js-header-secondary-menu" class="queerty-header-menu show">
<li class="nav-link">
<a href="https://www.facebook.com/Queerty/"><img src="/assets/icons/facebook-f-icon.svg" height="19" aria-hidden="true" alt="Facebook"></a>
</li>
<li class="nav-link">
<a href="https://twitter.com/queerty"><img src="/assets/icons/twitter-icon.svg" height="19" aria-hidden="true" alt="Twitter"></a>
</li>
<li class="nav-link">
<a href="https://www.instagram.com/queerty/"><img src="/assets/icons/instagram-icon.svg" height="19" aria-hidden="true" alt="Instagram"></a>
</li>
<li class="nav-link">
<a href="https://www.youtube.com/queerty/"><img src="/assets/icons/youtube-icon.svg" height="19" aria-hidden="true" alt="YouTube"></a>
</li>
<li class="nav-link">
<a href="https://www.queerty.com/podcast/"><img src="/assets/icons/podcast-icon.svg" height="19" aria-hidden="true" alt="YouTube"></a>
</li>
<li class="nav-link">
<a href="https://eepurl.com/RrfMf"><img src="/assets/icons/envelope-regular.svg" height="19" aria-hidden="true" alt="newsletter"></a>
</li>
<li class="nav-link queerty-menu-button" id="more-menu">
<img src="/assets/icons/bars-solid.svg" height="19" aria-hidden="true" title="Open Menu" alt="Menu">
</li>
</ul>
</nav>
</div>
</header>
<nav class="queerty-menu-content">
<div class="queerty-menu-close"><img src="/assets/icons/times-solid.svg" height="19" aria-hidden="true" title="Close Menu" alt="Close"></i></div>
<div class="queerty-menu-logo"><img src="/assets/q-2017/queerty-logo.svg" width="100" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo"></div>
<div class="queerty-menu-searchbox">
<form role="search" method="get" class="search-form" action="https://www.queerty.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
<ul>
<li><a href="https://www.queerty.com/wp/wp-login.php?redirect_to=%2F%2Fwww.queerty.com%2Frupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526" id="menu-login">Log in</a></li>
<li><a href="https://www.queerty.com/wp/wp-login.php?action=register" id="menu-register">Register</a></li>
</ul>
<div class="menu-now-on-queerty-container"><ul id="menu-now-on-queerty" class="menu"><li id="menu-item-581679" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-581679"><a href="https://www.queerty.com/pride50/">Pride50 2021</a></li>
<li id="menu-item-441445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441445"><a href="https://www.queerty.com/life">Life</a></li>
<li id="menu-item-441443" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-441443"><a href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li id="menu-item-441446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441446"><a href="https://www.queerty.com/politics">Politics</a></li>
<li id="menu-item-441444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441444"><a href="https://www.queerty.com/goods">Goods</a></li>
<li id="menu-item-574436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574436"><a href="https://www.queerty.com/podcast">Queerty Podcast</a></li>
<li id="menu-item-420168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-420168"><a href="//www.queerty.com/queerty-tv/">Video (Queerty TV)</a></li>
<li id="menu-item-504333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-504333"><a href="https://www.queerty.com/ever-after">Queerty Ever After</a></li>
<li id="menu-item-420166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-420166"><a href="https://www.queerty.com/dragaholic">Dragaholic</a></li>
<li id="menu-item-469065" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-469065"><a href="https://www.queerty.com/prepared">Prepared</a></li>
<li id="menu-item-573116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-573116"><a href="https://www.queerty.com/health">Health</a></li>
</ul></div>
<ul>
<li><a href="https://www.lgbtqnation.com/">LGBTQ Nation News</a></li>
<li><a href="https://www.gaycities.com/">GayCities Travel Guides</a></li>
</ul>
<ul>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
</ul>
</nav>
<div class="queerty-menu-fade-screen"></div>
<div id="content" class="site-content"> <header class="archive-header dragaholic-header">
<div class="left-holder">
<h2 class="category-heading">
<a href="/dragaholic">
<img src="/assets/dragaholic/dragaholic-logo-2017-200.png" alt="Dragaholic*" width="200" height="40" />
</a>
<div class="term-sponsorship" style="width:320px; margin-left:10px;">
<div id="div-gpt-ad-sponsorship1"><script>AdBridg.cmd.push(function(){ AdBridg.display('div-gpt-ad-sponsorship1'); });</script></div>
</div>
</h2>
</div>
<div class="right-holder">
<a class="twitter-follow-button" href="https://twitter.com/dragaholicnews" data-size="large" data-show-count="false">
Follow @dragaholicnews</a>
</div>
</header>
<script>window.twttr = (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0],
    t = window.twttr || {};
  if (d.getElementById(id)) return t;
  js = d.createElement(s);
  js.id = id;
  js.src = "https://platform.twitter.com/widgets.js";
  fjs.parentNode.insertBefore(js, fjs);

  t._e = [];
  t.ready = function(f) {
    t._e.push(f);
  };

  return t;
}(document, "script", "twitter-wjs"));</script>
<div class="single-wrapper">
<div id="primary" class="content-area single-article category-dragaholic">
<main id="main" class="site-main" role="main">
<article id="post-582753" class="post-582753 post type-post status-publish format-standard has-post-thumbnail hentry category-ad-friendly category-dragaholic category-entertainment category-queerty tag-all-stars tag-drag-race tag-rupauls-drag-race">
<header class="entry-header">
<div class="kicker ">Start your engines</div> <h1 class="entry-title"><a href="https://www.queerty.com/rupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526"><span itemprop="headline">&#8216;RuPaul&#8217;s Drag Race All Stars 6&#8217; cast, promo images appear to leak online</span></a></h1>
<div class="entry-meta">
<span class="byline"> By <span itemprop="author"> <a href="https://www.queerty.com/author/dan-tracer" title="Posts by Dan Tracer" rel="author">Dan Tracer</a></span></span> <time class="posted-on" itemprop="datePublished" datetime="2021-05-26T12:47:49-04:00">22 minutes ago</time> </div>
</header>
<div class="entry-content" itemprop="articleBody">
<script data-cfasync="false" type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/13536/tag"></script><script data-cfasync="false" src="//a.teads.tv/media/format/v3/teads-format.min.js"></script><p><img loading="lazy" class="aligncenter size-large wp-image-582758" src="https://queerty-prodweb.s3.amazonaws.com/2021/05/rupaul-shocked-670x423.png" alt="" width="670" height="423" srcset="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/rupaul-shocked-670x423.png?&amp;auto=format&amp;auto=compress&amp;w=670 670w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/rupaul-shocked-670x423.png?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/rupaul-shocked-670x423.png?&amp;auto=format&amp;auto=compress&amp;w=702 702w" sizes="(max-width: 670px) 100vw, 670px"></p>
<p>Another season of <em>Drag Race</em>, another apparent leak.</p>
<p>This time, it looks like the cast and promo photos for the upcoming <em><a href="https://www.queerty.com/tag/rupauls-drag-race">RuPaul’s Drag Race</a>: All Stars 6</em> have popped up on Twitter ahead of the show’s expected release later this year.</p>
<p>It should be noted that no official cast has been confirmed, and this is pure speculation. But the evidence is strong.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle1"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle1"); });</script></div>
<p><strong>Related: <a href="https://www.queerty.com/reddit-sleuths-say-theyve-uncovered-secret-cast-international-drag-race-stars-20210323">Reddit sleuths say they’ve uncovered the secret cast of ‘International Drag Race All-Stars’</a></strong></p>
<p>If the photos (which all match) are to be believed, the cast will see queens like SE11’s Silky, SE9/10’s Eureka, and SE11’s Scarlett Envy return to the race.</p>
<p>Twitter user @namsxnightmare shared the images, writing: “#AllStars6 Promo Looks”.</p>
<div class="">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr"><a href="https://twitter.com/hashtag/AllStars6?src=hash&amp;ref_src=twsrc%5Etfw">#AllStars6</a> Promo Looks <a href="https://t.co/C3Dpv9ZCdv">pic.twitter.com/C3Dpv9ZCdv</a></p>
<p>— ?????? / ???'? ????????? (@namsxnightmare) <a href="https://twitter.com/namsxnightmare/status/1397407500786405383?ref_src=twsrc%5Etfw">May 26, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p></div>
<p>Other queens who may or may not be appearing on the show are Yara Sofia (SE3), Ra’Jah O’Hara (SE11), Serena Cha Cha (SE5), Trinity K. Bonet (SE6), Sonique (SE2), Jiggly Caliente (SE4), Akeria Davenport (SE11), Jan Sport (SE12), Ginger Minj (SE7) and Pandora Boxx (SE2).</p><div class="ad-300 inline" id="div-gpt-ad-inarticle2"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle2"); });</script></div>
<p>As <a href="https://www.queerty.com/shocker-rupauls-drag-race-stars-season-6-will-not-air-vh1-20210225" target="_blank" rel="noopener">previously reported</a>, the newest season of <em>Drag Race All Stars</em> is sashaying away from network VH1. The show will now air on the new streaming service, Paramount+ (formerly CBS All-Access).</p>
<p>ViacomCBS, parent company of both VH1 and Paramount+ made the announcement February 24 at an investor meeting. The move is designed to drive traffic away from conventional cable and to the new streaming service, which will also offer original content, as well as popular series from CBS, Comedy Central, Nickelodeon, MTV, BET and more. The streaming service will also host films from the Paramount library; popular titles include <em>Flashdance, The Godfather</em> and the<em> Star Trek</em> series.</p>
</div>
<footer class="entry-footer">
<span class="tags-links"><a href="https://www.queerty.com/entertainment" rel="category">Entertainment</a> <a href="https://www.queerty.com/tag/all-stars" rel="tag">all stars</a> <a href="https://www.queerty.com/tag/drag-race" rel="tag">drag race</a> <a href="https://www.queerty.com/tag/rupauls-drag-race" rel="tag">RuPaul's Drag Race</a></span><div class="comments-link-area"><a href="https://www.queerty.com/rupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526#respond"><span class="comments-link">Add a comment</span></a></div> </footer>
</article>
</main>
<div class="article-email-prompt" id="queerty-article-email-prompt">
<h3>Get Dragaholic's Newsletter</h3>
Subscribe to Dragaholic for the best drag news and updates in your inbox
<form action="//gaycities.us1.list-manage.com/subscribe/post?u=ecab442566f15d8d4dcf64b0d&amp;id=51a79e064c" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank">
<input type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="Enter your email address" autocomplete="email">
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ecab442566f15d8d4dcf64b0d_51a79e064c" tabindex="-1" value=""></div>
<input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button">
</form>
</div>
<div style="width:90%; margin-left:auto; margin-right:auto;">
<h3 style="margin-bottom:4px;">Featured on Queerty TV</h3>
<script>
!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>
<script id="63359461e10348e1843f01215f3c4ead">
  cnxps.cmd.push(function () {
    cnxps({
      playerId: "461d6acb-cbff-447a-b4e7-ee9ee29c9631"
    }).render("63359461e10348e1843f01215f3c4ead");
  });
</script>
</div>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Add your Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/rupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526#respond" style="display:none;">Cancel reply</a></small></h3><p class="nocomments">Please <a href="https://www.queerty.com/wp/wp-login.php?redirect_to=https%3A%2F%2Fwww.queerty.com%2Frupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526">log in</a> to add your comment<br>Need an account? <strong><a href="https://www.queerty.com/wp/wp-login.php?action=register">Register</a></strong> *It's free and easy.</p> </div>
</div>
</div>
<script type="text/javascript" async="async" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-58640af04b28c97d"></script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.queerty.com\/rupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526"},"headline":"&#8216;RuPaul&#8217;s Drag Race All Stars 6&#8217; cast, promo images appear to leak online","url":"https:\/\/www.queerty.com\/rupauls-drag-race-stars-6-cast-promo-images-appear-leak-online-20210526","datePublished":"2021-05-26T12:47:49-04:00","dateModified":"2021-05-26T12:47:49-04:00","description":"Start your engines.","thumbnailUrl":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/05\/rupaul-shocked-307x289.png","image":{"@type":"ImageObject","url":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/05\/rupaul-shocked-307x289.png","height":670,"width":423},"creator":"Dan Tracer","author":{"@type":"Person","name":"Dan Tracer"},"articleSection":"Dragaholic","keywords":["Ad Friendly","Entertainment","Queerty","all stars","drag race","RuPaul's Drag Race","[ Has: Twitter embed ]","[ Word count: <300 ]"],"publisher":{"@type":"NewsMediaOrganization","name":"Queerty","url":"https:\/\/www.queerty.com\/","logo":{"@type":"ImageObject","url":"https:\/\/www.queerty.com\/assets\/q-2017\/queerty-logo-225x60.png","height":"60","width":"225"},"address":{"@type":"PostalAddress","streetAddress":"584 Castro St. #623","addressLocality":"San Francisco","addressRegion":"CA","postalCode":"94114","addressCountry":"USA"},"sameAs":["https:\/\/en.wikipedia.org\/wiki\/Queerty","https:\/\/www.facebook.com\/queerty","https:\/\/www.twitter.com\/queerty","https:\/\/www.instagram.com\/queerty","https:\/\/www.youtube.com\/user\/queertyTV"]}}</script>
<aside id="secondary" class="article-sidebar" role="complementary">
<div class="sidebar-ad-1" id="div-gpt-ad-box1">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box1'); });
			</script>
</div>
<section class="sidebar-related">
<h3 class="category-heading">
More in Dragaholic </h3>
<div class="cards-list">
<article id="post-580627" class="card card-small dragaholic-link">
<a href="https://www.queerty.com/jinkx-monsoon-brand-new-podcast-now-heres-listen-20210428">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/04/jinkx-monsoon-podcast.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Jinkx Monsoon has a brand new podcast out now&#8211;here&#8217;s how to listen">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Add to queue</div>
<h2 class="entry-title">Jinkx Monsoon has a brand new podcast out now&#8211;here&#8217;s how to listen</h2> <div class="entry-meta">
<a href="https://www.queerty.com/jinkx-monsoon-brand-new-podcast-now-heres-listen-20210428" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-28T11:38:47-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-579052" class="card card-small dragaholic-link">
<a href="https://www.queerty.com/drag-queens-modern-day-shamans-alaska-takes-us-church-drag-comedy-20210414">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/04/alaska_special-771-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Are drag queens modern-day shamans? Alaska takes us to the church of drag comedy.">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Drag Frontiers</div>
<h2 class="entry-title">Are drag queens modern-day shamans? Alaska takes us to the church of drag comedy.</h2> <div class="entry-meta">
<a href="https://www.queerty.com/drag-queens-modern-day-shamans-alaska-takes-us-church-drag-comedy-20210414" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-14T14:55:58-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-578389" class="card card-small dragaholic-link">
<a href="https://www.queerty.com/reddit-sleuths-say-theyve-uncovered-secret-cast-international-drag-race-stars-20210323">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2018/07/rupaul-shocked.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Reddit sleuths say they&#8217;ve uncovered the secret cast of &#8216;International Drag Race All-Stars&#8217;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Ru-mors</div>
<div class="card-commentcount">11 comments</div><h2 class="entry-title">Reddit sleuths say they&#8217;ve uncovered the secret cast of &#8216;International Drag Race All-Stars&#8217;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-578328" class="card card-small dragaholic-link">
<a href="https://www.queerty.com/nightclubs-rush-apologize-following-drag-race-racism-scandal-20210322">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/03/connections-nightclub.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Nightclubs rush to apologize following &#8216;Drag Race&#8217; racism scandal">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Racism's a Drag</div>
<h2 class="entry-title">Nightclubs rush to apologize following &#8216;Drag Race&#8217; racism scandal</h2> <div class="entry-meta">
<a href="https://www.queerty.com/nightclubs-rush-apologize-following-drag-race-racism-scandal-20210322" rel="bookmark"><time class="entry-date published updated" datetime="2021-03-22T12:40:31-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-2" id="div-gpt-ad-box2">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box2'); });
			</script>
</div>
<br>
<div style="width:300px; border:1px solid #EFEFEF; text-align:left; padding:10px; margin-left:auto; margin-right:auto;">
<a href="https://www.queerty.com/podcast/" style="float:left; margin-right:10px;"><img src="https://content.production.cdn.art19.com/images/77/87/4f/6c/77874f6c-6d73-4253-9fa0-1a10f85c198d/50a1b9d1711a394dd18db7a4127889370b188aba2cb38148d2fcfbfb98d2787b4ed3d50cf06d6e6c5a500456feef79e168f7676d7286162d85fa116e0cb6d86d.jpeg" alt="Thumbnail" height="80" width="80" border="0"></a>
<a href="https://www.queerty.com/podcast/" style="color:#000; font-family: proxima-nova, sans-serif; font-size:15px; padding-bottom:5px; text-decoration:none;">LISTEN: Bennifer is Back (w/ Bianca Del Rio)</a>
<br> <small>Listen at: <a href="https://podcasts.apple.com/us/podcast/queerty/id1544558907">Apple</a> &middot; <a href="https://open.spotify.com/show/7DAZbVOmbLkDHJnM7VtTJV">Spotify</a> &middot; <a href="https://podcasts.google.com/feed/aHR0cHM6Ly9yc3MuYXJ0MTkuY29tL3F1ZWVydHk=">Google </a> &middot; <a href="https://www.stitcher.com/show/queerty">Stitcher</a></small>
</div>
<section class="sidebar-related">
<h3 class="category-heading">
Popular on Queerty
</h3>
<div class="cards-list">
<article id="post-582312" class="card card-small ">
<a href="https://www.queerty.com/ivanka-trumps-chance-becoming-president-just-reduced-zero-20210519">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/ivanka-nbc-interview-screenshot-670x479-1-1.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Ivanka Trump&#8217;s chance of becoming president was just reduced to zero">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Probed</div>
<div class="card-commentcount">1.5K shares</div><h2 class="entry-title">Ivanka Trump&#8217;s chance of becoming president was just reduced to zero</h2> <div class="entry-meta">
<a href="https://www.queerty.com/ivanka-trumps-chance-becoming-president-just-reduced-zero-20210519" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-19T16:06:37-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-582587" class="card card-small ">
<a href="https://www.queerty.com/ivanka-trump-accidentally-purpose-commit-perjury-sure-looks-like-20210524">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/06/ivanka-trump-video-speech-bye-ivanka.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Did Ivanka Trump accidentally on purpose commit perjury? It sure looks like it!">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">perjurer?</div>
<div class="card-commentcount">26 comments</div><h2 class="entry-title">Did Ivanka Trump accidentally on purpose commit perjury? It sure looks like it!</h2> <div class="entry-meta">
<a href="https://www.queerty.com/ivanka-trump-accidentally-purpose-commit-perjury-sure-looks-like-20210524" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-24T13:21:02-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-582225" class="card card-small ">
<a href="https://www.queerty.com/men-posting-hairy-chests-twitter-prove-theyre-not-ick-20210519">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/hairy_chests_ick_shutterstock_670_355.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Men are posting their hairy chests to Twitter to prove they’re not ‘ick’">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Hot and hirsute</div>
<div class="card-commentcount">27 comments</div><h2 class="entry-title">Men are posting their hairy chests to Twitter to prove they’re not ‘ick’</h2> <div class="entry-meta">
<a href="https://www.queerty.com/men-posting-hairy-chests-twitter-prove-theyre-not-ick-20210519" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-19T09:25:00-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-582348" class="card card-small ">
<a href="https://www.queerty.com/lego-launch-first-lgbtq-set-everyone-awesome-20210520">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/lego_lgbtq_670_355.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="LEGO launches its first LGBTQ set – because “Everyone is Awesome”">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">child's play</div>
<div class="card-commentcount">28 comments</div><h2 class="entry-title">LEGO launches its first LGBTQ set – because “Everyone is Awesome”</h2> <div class="entry-meta">
<a href="https://www.queerty.com/lego-launch-first-lgbtq-set-everyone-awesome-20210520" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-20T09:10:16-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-582356" class="card card-small ">
<a href="https://www.queerty.com/ryan-murphy-pays-beautiful-tribute-billy-porter-reveals-hiv-status-20210520">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/billy_porter_ryan_murphy_shutterstock.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Ryan Murphy pays beautiful tribute to Billy Porter after he reveals HIV status">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">truth</div>
<div class="card-commentcount">22 comments</div><h2 class="entry-title">Ryan Murphy pays beautiful tribute to Billy Porter after he reveals HIV status</h2> <div class="entry-meta">
<a href="https://www.queerty.com/ryan-murphy-pays-beautiful-tribute-billy-porter-reveals-hiv-status-20210520" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-20T09:45:38-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</section>
</aside>
<br clear=all>
<div class="single-bottom-articles">
<h3>
Latest on Queerty </h3>
<div class="single-bottom-articles-slider slider slick-slider">
<div><article id="post-582752" class="card card-small ">
<a href="https://www.queerty.com/rand-paul-wife-accuse-80s-singer-possibly-behind-foiled-plot-killed-20210526">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/rand-paul-kelley-paul.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Rand Paul and his wife accuse &#8217;80s singer of possibly being behind foiled plot to have them killed">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">drama queens</div>
<h2 class="entry-title">Rand Paul and his wife accuse &#8217;80s singer of possibly being behind foiled plot to have them killed</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-582745" class="card card-small ">
<a href="https://www.queerty.com/hitler-satan-trending-course-something-marjorie-taylor-greene-said-20210526">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/marjorie-taylor-green-nazis.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Hitler and Satan are trending and of course it has to do with something Marjorie Taylor Greene said">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">qanon queen</div>
<h2 class="entry-title">Hitler and Satan are trending and of course it has to do with something Marjorie Taylor Greene said</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-582739" class="card card-small gaycities-link">
<a target="_blank" href="https://www.gaycities.com/outthere/51346/photos-10-worlds-sexiest-nude-beaches-enjoy-safely-summer/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=PHOTOS%3A+10+of+the+world%E2%80%99s+sexiest+nude+beaches+to+enjoy+safely+this+summer">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/men_nude_beach_shutterstock_15594820.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="PHOTOS: 10 of the world’s sexiest nude beaches to enjoy safely this summer">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">wanderlust</div>
<h2 class="entry-title">PHOTOS: 10 of the world’s sexiest nude beaches to enjoy safely this summer</h2> <div class="entry-meta">
<a href="https://www.queerty.com/photos-10-worlds-sexiest-nude-beaches-enjoy-safely-summer-2-20210526" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-26T10:15:56-04:00">2 hours ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-581995" class="card card-small pride-50-link">
<a href="https://www.queerty.com/boy-bander-duncan-james-reveals-survive-homophobia-gay-dad-20210526">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/Screen-Shot-2021-05-24-at-2.30.57-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Boy bander Duncan James reveals how to survive homophobia as a gay dad">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">boy in the band</div>
<h2 class="entry-title">Boy bander Duncan James reveals how to survive homophobia as a gay dad</h2> <div class="entry-meta">
<a href="https://www.queerty.com/boy-bander-duncan-james-reveals-survive-homophobia-gay-dad-20210526" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-26T10:00:56-04:00">3 hours ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-582732" class="card card-small ">
<a href="https://www.queerty.com/lauren-boebert-like-use-pronoun-reference-20210526">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/03/lauren_boebert_wikimedia_commons_2021.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Lauren Boebert reveals new preferred “pronoun”">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">So original</div>
<div class="card-commentcount">7 comments</div><h2 class="entry-title">Lauren Boebert reveals new preferred “pronoun”</h2> <div class="entry-meta">
<a href="https://www.queerty.com/lauren-boebert-like-use-pronoun-reference-20210526" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-26T09:20:32-04:00">3 hours ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-582706" class="card card-small lgbtqnation-link">
<a target="_blank" href="https://www.lgbtqnation.com/2021/05/rapper-dies-bisexual-threeway-jumped-off-balcony-hide-wife/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=Rapper+dies+during+bisexual+threeway.+He+jumped+off+a+balcony+to+hide+from+his+wife.">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/MCKevin.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Rapper dies during bisexual threeway. He jumped off a balcony to hide from his wife.">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">wasn't his wife</div>
<h2 class="entry-title">Rapper dies during bisexual threeway. He jumped off a balcony to hide from his wife.</h2> <div class="entry-meta">
<a href="https://www.queerty.com/rapper-dies-bisexual-threeway-jumped-off-balcony-hide-wife-20210525" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-25T14:59:04-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-582703" class="card card-small ">
<a href="https://www.queerty.com/actor-ronen-rubinstein-reveals-one-thing-helped-come-bisexual-20210525">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/Ronen-Rubinstein-590x370-1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Actor Ronen Rubinstein reveals the one thing that helped him come out as bisexual">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">opening up</div>
<div class="card-commentcount">10 comments</div><h2 class="entry-title">Actor Ronen Rubinstein reveals the one thing that helped him come out as bisexual</h2> <div class="entry-meta">
<a href="https://www.queerty.com/actor-ronen-rubinstein-reveals-one-thing-helped-come-bisexual-20210525" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-25T14:57:57-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-582690" class="card card-small ">
<a href="https://www.queerty.com/watch-anderson-cooper-eviscerates-ted-cruz-homophobic-comments-20210525">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/anderson-ted-cruz2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="WATCH: Anderson Cooper eviscerates Ted Cruz over homophobic comments">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Cruz Control</div>
<div class="card-commentcount">9 comments</div><h2 class="entry-title">WATCH: Anderson Cooper eviscerates Ted Cruz over homophobic comments</h2> <div class="entry-meta">
<a href="https://www.queerty.com/watch-anderson-cooper-eviscerates-ted-cruz-homophobic-comments-20210525" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-25T14:31:33-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-582691" class="card card-small ">
<a href="https://www.queerty.com/ellen-plans-flee-country-show-ends-no-choice-matter-source-says-20210525">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/07/ellen_degeneres_letter_youtube_670_355.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Ellen plans to leave the country after her show ends, has &#8220;no choice in the matter&#8221; source says">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">moving on</div>
<div class="card-commentcount">47 comments</div><h2 class="entry-title">Ellen plans to leave the country after her show ends, has &#8220;no choice in the matter&#8221; source says</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-582669" class="card card-small ">
<a href="https://www.queerty.com/kevin-spacey-attempting-comeback-accuser-furious-20210525">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/shutterstock_101217715-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Kevin Spacey is attempting a comeback. His accuser is furious.">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Act III</div>
<div class="card-commentcount">39 comments</div><h2 class="entry-title">Kevin Spacey is attempting a comeback. His accuser is furious.</h2> <div class="entry-meta">
<a href="https://www.queerty.com/kevin-spacey-attempting-comeback-accuser-furious-20210525" rel="bookmark"><time class="entry-date published updated" datetime="2021-05-25T13:33:25-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-582667" class="card card-small ">
<a href="https://www.queerty.com/jewish-republican-accepts-money-nazis-rants-forcing-fish-exercise-treadmills-20210525">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/josh-mandel-screengrab-interview.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Jewish Republican who accepts money from Nazis rants about forcing fish to exercise on treadmills">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">something's fishy</div>
<div class="card-commentcount">26 comments</div><h2 class="entry-title">Jewish Republican who accepts money from Nazis rants about forcing fish to exercise on treadmills</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-582509" class="card card-small queerty-interview-link">
<a href="https://www.queerty.com/blake-lee-describes-going-christmas-hunk-psycopath-cruel-summer-20210525">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/05/157022_0471-crop.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Blake Lee describes going from Christmas hunk to psycopath in &#8216;Cruel Summer&#8217;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">'Cruel' Dude</div>
<h2 class="entry-title">Blake Lee describes going from Christmas hunk to psycopath in &#8216;Cruel Summer&#8217;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div>
</div>
</div></div>
</div>
<div class="site-footer-holder">
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="footer-brand">
<span class="asterisk"> </span> Free of an agenda (except that gay one)
</div>
<div class="tags-links">
<a href="//www.queerty.com/tag/andy-cohen">Andy Cohen</a> <a href="//www.queerty.com/tag/bowen-yang">Bowen Yang</a> <a href="//www.queerty.com/tag/colton-underwood">Colton Underwood</a> <a href="//www.queerty.com/tag/conrad-rocha">Conrad Rocha</a> <a href="//www.queerty.com/tag/gus-kenworthy">Gus Kenworthy</a> <a href="//www.queerty.com/tag/janet-mock">Janet Mock</a> <a href="//www.queerty.com/tag/lil-nas-x">Lil Nas X</a> <a href="//www.queerty.com/tag/ricky-martin">Ricky Martin</a> <a href="//www.queerty.com/tag/russell-tovey">Russell Tovey</a> <a href="//www.queerty.com/tag/ryan-murphy">Ryan Murphy</a> <div class="second-row">
<a href="//www.queerty.com/tag/homophobia">Homophobia</a> <a href="//www.queerty.com/tag/racism">Racism</a> <a href="//www.queerty.com/tag/rupaul's-drag-race">Rupaul's Drag Race</a> <a href="//www.queerty.com/tag/matt-gaetz">Matt Gaetz</a> <a href="//www.queerty.com/tag/transphobia">Transphobia</a> <a href="//www.queerty.com/tag/relationships">Relationships</a> <a href="//www.queerty.com/tag/grindr">Grindr</a>
</div>
</div>
<div class="footer-links">
<ul class="main" id="footer-company-links">
<li><a href="http://www.q.digital"><img src="/assets/q-digital-blue-90x37.png" alt="Q.digital" width="90"></a></li>
<li><b>A Q.Digital Company</b></li>
<li>&copy; 2021 Queerty, Inc.</li>
<li><a href="http://www.q.digital">Advertise With Us</a></li>
</ul>
<ul class="main" id="footer-contact-links">
<li><h3>Contact</h3></li>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
<li><a href="https://www.queerty.com/queertys-comment-policy">Comments Policy</a>
<li><a href="https://www.queerty.com/privacy-policy">Privacy Statement</a>
<li><a href="https://www.queerty.com/terms-of-use">Terms of Use</a>
<li><a id="ccpaOptOut">Do Not Sell My Personal Information</a>
</ul>
<ul class="main" id="footer-follow-links">
<li><h3>Follow</h3></li>
<li><a href="https://linktr.ee/queertypodcast">Podcast</a></li>
<li><a href="https://www.facebook.com/Queerty/">Facebook</a></li>
<li><a href="https://www.twitter.com/Queerty/">Twitter</a></li>
<li><a href="https://www.instagram.com/Queerty/">Instagram</a></li>
<li><a href="https://www.youtube.com/user/QueertyTV/">YouTube</a></li>
</ul>
<ul class="main double" id="footer-gaycities-links">
<li><h3>GayCities: Your Gay Travel Guide:</h3></li>
<li><a href="https://newyork.gaycities.com/">New York</a></li>
<li><a href="https://london.gaycities.com/">London</a></li>
<li><a href="https://sanfrancisco.gaycities.com/">San Francisco</a></li>
<li><a href="https://chicago.gaycities.com/">Chicago</a></li>
<li><a href="https://losangeles.gaycities.com/">Los Angeles</a></li>
<li><a href="https://washingtondc.gaycities.com/">Washington DC</a></li>
<li><a href="https://dallas.gaycities.com/">Dallas</a></li>
<li><a href="https://saskatoon.gaycities.com/">Gay Saskatoon</a></li>
<li><a href="https://www.gaycities.com/places/"><b>See all 230+ cities...</b></a></li>
</ul>
</div>
</footer>
</div>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "32666898" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=32666898&cv=2.0&cj=1" alt="Comscore Measurement" />
</noscript>

<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '686853021424163');
  fbq('track', 'PageView');
</script>
<noscript><img height='1' width='1' style='display:none'
  src='https://www.facebook.com/tr?id=686853021424163&ev=PageView&noscript=1'
/></noscript>

<script>
  fbq('track', 'ViewContent');
</script>
<script>
	window.dataLayer = window.dataLayer || []
	dataLayer.push({
	   'event': 'Page Details',
	   'pageType': 'article',
	   'pageCategory': 'dragaholic'
	   
	});
	</script>
<script type="text/javascript">var algolia = {"debug":false,"application_id":"6S92GABH7H","search_api_key":"cfd5e12cdf4a6106712391cbcf54f087","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"queerty_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"queerty_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]}}};</script><script>(function(d){var s=d.createElement('script');s.type='text/javascript';s.src='https://a.omappapi.com/app/js/api.min.js';s.async=true;s.dataset.campaign='e0mfnzjpsutchxulkvrp';s.dataset.user='40711';d.getElementsByTagName('head')[0].appendChild(s);})(document);</script> <script type="text/javascript">
		var e0mfnzjpsutchxulkvrp_shortcode = true;		</script>
<script type='text/javascript' src='https://q-digital.videoplayerhub.com/galleryplayer.js?ver=20201101' id='bt-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' async src='https://platform.twitter.com/widgets.js?ver=20161216' id='twitter-js-js'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js?ver=5.7.2' id='slick-js'></script>
<script type='text/javascript' async src='https://www.queerty.com/content/themes/queerty_2017/js/min/queerty-nosticky-min.js?ver=20200120a' id='queerty_2017-main-js'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.7.2' async='async' id='remote_sdk-js'></script>
<script type='text/javascript' src='https://www.queerty.com/content/plugins/optinmonster/assets/js/helper.js?ver=2.3.3' id='optinmonster-wp-helper-js'></script>
<script type="text/javascript">var omapi_localized = { ajax: 'https://www.queerty.com/wp/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: '474e19c82d', slugs: {"e0mfnzjpsutchxulkvrp":{"slug":"e0mfnzjpsutchxulkvrp","mailpoet":false}} };</script>
<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":582753,"object_key":"post","object_type":"post","term_ids":[69394,72450,2215,310,77410,11047,11089]};</script>
<script data-cfasync="false" id="parsely-cfg" data-parsely-site="queerty.com" src="https://cdn.parsely.com/keys/queerty.com/p.js"></script>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"65589fb03d811c54","r":1,"version":"2021.5.1","si":10}'></script>
</body>
</html>