<!DOCTYPE html>
<html>
<head>
<script type="text/javascript" src="//digg7anmcfked.cloudfront.net/script.js"></script>
<link rel="stylesheet" href="https://use.typekit.net/cdb4vyt.css">
<meta name="viewport" content="width=device-width, initial-scale=1">

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
</script>

<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.2634970.min.js?cachebuster=1';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      // Return control to GPT if the AdBridg library fails to load.
      adb.onerror = function() {
        console.log('Fallback: ')
        if (AdBridg.exists) { return; }
        document.createElement('IMG').src = '//adspsp.com/pt/2634970/3/1/?e=0';
        var dq = [], es;
        dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
        AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
        AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
        AdBridg.destroySlots = function(s) { return googletag.destroySlots(s); }
        AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
        AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
        AdBridg.render = function() { }
        AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
        AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
        AdBridg.useSizeMapping = function() { }
        AdBridg.cmd.push = function(f) {
          if (typeof(f)=='object') {
            var api_fallback = function(o) {
              googletag.cmd.push(function() {
                var u=AdBridg.defineSlot(o.gpt_path,o.size||[],o.dom_id);
                if(o.size_map) {
                  var m = googletag.sizeMapping();
                  for(var oi=0;oi<o.size_map.length;oi++){m=m.addSize(o.size_map[oi].viewport, o.size_map[oi].sizes);}
                  u.defineSizeMapping(m.build());
                }
                if(o.events) {
                  if(o.events["gpt.defined"]){o.events["gpt.defined"](u);}
                  var fl = function(a,b){if(o.events[a]){googletag.pubads().addEventListener(b,function(e){if(e.slot===u){o.events[a](u,e)}})}}
                  fl("gpt.rendered",'slotRenderEnded');
                  fl("gpt.viewed",'impressionViewable');
                  fl("gpt.visibilityChanged",'slotVisibilityChanged');
                }
              });
            }
            if(f.length){for(var i=0;i<f.length;++i){api_fallback(f[i]);}}else{api_fallback(f);}
            f=function(){AdBridg.serve()}
          }
          return googletag.cmd.push(f);
        }
        while (AdBridg.cmd.length) { AdBridg.cmd.push(AdBridg.cmd.shift()); }
      }
  })();
AdBridg.cmd.push({
	action: 'spa_pv_initialize',
	config: {
		footer_sticky: false,
		qd_path: '/4564944/queerty/health/article'
	}
});
</script>
<script>
AdBridg.cmd.push(function () {
	googletag.pubads().collapseEmptyDivs();
	googletag.pubads().setTargeting('articleid', ['605809']);
	googletag.pubads().setTargeting('Tag', ['articlepage','advice','ask jake','jake myers','lgbtq therapy space','health','life','queerty']);
	googletag.pubads().setTargeting('UGC', ['no']);
  });
</script>
<script>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</script>
<title>I’m addicted to posting my naked fat pics on Reddit / Queerty</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//powerad.ai' />
<link rel='dns-prefetch' href='//q-digital.videoplayerhub.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Feed" href="https://www.queerty.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Comments Feed" href="https://www.queerty.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; I’m addicted to posting my naked fat pics on Reddit Comments Feed" href="https://www.queerty.com/im-addicted-posting-naked-fat-pics-reddit-20220102/feed" />
<link rel='stylesheet' id='queerty_2017-style-css' href='https://www.queerty.com/content/themes/queerty_2017/style.css?ver=20211221a' type='text/css' media='all' />
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://powerad.ai/script.js?ver=20201101' id='nxtm-js'></script>
<link rel="canonical" href="https://www.queerty.com/im-addicted-posting-naked-fat-pics-reddit-20220102" />
<meta property="og:site_name" content="Queerty" /><meta name="twitter:card" content="summary_large_image"> <meta name="description" content="&quot;Recently, I&#039;ve started posting pictures of myself naked on Reddit in threads for lovers of overweight gay men. When I do this, I am immediately flooded with validation and praise..." />
<meta property="og:description" content="&quot;Recently, I&#039;ve started posting pictures of myself naked on Reddit in threads for lovers of overweight gay men. When I do this, I am immediately flooded with validation and praise...">
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.queerty.com/im-addicted-posting-naked-fat-pics-reddit-20220102" />
<meta property="og:title" content="I’m addicted to posting my naked fat pics on Reddit" />
<meta property="og:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/shutterstock_1271086231.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=1200&h=630&wat=1&wat_gravity=southeast&wat_pad=70" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta name="twitter:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/shutterstock_1271086231.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=1200&h=630&wat=1&wat_gravity=southeast&wat_pad=70" />
<meta name="publish_date" property="article:published_time" content="2022-01-02T10:00:52-05:00" />
<meta property="article:modified_time" content="2021-12-22T17:24:35-05:00" />
<meta name="twitter:url" content="https://www.queerty.com/im-addicted-posting-naked-fat-pics-reddit-20220102" />
<meta name="twitter:title" content="I’m addicted to posting my naked fat pics on Reddit" />
<meta name="twitter:description" content="&quot;Recently, I&#039;ve started posting pictures of myself naked on Reddit in threads for lovers of overweight gay men. When I do this, I am immediately flooded with validation and praise..." />
<meta name="news_keywords" content="Advice, Ask Jake, Jake Myers, LGBTQ Therapy Space"><meta property="article:tags" content="Advice, Ask Jake, Jake Myers, LGBTQ Therapy Space"><meta name="author" property="author" content="Jake Myers" /><meta name="twitter:label1" content="By"><meta name="twitter:data1" content="Jake Myers"> <style>
            #tps_carousel_container ._button,
            #tps_carousel_container ._button svg {
                color: #f08100;
                fill: #f08100;
            }

            #tps_carousel_container ._button {
                font-size: 32px;
                line-height: 32px;
            }

            #tps_carousel_container ._button svg {
                width: 32px;
                height: 32px;
            }

            #tps_carousel_container ._button:hover,
            #tps_carousel_container ._button:focus,
            #tps_carousel_container ._button:hover svg,
            #tps_carousel_container ._button:focus svg {
                color: #ffa338;
                fill: #ffa338;
            }

            #tps_carousel_container ._disabled,
            #tps_carousel_container ._disabled svg {
                color: #777777 !important;
                fill: #777777 !important;
            }

            #tps_carousel_container ._carousel {
                margin: 0 42px;
            }

            #tps_carousel_container ._prev {
                margin-right: 10px;
            }

            #tps_carousel_container ._next {
                margin-left: 10px;
            }
        </style>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KRQPBJR');</script>

<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
<link rel="preconnect" href="https://queerty-assets.s3.amazonaws.com">
<link rel="preload" href="https://www.googletagservices.com/tag/js/gpt.js">
<link rel="preconnect" href="https://www.googletagmanager.com">
<link rel="preconnect" href="https://adabgmwwup.cloudimg.io/">
<meta property="fb:app_id" content="153299894806318" />
<meta property="fb:pages" content="33720334139" />
<meta name="application-name" content="Queerty*">
<meta name="msapplication-config" content="https://queerty-assets.s3.amazonaws.com/assets/q-2017/favicons/browserconfig.xml?v=lkgzj5W5Gl">
<link rel="apple-touch-icon" sizes="180x180" href="https://queerty-assets.s3.amazonaws.com/assets/q-2017/favicons/apple-touch-icon.png?v=lkgzj5W5Gl">
<link rel="icon" type="image/png" href="https://queerty-assets.s3.amazonaws.com/assets/q-2017/favicons/favicon-32x32.png?v=lkgzj5W5Gl" sizes="32x32">
<link rel="icon" type="image/png" href="https://queerty-assets.s3.amazonaws.com/assets/q-2017/favicons/favicon-16x16.png?v=lkgzj5W5Gl" sizes="16x16">
<link rel="manifest" href="https://queerty-assets.s3.amazonaws.com/assets/q-2017/favicons/manifest.json?v=20180829">
<link rel="mask-icon" href="https://queerty-assets.s3.amazonaws.com/assets/q-2017/favicons/safari-pinned-tab.svg?v=lkgzj5W5Gl" color="#5bbad5">
<link rel="shortcut icon" href="https://queerty-assets.s3.amazonaws.com/assets/q-2017/favicons/favicon.ico?v=lkgzj5W5Gl">
<meta property="article:publisher" content="https://www.facebook.com/queerty" />
<style>
.ad-leaderboard-header {
	background-color:transparent !important;
	position:relative;
	margin-top:10px;
}
.queerty-header {
	padding-top:10px !important;
}
@media screen and (max-height: 769px) {
	.queerty-header {
    	min-height: 4.688rem;
    	padding: 10px 0 10px !important;
	}
}
</style>
</head>
<body class="post-template-default single single-post postid-605809 single-format-standard category-health category-life category-queerty">
<div id="top-of-page" style="display:none;"></div>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRQPBJR"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="div-gpt-ad-sidebarvideoplayer" style="height:1px;width:1px;">
<script>
		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-sidebarvideoplayer'); });
		</script>
</div>
<div id="page" class="site">
<div class="ad-leaderboard-header" id="div-gpt-ad-leader1">
<script>
				AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-leader1'); });
				</script>
</div>

<div id="is-phone"></div>

<header id="masthead" class="queerty-header">
<div class="queerty-header-wrapper">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="js-header-main-menu" class="queerty-header-menu show">
<li class="nav-link selected"> <a href="/">Latest</a>
</li>
<li class="nav-link navcat-life "><a class="scroll-on-page-link" data-scroll="category-life" href="https://www.queerty.com/life">Life</a></li>
<li class="nav-link navcat-entertainment "><a class="scroll-on-page-link" data-scroll="category-entertainment" href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li class="nav-link navcat-politics "><a class="scroll-on-page-link" data-scroll="category-politics" href="https://www.queerty.com/politics">Politics</a></li>
<li class="nav-link navcat-out-for-good "><a href="/out-for-good">Out for Good</a></li> </ul>
</nav>
<div class="logo-area">
<a href="/" class="queerty-logo"><!-- -->
<img src="https://queerty-assets.s3.amazonaws.com/assets/q-2017/queerty-logo.svg" width="275" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo">
<img src="/assets/promos/pride/2019/queerty-pride.svg" width="275" alt="Queerty* Pride" class="queerty-header-pride-logo" style="display:none;">
</a>
</div>
<nav id="right-navigation" class="secondary-navigation" role="navigation">
<ul id="js-header-secondary-menu" class="queerty-header-menu show">
<li class="nav-link">
<a href="https://www.facebook.com/Queerty/"><img src="/assets/icons/facebook-f-icon.svg" height="19" aria-hidden="true" alt="Facebook"></a>
</li>
<li class="nav-link">
<a href="https://twitter.com/queerty"><img src="/assets/icons/twitter-icon.svg" height="19" aria-hidden="true" alt="Twitter"></a>
</li>
<li class="nav-link">
<a href="https://www.instagram.com/queerty/"><img src="/assets/icons/instagram-icon.svg" height="19" aria-hidden="true" alt="Instagram"></a>
</li>
<li class="nav-link">
<a href="https://www.youtube.com/queerty/"><img src="/assets/icons/youtube-icon.svg" height="19" aria-hidden="true" alt="YouTube"></a>
</li>
<li class="nav-link">
<a href="https://eepurl.com/RrfMf"><img src="/assets/icons/envelope-regular.svg" height="19" aria-hidden="true" alt="newsletter"></a>
</li>
<li class="nav-link queerty-menu-button" id="more-menu">
<img src="/assets/icons/bars-solid.svg" height="19" aria-hidden="true" title="Open Menu" alt="Menu">
</li>
</ul>
</nav>
</div>
</header>
<nav class="queerty-menu-content">
<div class="queerty-menu-close"><img src="/assets/icons/times-solid.svg" height="19" aria-hidden="true" title="Close Menu" alt="Close"></i></div>
<div class="queerty-menu-logo"><img src="https://queerty-assets.s3.amazonaws.com/assets/q-2017/queerty-logo.svg" width="100" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo"></div>
<div class="queerty-menu-searchbox">
<form role="search" method="get" class="search-form" action="https://www.queerty.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
<ul>
<li><a href="https://www.queerty.com/wp/wp-login.php?redirect_to=%2F%2Fwww.queerty.com%2Fim-addicted-posting-naked-fat-pics-reddit-20220102" id="menu-login">Log in</a></li>
<li><a href="https://www.queerty.com/wp/wp-login.php?action=register" id="menu-register">Register</a></li>
</ul>
<div class="menu-now-on-queerty-container"><ul id="menu-now-on-queerty" class="menu"><li id="menu-item-441445" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-441445"><a href="https://www.queerty.com/life">Life</a></li>
<li id="menu-item-441443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441443"><a href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li id="menu-item-441446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441446"><a href="https://www.queerty.com/politics">Politics</a></li>
<li id="menu-item-441444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441444"><a href="https://www.queerty.com/goods">Goods</a></li>
<li id="menu-item-420168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-420168"><a href="//www.queerty.com/queerty-tv/">Video (Queerty TV)</a></li>
<li id="menu-item-504333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-504333"><a href="https://www.queerty.com/ever-after">Queerty Ever After</a></li>
<li id="menu-item-420166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-420166"><a href="https://www.queerty.com/dragaholic">Dragaholic</a></li>
<li id="menu-item-469065" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-469065"><a href="https://www.queerty.com/prepared">Prepared</a></li>
<li id="menu-item-573116" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-573116"><a href="https://www.queerty.com/health">Health</a></li>
<li id="menu-item-591416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-591416"><a href="https://www.queerty.com/out-for-good">Out for Good</a></li>
</ul></div>
<ul>
<li><a href="https://www.lgbtqnation.com/">LGBTQ Nation News</a></li>
<li><a href="https://www.gaycities.com/">GayCities Travel Guides</a></li>
</ul>
<ul>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
</ul>
<ul><li><a href="#" id="toggle-dark-mode">Toggle Dark Mode</a></li></ul>
</nav>
<div class="queerty-menu-fade-screen"></div>
<div id="content" class="site-content"> <header class="archive-header health-header single-wrapper">
<h1 class="category-heading">
<a href="/health" title="Queerty Health">
<img src="https://queerty-assets.s3.amazonaws.com/assets/editorial-headers/queerty-health-logo.png" alt="Queerty Health News" align="absmiddle" height="50" style="height:50px;" />
</a>
</h1>
</header>
<div class="single-wrapper">
<div id="primary" class="content-area single-article ">
<main id="main" class="site-main" role="main">
<article id="post-605809" class="post-605809 post type-post status-publish format-standard has-post-thumbnail hentry category-health category-life category-queerty tag-advice tag-ask-jake tag-jake-myers tag-lgbtq-therapy-space">
<header class="entry-header">
<div class="kicker ">ask jake</div> <h1 class="entry-title"><a href="https://www.queerty.com/im-addicted-posting-naked-fat-pics-reddit-20220102"><span itemprop="headline">I’m addicted to posting my naked fat pics on Reddit</span></a></h1>
<div class="entry-meta">
<span class="byline"> By <span itemprop="author"> <span class="author vcard">Jake Myers</span></span></span> <time class="posted-on" itemprop="datePublished" datetime="2022-01-02T10:00:52-05:00">59 minutes ago</time> </div>
</header>
<div class="entry-content" itemprop="articleBody">
<p><img loading="lazy" class="aligncenter size-large wp-image-606184" src="https://queerty-prodweb.s3.amazonaws.com/2021/12/shutterstock_1271086231-670x377.jpg" alt="" width="670" height="377" srcset="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/shutterstock_1271086231-670x377.jpg?&amp;auto=format&amp;auto=compress&amp;w=670 670w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/shutterstock_1271086231-670x377.jpg?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/shutterstock_1271086231-670x377.jpg?&amp;auto=format&amp;auto=compress&amp;w=1000 1000w" sizes="(max-width: 670px) 100vw, 670px"></p>
<p><strong><em>Hi Jake,</em></strong></p>
<p><strong><em>I’ve fallen into a pattern that I need to figure out. I am a bigger guy and because of this dating has never been easy. I’ve been blocked so many times by guys on <a href="https://www.queerty.com/tag/grindr">Grindr</a> just because I’m fat. Recently, I’ve started posting pictures of myself naked on Reddit in threads for lovers of overweight gay men. When I do this, I am immediately flooded with validation and praise. I take a disgusting picture of myself in the mirror, throw it up on a lonely Saturday night, and sit back and enjoy the tsunami of comments and private messages about how beautiful and sexy I am. The rush from this is so strong is feels almost like an addiction. Suddenly I feel so much better about myself. I used to only do it every now and then but lately it’s been a couple of times a week. So, I’m wondering if this is OK, or is this behavior is weird or somehow dangerous for my mental health?</em></strong></p>
<p><strong><em>Porky but Praised</em></strong></p>
<p>Dear Porky but Praised,</p><div class="inline-ad-holder"><div id="div-gpt-ad-inarticle1"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle1"); });</script></div></div>
<p>I can understand how it can feel good to be complimented for something you’ve been shamed for in the past. We know how superficial gay men can sometimes be, especially in places like Grindr (“no fats, no femmes”), so when you get a different reaction than you might be used to, it can be intoxicating. My concern is that in using this kind of anonymous validation as the path towards self-esteem, you’re opening yourself up to the occasional troll who may try to eviscerate you and that you’ll end up focusing on that, and it could upend you.</p>
<p>Ohio State University did a study measuring brain activity in 1998 that concluded, “negative stimuli have a greater impact on our minds than positive stimuli.” We tend to focus more on negative comments than positive ones, and allow those to overtake us. If you set yourself up to generate self-esteem from the opinions of others, your self-worth is then teetering on a weak foundation of outside views that you have no control over. One contrary opinion and that house of cards will fall.</p>
<p>Instead, I invite you to consider other options for self-worth. The only person’s opinion that ultimately matters is your own, because that’s the only one you have control over. Practice being kind to yourself when it comes to your weight and appearance. For example, I noticed you called yourself “fat” and used the word “disgusting.” What if you weren’t quite so harsh towards yourself, and viewed yourself as “a work in progress”? The tone in which you talk to yourself matters. <a href="https://lgbtqtherapyspace.com/">Therapy</a> can be a great sounding board for being aware of how we talk to ourselves, and honing new language. Practice self-love. Although it may not be as immediately gratifying, it’s ultimately a more stable foundation.</p><div class="inline-ad-holder"><div id="div-gpt-ad-inarticle2"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle2"); });</script></div></div>
<p>You also have to think about the long game here. Online validation might feel good for a moment, but ultimately when the private messages stop and the feeling you get fizzles away. If you get your self-esteem from somewhere else, it may not be as intense in the moment, but it will last a lot longer. Ask yourself, perhaps with a <a href="https://lgbtqtherapyspace.com/therapists-page/">therapist</a>, what else makes you feel good about yourself? You may discover things like doing things for others, being true to yourself, making people laugh, talking with a friend, achieving a goal, or being self-sufficient are what truly matter.</p>
<p>While you may want to reach for social media or chat boards for a quick fix, remember that it’s only a band-aid, and that it could be ripped off at any moment. Think about joining a <a href="https://www.instagram.com/lgbtqtherapyspace/">community</a> that’s based more in values rather than superficial qualities like appearance. The road to self-worth is longer and harder, but much like your body parts in those Reddit photos, you’ll be as free as the wind.</p>
<p><strong><em>Jake Myers the Founder of <a href="https://lgbtqtherapyspace.com">LGBTQ Therapy Space</a> , the first LGBTQ owned and operated national platform for teletherapy. He has a Masters in Clinical Psychology from Antioch University Los Angeles, with a specialization in LGBT Affirmative Psychotherapy, and is a Licensed Marriage &amp; Family Therapist in both California and Florida.</em></strong></p><div class="inline-ad-holder"><div id="div-gpt-ad-inarticle3"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle3"); });</script></div></div>
<p>Join the LGBTQ Therapy Space community, and ask Jake a question!<br>
<a href="https://www.instagram.com/lgbtqtherapyspace/">Instagram</a><br>
<a href="https://www.facebook.com/LGBTQTherapySpace/">Facebook</a><br>
<a href="https://twitter.com/LGBTQTherapySp">Twitter</a></p>
<p>You can also email Jake at <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="ff959e949a92869a8d8cbf8e8a9a9a8d8b86d19c9092">[email&#160;protected]</a></p>
<div class="outstream-ad-holder"><div id="div-gpt-ad-outstreamplayer"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-outstreamplayer"); });</script></div></div> </div>
<footer class="entry-footer">
<span class="tags-links"><a href="https://www.queerty.com/life" rel="category">Life</a> <a href="https://www.queerty.com/tag/advice" rel="tag">Advice</a> <a href="https://www.queerty.com/tag/ask-jake" rel="tag">Ask Jake</a> <a href="https://www.queerty.com/tag/jake-myers" rel="tag">Jake Myers</a> <a href="https://www.queerty.com/tag/lgbtq-therapy-space" rel="tag">LGBTQ Therapy Space</a></span><div class="comments-link-area"><a href="https://www.queerty.com/im-addicted-posting-naked-fat-pics-reddit-20220102#respond"><span class="comments-link">Add a comment</span></a></div> </footer>
</article>
</main>
<div class="article-email-prompt-red" id="queerty-article-email-prompt">
<h3><span class="asterisk"> </span>Get Queerty Daily</h3>
Subscribe to Queerty for a daily dose of #life #advice #askjake stories and more
<form action="//queerty.us1.list-manage.com/subscribe/post?u=ecab442566f15d8d4dcf64b0d&amp;id=221c27272a" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank">
<input type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="Your email" autocomplete="email">
<input type="hidden" name="group[5437][16]" value="1">
<input type="hidden" value="2" name="group[5409][2]" id="mce-group[5409]-5409-0">
<input type="hidden" value="1" name="group[5409][1]" id="mce-group[5409]-5409-1">
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ecab442566f15d8d4dcf64b0d_221c27272a" tabindex="-1" value=""></div>
<input type="submit" value="Subscribe" name="submit" id="mc-embedded-subscribe" class="button">
</form>
</div>
<div style="margin-left:auto; margin-right:auto; text-align: center;" id="div-gpt-ad-box5">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box5'); });
			</script>
</div>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Add your Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/im-addicted-posting-naked-fat-pics-reddit-20220102#respond" style="display:none;">Cancel reply</a></small></h3><p class="nocomments">Please <a href="https://www.queerty.com/wp/wp-login.php?redirect_to=https%3A%2F%2Fwww.queerty.com%2Fim-addicted-posting-naked-fat-pics-reddit-20220102">log in</a> to add your comment<br>Need an account? <strong><a href="https://www.queerty.com/wp/wp-login.php?action=register">Register</a></strong> *It's free and easy.</p> </div>
</div>
</div>
<script type="text/javascript" async="async" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-58640af04b28c97d"></script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.queerty.com\/im-addicted-posting-naked-fat-pics-reddit-20220102"},"headline":"I\u2019m addicted to posting my naked fat pics on Reddit","url":"https:\/\/www.queerty.com\/im-addicted-posting-naked-fat-pics-reddit-20220102","datePublished":"2022-01-02T10:00:52-05:00","dateModified":"2021-12-22T17:24:35-05:00","description":"\"Recently, I've started posting pictures of myself naked on Reddit in threads for lovers of overweight gay men. When I do this, I am immediately flooded with validation and praise.\"","thumbnailUrl":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/12\/shutterstock_1271086231-307x289.jpg","image":{"@type":"ImageObject","url":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/12\/shutterstock_1271086231-307x289.jpg","height":670,"width":377},"creator":"Jake Myers","author":{"@type":"Person","name":"Jake Myers"},"articleSection":"Life","keywords":["Health","Queerty","Advice","Ask Jake","Jake Myers","LGBTQ Therapy Space","[ Has: Twitter embed ]","[ Word count: 600-1000 ]"],"publisher":{"@type":"NewsMediaOrganization","name":"Queerty","url":"https:\/\/www.queerty.com\/","logo":{"@type":"ImageObject","url":"https:\/\/queerty-assets.s3.amazonaws.com\/assets\/q-2017\/queerty-logo-225x60.png","height":"60","width":"225"},"address":{"@type":"PostalAddress","streetAddress":"584 Castro St. #623","addressLocality":"San Francisco","addressRegion":"CA","postalCode":"94114","addressCountry":"USA"},"sameAs":["https:\/\/en.wikipedia.org\/wiki\/Queerty","https:\/\/www.facebook.com\/queerty","https:\/\/www.twitter.com\/queerty","https:\/\/www.instagram.com\/queerty","https:\/\/www.youtube.com\/user\/queertyTV"]}}</script>
<aside id="secondary" class="article-sidebar" role="complementary">
<div class="sidebar-ad-1" id="div-gpt-ad-box1">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box1'); });
			</script>
</div>
<div id="q-video-player" style="display:none;"></div>
<style>
	.sidebar-health article.card-side {
		border:none;
		background:none;
	}

</style>
<section class="sidebar-related sidebar-health">
<div style="text-align:center; margin:10px auto;">
<img src="/assets/editorial-headers/queerty-health-logo.png" width="180" alt=" Queerty Health" style="height:36px; width:auto; background:none;">
</div>
<div class="cards-list">
<article id="post-606634" class="card card-side ">
<a href="https://www.queerty.com/fda-approves-injectable-form-prep-given-every-two-months-20211221">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/06/men_interracial_couple_kissing_shutterstock.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=120&h=155" width="120" height="155" class="wp-post-image" alt="FDA approves injectable form of PrEP given every two months">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">protection</div> <h2 class="entry-title">FDA approves injectable form of PrEP given every two months</h2> <div class="entry-meta">
<a href="https://www.queerty.com/fda-approves-injectable-form-prep-given-every-two-months-20211221" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-21T09:20:41-05:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-605575" class="card card-side ">
<a href="https://www.queerty.com/viagra-linked-unexpected-beneficial-long-term-side-effect-20211207">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/viagra_sildenafil_shutterstock_1652592268.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=120&h=155" width="120" height="155" class="wp-post-image" alt="Viagra linked to unexpected and beneficial long-term side effect">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">looking up</div> <h2 class="entry-title">Viagra linked to unexpected and beneficial long-term side effect</h2> <div class="entry-meta">
<a href="https://www.queerty.com/viagra-linked-unexpected-beneficial-long-term-side-effect-20211207" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-07T09:50:17-05:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-604937" class="card card-side ">
 <a href="https://www.queerty.com/hollywood-couple-donate-250k-help-gay-men-la-tackle-meth-use-20211204">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/11/man_addiction_depresed_meth_shutterstock.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=120&h=155" width="120" height="155" class="wp-post-image" alt="Hollywood couple donate $250k to help gay men in LA tackle their meth use">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">breaking the cycle</div> <div class="card-commentcount">14 </div><h2 class="entry-title">Hollywood couple donate $250k to help gay men in LA tackle their meth use</h2> <div class="entry-meta">
<a href="https://www.queerty.com/hollywood-couple-donate-250k-help-gay-men-la-tackle-meth-use-20211204" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-04T07:29:20-05:00"></time></a> </div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-2" id="div-gpt-ad-box2">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box2'); });
			</script>
</div>
<br>
<section class="sidebar-related">
<h3 class="category-heading">
Popular on Queerty
</h3>
<div class="cards-list">
<article id="post-605996" class="card card-small ">
<a href="https://www.queerty.com/father-asks-internet-talk-birds-bees-without-heteronormativity-20220102">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/father-and-son-talking.jpeg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Father asks Internet how to talk birds and bees without heteronormativity">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">facts of life</div>
<h2 class="entry-title">Father asks Internet how to talk birds and bees without heteronormativity</h2> <div class="entry-meta">
<a href="https://www.queerty.com/father-asks-internet-talk-birds-bees-without-heteronormativity-20220102" rel="bookmark"><time class="entry-date published updated" datetime="2022-01-02T09:00:10-05:00">2 hours ago</time></a> </div>
</section>
</a>
</article>
<article id="post-606729" class="card card-small ">
<a href="https://www.queerty.com/doesnt-love-little-dan-levy-christmas-20220101">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/Happiest-Season1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Who doesn&#8217;t love a little Dan Levy at Christmas?">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">screen gems</div>
<h2 class="entry-title">Who doesn&#8217;t love a little Dan Levy at Christmas?</h2> <div class="entry-meta">
<a href="https://www.queerty.com/doesnt-love-little-dan-levy-christmas-20220101" rel="bookmark"><time class="entry-date published updated" datetime="2022-01-01T11:13:49-05:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-607214" class="card card-small ">
<a href="https://www.queerty.com/pietro-bosellis-spread-terry-millers-mask-billy-eichners-thirst-trap-20220101">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/pietro-boselli-brad-goreski-Guilherme-Everton-Ferreira-billy-eichner-instastuds.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Pietro Boselli&#8217;s spread, Terry Miller&#8217;s mask, &#038; Billy Eichner&#8217;s thirst trap">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">instastuds</div>
<h2 class="entry-title">Pietro Boselli&#8217;s spread, Terry Miller&#8217;s mask, &#038; Billy Eichner&#8217;s thirst trap</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-606570" class="card card-small ">
<a href="https://www.queerty.com/old-acquaintance-forgot-7-new-years-resolutions-queer-community-20220101">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/year-g7d3eb2070_1920.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Old acquaintance be forgot: 7 New Year’s resolutions for the queer community">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Get it together, people</div>
<div class="card-commentcount">8 </div><h2 class="entry-title">Old acquaintance be forgot: 7 New Year’s resolutions for the queer community</h2> <div class="entry-meta">
<a href="https://www.queerty.com/old-acquaintance-forgot-7-new-years-resolutions-queer-community-20220101" rel="bookmark"><time class="entry-date published updated" datetime="2022-01-01T11:00:35-05:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-606866" class="card card-small ">
<a href="https://www.queerty.com/former-wwe-superstar-jake-atlas-butt-squeezing-can-lead-fitness-20220101">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/Kenny-marquez2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Former WWE Superstar Jake Atlas on how butt squeezing can lead to fitness">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">atlas squeezed</div>
<h2 class="entry-title">Former WWE Superstar Jake Atlas on how butt squeezing can lead to fitness</h2> <div class="entry-meta">
<a href="https://www.queerty.com/former-wwe-superstar-jake-atlas-butt-squeezing-can-lead-fitness-20220101" rel="bookmark"><time class="entry-date published updated" datetime="2022-01-01T10:00:23-05:00"></time></a> </div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-3" id="div-gpt-ad-box3">
<script>
		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box3'); });
		</script>
</div>
</aside>
<br clear=all>
<div class="single-bottom-articles">
<h3>
Latest on Queerty </h3>
<div class="single-bottom-articles-slider slider slick-slider">
<div><article id="post-606703" class="card card-small ">
<a href="https://www.queerty.com/straight-people-arent-nearly-straight-think-study-suggests-20220102">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/two-men-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Straight people aren&#8217;t nearly as straight as they think, study suggests">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">questioning</div>
<h2 class="entry-title">Straight people aren&#8217;t nearly as straight as they think, study suggests</h2> <div class="entry-meta">
<a href="https://www.queerty.com/straight-people-arent-nearly-straight-think-study-suggests-20220102" rel="bookmark"><time class="entry-date published updated" datetime="2022-01-02T10:57:10-05:00">3 minutes ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-605996" class="card card-small ">
<a href="https://www.queerty.com/father-asks-internet-talk-birds-bees-without-heteronormativity-20220102">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/father-and-son-talking.jpeg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Father asks Internet how to talk birds and bees without heteronormativity">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">facts of life</div>
<h2 class="entry-title">Father asks Internet how to talk birds and bees without heteronormativity</h2> <div class="entry-meta">
<a href="https://www.queerty.com/father-asks-internet-talk-birds-bees-without-heteronormativity-20220102" rel="bookmark"><time class="entry-date published updated" datetime="2022-01-02T09:00:10-05:00">2 hours ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-606729" class="card card-small ">
<a href="https://www.queerty.com/doesnt-love-little-dan-levy-christmas-20220101">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/Happiest-Season1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Who doesn&#8217;t love a little Dan Levy at Christmas?">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">screen gems</div>
<h2 class="entry-title">Who doesn&#8217;t love a little Dan Levy at Christmas?</h2> <div class="entry-meta">
<a href="https://www.queerty.com/doesnt-love-little-dan-levy-christmas-20220101" rel="bookmark"><time class="entry-date published updated" datetime="2022-01-01T11:13:49-05:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-607214" class="card card-small ">
<a href="https://www.queerty.com/pietro-bosellis-spread-terry-millers-mask-billy-eichners-thirst-trap-20220101">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/pietro-boselli-brad-goreski-Guilherme-Everton-Ferreira-billy-eichner-instastuds.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Pietro Boselli&#8217;s spread, Terry Miller&#8217;s mask, &#038; Billy Eichner&#8217;s thirst trap">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">instastuds</div>
<h2 class="entry-title">Pietro Boselli&#8217;s spread, Terry Miller&#8217;s mask, &#038; Billy Eichner&#8217;s thirst trap</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-606570" class="card card-small ">
<a href="https://www.queerty.com/old-acquaintance-forgot-7-new-years-resolutions-queer-community-20220101">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/year-g7d3eb2070_1920.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Old acquaintance be forgot: 7 New Year’s resolutions for the queer community">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Get it together, people</div>
<div class="card-commentcount">8 </div><h2 class="entry-title">Old acquaintance be forgot: 7 New Year’s resolutions for the queer community</h2> <div class="entry-meta">
<a href="https://www.queerty.com/old-acquaintance-forgot-7-new-years-resolutions-queer-community-20220101" rel="bookmark"><time class="entry-date published updated" datetime="2022-01-01T11:00:35-05:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-606866" class="card card-small ">
<a href="https://www.queerty.com/former-wwe-superstar-jake-atlas-butt-squeezing-can-lead-fitness-20220101">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/Kenny-marquez2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Former WWE Superstar Jake Atlas on how butt squeezing can lead to fitness">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">atlas squeezed</div>
<h2 class="entry-title">Former WWE Superstar Jake Atlas on how butt squeezing can lead to fitness</h2> <div class="entry-meta">
<a href="https://www.queerty.com/former-wwe-superstar-jake-atlas-butt-squeezing-can-lead-fitness-20220101" rel="bookmark"><time class="entry-date published updated" datetime="2022-01-01T10:00:23-05:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-606083" class="card card-small ">
<a href="https://www.queerty.com/crunch-fitness-asks-patrons-sex-anywhere-mens-locker-room-20220101">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/lil-nas-x-locker-room.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Crunch Fitness asks patrons to have sex “anywhere” but the men’s locker room">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">not that kind of cardio</div>
<div class="card-commentcount">11 </div><h2 class="entry-title">Crunch Fitness asks patrons to have sex “anywhere” but the men’s locker room</h2> <div class="entry-meta">
<a href="https://www.queerty.com/crunch-fitness-asks-patrons-sex-anywhere-mens-locker-room-20220101" rel="bookmark"><time class="entry-date published updated" datetime="2022-01-01T09:00:55-05:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-607106" class="card card-small dragaholic-link">
<a href="https://www.queerty.com/drag-race-contestants-compete-next-queen-universe-20211231">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/adore-delano-670x413-1.webp?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Which &#8216;Drag Race&#8217; contestants should compete on the next &#8216;Queen of the Universe&#8217;?">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Sing out Louise</div>
<h2 class="entry-title">Which &#8216;Drag Race&#8217; contestants should compete on the next &#8216;Queen of the Universe&#8217;?</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-607208" class="card card-small lgbtqnation-link">
<a target="_blank" href="https://www.lgbtqnation.com/2021/12/ever-charming-beloved-betty-white-died-99/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=LGBTQ+icon+Betty+White+dies+at+age+99">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/betty_white_youtube.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="LGBTQ icon Betty White dies at age 99">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Rest In Peace</div>
<h2 class="entry-title">LGBTQ icon Betty White dies at age 99</h2> <div class="entry-meta">
<a href="https://www.queerty.com/lgbtq-icon-betty-white-dies-age-99-20211231" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-31T15:00:34-05:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-606540" class="card card-small ">
<a href="https://www.queerty.com/weve-noticed-straight-guys-checking-guys-right-20211231">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/man-at-gym.jpeg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="We’ve all noticed straight guys checking out other guys, right?">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">eye candy</div>
<div class="card-commentcount">26 comments</div><h2 class="entry-title">We’ve all noticed straight guys checking out other guys, right?</h2> <div class="entry-meta">
<a href="https://www.queerty.com/weve-noticed-straight-guys-checking-guys-right-20211231" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-31T12:00:46-05:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-606714" class="card card-small ">
<a href="https://www.queerty.com/new-year-dawns-take-moment-reflect-dark-moment-queer-history-20211231">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/BOY_105_BB_4232-Boys-1196.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="As a new year dawns, take a moment to reflect on a dark moment in queer history">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">weekend binge</div>
<h2 class="entry-title">As a new year dawns, take a moment to reflect on a dark moment in queer history</h2> <div class="entry-meta">
<a href="https://www.queerty.com/new-year-dawns-take-moment-reflect-dark-moment-queer-history-20211231" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-31T11:00:45-05:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-605991" class="card card-small ">
<a href="https://www.queerty.com/gay-guys-list-cartoon-crushes-aladdin-archer-20211231">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/12/archer.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Gay guys list their cartoon crushes, from Aladdin to Archer">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">drawn in</div>
<div class="card-commentcount">32 comments</div><h2 class="entry-title">Gay guys list their cartoon crushes, from Aladdin to Archer</h2> <div class="entry-meta">
<a href="https://www.queerty.com/gay-guys-list-cartoon-crushes-aladdin-archer-20211231" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-31T10:00:43-05:00"></time></a> </div>
</section>
</a>
</article>
</div>
</div>
</div></div>
</div>
<div class="site-footer-holder">
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="footer-brand">
<span class="asterisk"> </span> Free of an agenda (except that gay one)
</div>
<div class="tags-links">
<a href="//www.queerty.com/tag/andy-cohen">Andy Cohen</a> <a href="//www.queerty.com/tag/bowen-yang">Bowen Yang</a> <a href="//www.queerty.com/tag/colton-underwood">Colton Underwood</a> <a href="//www.queerty.com/tag/conrad-rocha">Conrad Rocha</a> <a href="//www.queerty.com/tag/gus-kenworthy">Gus Kenworthy</a> <a href="//www.queerty.com/tag/janet-mock">Janet Mock</a> <a href="//www.queerty.com/tag/lil-nas-x">Lil Nas X</a> <a href="//www.queerty.com/tag/ricky-martin">Ricky Martin</a> <a href="//www.queerty.com/tag/russell-tovey">Russell Tovey</a> <a href="//www.queerty.com/tag/ryan-murphy">Ryan Murphy</a> <div class="second-row">
<a href="//www.queerty.com/tag/homophobia">Homophobia</a> <a href="//www.queerty.com/tag/racism">Racism</a> <a href="//www.queerty.com/tag/rupaul's-drag-race">Rupaul's Drag Race</a> <a href="//www.queerty.com/tag/matt-gaetz">Matt Gaetz</a> <a href="//www.queerty.com/tag/transphobia">Transphobia</a> <a href="//www.queerty.com/tag/relationships">Relationships</a> <a href="//www.queerty.com/tag/grindr">Grindr</a>
</div>
</div>
<div class="footer-links">
<ul class="main" id="footer-company-links">
<li><a href="http://www.q.digital"><img src="https://queerty-assets.s3.amazonaws.com/assets/q-digital-blue-90x37.png" alt="Q.digital" width="90"></a></li>
<li><b>A Q.Digital Company</b></li>
<li>&copy; 2022 Queerty, Inc.</li>
<li><a href="http://www.q.digital">Advertise With Us</a></li>
</ul>
<ul class="main" id="footer-contact-links">
<li><h3>Contact</h3></li>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
<li><a href="https://www.queerty.com/queertys-comment-policy">Comments Policy</a>
<li><a href="https://www.queerty.com/privacy-policy">Privacy Statement</a>
<li><a href="https://www.queerty.com/terms-of-use">Terms of Use</a>
<li><a id="ccpaOptOut">Do Not Sell My Personal Information</a>
</ul>
<ul class="main" id="footer-follow-links">
<li><h3>Follow</h3></li>
<li><a href="https://www.facebook.com/Queerty/">Facebook</a></li>
<li><a href="https://www.twitter.com/Queerty/">Twitter</a></li>
<li><a href="https://www.instagram.com/Queerty/">Instagram</a></li>
<li><a href="https://www.youtube.com/user/QueertyTV/">YouTube</a></li>
</ul>
<ul class="main double" id="footer-gaycities-links">
<li><h3>GayCities: Your Gay Travel Guide:</h3></li>
<li><a href="https://newyork.gaycities.com/">New York</a></li>
<li><a href="https://london.gaycities.com/">London</a></li>
<li><a href="https://sanfrancisco.gaycities.com/">San Francisco</a></li>
<li><a href="https://chicago.gaycities.com/">Chicago</a></li>
<li><a href="https://losangeles.gaycities.com/">Los Angeles</a></li>
<li><a href="https://washingtondc.gaycities.com/">Washington DC</a></li>
<li><a href="https://dallas.gaycities.com/">Dallas</a></li>
<li><a href="https://saskatoon.gaycities.com/">Gay Saskatoon</a></li>
<li><a href="https://www.gaycities.com/places/"><b>See all 230+ cities...</b></a></li>
</ul>
</div>
</footer>
</div>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "32666898" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=32666898&cv=2.0&cj=1" alt="Comscore Measurement" />
</noscript>

<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '686853021424163');
  fbq('track', 'PageView');
</script>
<noscript><img height='1' width='1' style='display:none'
  src='https://www.facebook.com/tr?id=686853021424163&ev=PageView&noscript=1'
/></noscript>

<script>
  fbq('track', 'ViewContent');
</script>
<script>
	window.dataLayer = window.dataLayer || []
	dataLayer.push({
	   'event': 'Page Details',
	   'pageType': 'article',
	   'pageCategory': 'life'
	   
	});
	</script>
<script type="text/javascript">var algolia = {"debug":false,"application_id":"6S92GABH7H","search_api_key":"cfd5e12cdf4a6106712391cbcf54f087","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"queerty_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"queerty_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]}}};</script><script>(function(d){var s=d.createElement('script');s.type='text/javascript';s.src='https://a.omappapi.com/app/js/api.min.js';s.async=true;s.dataset.campaign='tfz4g6oz4kxaewvppkax';s.dataset.user='40711';d.getElementsByTagName('head')[0].appendChild(s);})(document);</script> <script type="text/javascript">
		var tfz4g6oz4kxaewvppkax_shortcode = true;		</script>
<script type='text/javascript' src='https://q-digital.videoplayerhub.com/galleryplayer.js?ver=20201101' id='bt-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/comment-reply.min.js?ver=5.8.2' id='comment-reply-js'></script>
<script type='text/javascript' async src='https://platform.twitter.com/widgets.js?ver=20161216' id='twitter-js-js'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js?ver=5.8.2' id='slick-js'></script>
<script type='text/javascript' async src='https://www.queerty.com/content/themes/queerty_2017/js/min/queerty-nosticky-min.js?ver=20210712a' id='queerty_2017-main-js'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
<script type='text/javascript' src='https://www.queerty.com/content/plugins/optinmonster/assets/js/helper.js?ver=2.6.9' id='optinmonster-wp-helper-js'></script>
<script type="text/javascript">var omapi_localized = {
			ajax: 'https://www.queerty.com/wp/wp-admin/admin-ajax.php?optin-monster-ajax-route=1',
			nonce: '475d5c144d',
			slugs: 
			{"tfz4g6oz4kxaewvppkax":{"slug":"tfz4g6oz4kxaewvppkax","mailpoet":false}}		};</script>
<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":605809,"object_key":"post","object_type":"post","term_ids":[83099,69296,310,1168,80373,79534,90086]};</script>
<script data-cfasync="false" id="parsely-cfg" data-parsely-site="queerty.com" src="https://cdn.parsely.com/keys/queerty.com/p.js"></script>
</body>
</html>