<!DOCTYPE html>
<html>
<head>
<script type="text/javascript" src="//digg7anmcfked.cloudfront.net/script.js"></script>
<link rel="stylesheet" href="https://use.typekit.net/cdb4vyt.css">
<meta name="viewport" content="width=device-width, initial-scale=1">

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
</script>

<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.2634970.min.js?cachebuster=1';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      // Return control to GPT if the AdBridg library fails to load.
      adb.onerror = function() {
        console.log('Fallback: ')
        if (AdBridg.exists) { return; }
        document.createElement('IMG').src = '//adspsp.com/pt/2634970/3/1/?e=0';
        var dq = [], es;
        dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
        AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
        AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
        AdBridg.destroySlots = function(s) { return googletag.destroySlots(s); }
        AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
        AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
        AdBridg.render = function() { }
        AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
        AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
        AdBridg.useSizeMapping = function() { }
        AdBridg.cmd.push = function(f) {
          if (typeof(f)=='object') {
            var api_fallback = function(o) {
              googletag.cmd.push(function() {
                var u=AdBridg.defineSlot(o.gpt_path,o.size||[],o.dom_id);
                if(o.size_map) {
                  var m = googletag.sizeMapping();
                  for(var oi=0;oi<o.size_map.length;oi++){m=m.addSize(o.size_map[oi].viewport, o.size_map[oi].sizes);}
                  u.defineSizeMapping(m.build());
                }
                if(o.events) {
                  if(o.events["gpt.defined"]){o.events["gpt.defined"](u);}
                  var fl = function(a,b){if(o.events[a]){googletag.pubads().addEventListener(b,function(e){if(e.slot===u){o.events[a](u,e)}})}}
                  fl("gpt.rendered",'slotRenderEnded');
                  fl("gpt.viewed",'impressionViewable');
                  fl("gpt.visibilityChanged",'slotVisibilityChanged');
                }
              });
            }
            if(f.length){for(var i=0;i<f.length;++i){api_fallback(f[i]);}}else{api_fallback(f);}
            f=function(){AdBridg.serve()}
          }
          return googletag.cmd.push(f);
        }
        while (AdBridg.cmd.length) { AdBridg.cmd.push(AdBridg.cmd.shift()); }
      }
  })();
AdBridg.cmd.push({
	action: 'spa_pv_initialize',
	config: {
		footer_sticky: false,
		qd_path: '/4564944/queerty/entertainment/article'
	}
});
</script>
<script>
AdBridg.cmd.push(function () {
	googletag.pubads().collapseEmptyDivs();
	googletag.pubads().setTargeting('articleid', ['591033']);
	googletag.pubads().setTargeting('Tag', ['articlepage','burn book','daily dose','mean girls','mean girls day','screen gems','weekend binge','ad friendly','entertainment','feature','queerty']);
	googletag.pubads().setTargeting('UGC', ['no']);
  });
</script>
<script>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</script>
<title>It&#8217;s &#8216;Mean Girls&#8217; Day! Celebrate in the most fetch way possible. / Queerty</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//powerad.ai' />
<link rel='dns-prefetch' href='//q-digital.videoplayerhub.com' />
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Feed" href="https://www.queerty.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Comments Feed" href="https://www.queerty.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; It&#8217;s &#8216;Mean Girls&#8217; Day! Celebrate in the most fetch way possible. Comments Feed" href="https://www.queerty.com/mean-girls-day-celebrate-fetch-way-possible-20211003/feed" />
<link rel='stylesheet' id='queerty_2017-style-css' href='https://www.queerty.com/content/themes/queerty_2017/style.css?ver=20210930a' type='text/css' media='all' />
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://powerad.ai/script.js?ver=20201101' id='nxtm-js'></script>
<link rel="canonical" href="https://www.queerty.com/mean-girls-day-celebrate-fetch-way-possible-20211003" />
<meta property="og:site_name" content="Queerty" /><meta name="twitter:card" content="summary_large_image"><meta name="twitter:creator" content="thegaymagneto"> <meta name="description" content="October 3 marks the newly-minted holiday Mean Girls Day. It&#039;s time to celebrate..." />
<meta property="og:description" content="October 3 marks the newly-minted holiday Mean Girls Day. It&#039;s time to celebrate...">
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.queerty.com/mean-girls-day-celebrate-fetch-way-possible-20211003" />
<meta property="og:title" content="It&#8217;s &#8216;Mean Girls&#8217; Day! Celebrate in the most fetch way possible." />
<meta property="og:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/mean-girls-jonathan-bennett.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=1200&h=630&wat=1&wat_gravity=southeast&wat_pad=70" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta name="twitter:image" content="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/mean-girls-jonathan-bennett.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=1200&h=630&wat=1&wat_gravity=southeast&wat_pad=70" />
<meta name="publish_date" property="article:published_time" content="2021-10-03T10:20:45-04:00" />
<meta property="article:modified_time" content="2021-10-03T10:20:33-04:00" />
<meta name="twitter:url" content="https://www.queerty.com/mean-girls-day-celebrate-fetch-way-possible-20211003" />
<meta name="twitter:title" content="It&#8217;s &#8216;Mean Girls&#8217; Day! Celebrate in the most fetch way possible." />
<meta name="twitter:description" content="October 3 marks the newly-minted holiday Mean Girls Day. It&#039;s time to celebrate..." />
<meta name="news_keywords" content="burn book, daily dose, mean girls, mean girls day, screen gems, weekend binge"><meta property="article:tags" content="burn book, daily dose, mean girls, mean girls day, screen gems, weekend binge"><meta name="author" property="author" content="David Reddish" /><meta name="twitter:label1" content="By"><meta name="twitter:data1" content="David Reddish"> <style>
            #tps_carousel_container ._button,
            #tps_carousel_container ._button svg {
                color: #f08100;
                fill: #f08100;
            }

            #tps_carousel_container ._button {
                font-size: 32px;
                line-height: 32px;
            }

            #tps_carousel_container ._button svg {
                width: 32px;
                height: 32px;
            }

            #tps_carousel_container ._button:hover,
            #tps_carousel_container ._button:focus,
            #tps_carousel_container ._button:hover svg,
            #tps_carousel_container ._button:focus svg {
                color: #ffa338;
                fill: #ffa338;
            }

            #tps_carousel_container ._disabled,
            #tps_carousel_container ._disabled svg {
                color: #777777 !important;
                fill: #777777 !important;
            }

            #tps_carousel_container ._carousel {
                margin: 0 42px;
            }

            #tps_carousel_container ._prev {
                margin-right: 10px;
            }

            #tps_carousel_container ._next {
                margin-left: 10px;
            }
        </style>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KRQPBJR');</script>

<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
<link rel="preconnect" href="https://queerty-assets.s3.amazonaws.com">
<link rel="preload" href="https://www.googletagservices.com/tag/js/gpt.js">
<link rel="preconnect" href="https://www.googletagmanager.com">
<link rel="preconnect" href="https://queerty-prodweb.imgix.net">
<meta property="fb:app_id" content="153299894806318" />
<meta name="theme-color" content="#f43700" />
<meta name="apple-itunes-app" content="app-id=1046987164">
<meta property="fb:pages" content="33720334139" />
<meta name="apple-mobile-web-app-title" content="Queerty*">
<meta name="application-name" content="Queerty*">
<meta name="msapplication-config" content="/assets/q-2017/favicons/browserconfig.xml?v=lkgzj5W5Gl">
<link rel="apple-touch-icon" sizes="180x180" href="/assets/q-2017/favicons/apple-touch-icon.png?v=lkgzj5W5Gl">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-32x32.png?v=lkgzj5W5Gl" sizes="32x32">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-16x16.png?v=lkgzj5W5Gl" sizes="16x16">
<link rel="manifest" href="/assets/q-2017/favicons/manifest.json?v=20180829">
<link rel="mask-icon" href="/assets/q-2017/favicons/safari-pinned-tab.svg?v=lkgzj5W5Gl" color="#5bbad5">
<link rel="shortcut icon" href="/assets/q-2017/favicons/favicon.ico?v=lkgzj5W5Gl">
<meta property="article:publisher" content="https://www.facebook.com/queerty" />
<style>
.ad-leaderboard-header {
	background-color:transparent !important;
	position:relative;
	margin-top:10px;
}
.queerty-header {
	padding-top:10px !important;
}
@media screen and (max-height: 769px) {
	.queerty-header {
    	min-height: 4.688rem;
    	padding: 10px 0 10px !important;
	}
}
</style>
</head>
<body class="post-template-default single single-post postid-591033 single-format-standard category-ad-friendly category-entertainment category-feature category-queerty">
<div id="top-of-page" style="display:none;"></div>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRQPBJR"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="div-gpt-ad-skin" style="height:1px;width:1px;">
<script>
		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-skin'); });
		</script>
</div>
<div id="div-gpt-ad-sidebarvideoplayer" style="height:1px;width:1px;">
<script>
		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-sidebarvideoplayer'); });
		</script>
</div>
<div id="page" class="site">
<div class="ad-leaderboard-header" id="div-gpt-ad-leader1">
<script>
				AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-leader1'); });
				</script>
</div>

<div id="is-phone"></div>

<header id="masthead" class="queerty-header">
<div class="queerty-header-wrapper">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="js-header-main-menu" class="queerty-header-menu show">
<li class="nav-link selected"> <a href="/">Latest</a>
</li>
<li class="nav-link navcat-life "><a class="scroll-on-page-link" data-scroll="category-life" href="https://www.queerty.com/life">Life</a></li>
<li class="nav-link navcat-entertainment "><a class="scroll-on-page-link" data-scroll="category-entertainment" href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li class="nav-link navcat-politics "><a class="scroll-on-page-link" data-scroll="category-politics" href="https://www.queerty.com/politics">Politics</a></li>
<li class="nav-link navcat-goods "><a class="scroll-on-page-link" data-scroll="category-goods" href="https://www.queerty.com/goods">Goods</a></li>
</ul>
</nav>
<div class="logo-area">
<a href="/" class="queerty-logo"><!-- -->
<img src="/assets/q-2017/queerty-logo.svg" width="275" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo">
<img src="/assets/promos/pride/2019/queerty-pride.svg" width="275" alt="Queerty* Pride" class="queerty-header-pride-logo" style="display:none;">
</a>
</div>
<nav id="right-navigation" class="secondary-navigation" role="navigation">
<ul id="js-header-secondary-menu" class="queerty-header-menu show">
<li class="nav-link">
<a href="https://www.facebook.com/Queerty/"><img src="/assets/icons/facebook-f-icon.svg" height="19" aria-hidden="true" alt="Facebook"></a>
</li>
<li class="nav-link">
<a href="https://twitter.com/queerty"><img src="/assets/icons/twitter-icon.svg" height="19" aria-hidden="true" alt="Twitter"></a>
</li>
<li class="nav-link">
<a href="https://www.instagram.com/queerty/"><img src="/assets/icons/instagram-icon.svg" height="19" aria-hidden="true" alt="Instagram"></a>
</li>
<li class="nav-link">
<a href="https://www.youtube.com/queerty/"><img src="/assets/icons/youtube-icon.svg" height="19" aria-hidden="true" alt="YouTube"></a>
</li>
<li class="nav-link">
<a href="https://eepurl.com/RrfMf"><img src="/assets/icons/envelope-regular.svg" height="19" aria-hidden="true" alt="newsletter"></a>
</li>
<li class="nav-link queerty-menu-button" id="more-menu">
<img src="/assets/icons/bars-solid.svg" height="19" aria-hidden="true" title="Open Menu" alt="Menu">
</li>
</ul>
</nav>
</div>
</header>
<nav class="queerty-menu-content">
<div class="queerty-menu-close"><img src="/assets/icons/times-solid.svg" height="19" aria-hidden="true" title="Close Menu" alt="Close"></i></div>
<div class="queerty-menu-logo"><img src="/assets/q-2017/queerty-logo.svg" width="100" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo"></div>
<div class="queerty-menu-searchbox">
<form role="search" method="get" class="search-form" action="https://www.queerty.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
<ul>
<li><a href="https://www.queerty.com/wp/wp-login.php?redirect_to=%2F%2Fwww.queerty.com%2Fmean-girls-day-celebrate-fetch-way-possible-20211003" id="menu-login">Log in</a></li>
<li><a href="https://www.queerty.com/wp/wp-login.php?action=register" id="menu-register">Register</a></li>
</ul>
<div class="menu-now-on-queerty-container"><ul id="menu-now-on-queerty" class="menu"><li id="menu-item-581679" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-581679"><a href="https://www.queerty.com/pride50/">Pride50 2021</a></li>
<li id="menu-item-441445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441445"><a href="https://www.queerty.com/life">Life</a></li>
<li id="menu-item-441443" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-441443"><a href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li id="menu-item-441446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441446"><a href="https://www.queerty.com/politics">Politics</a></li>
<li id="menu-item-441444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441444"><a href="https://www.queerty.com/goods">Goods</a></li>
<li id="menu-item-574436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574436"><a href="https://www.queerty.com/podcast">Queerty Podcast</a></li>
<li id="menu-item-420168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-420168"><a href="//www.queerty.com/queerty-tv/">Video (Queerty TV)</a></li>
<li id="menu-item-504333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-504333"><a href="https://www.queerty.com/ever-after">Queerty Ever After</a></li>
<li id="menu-item-420166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-420166"><a href="https://www.queerty.com/dragaholic">Dragaholic</a></li>
<li id="menu-item-469065" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-469065"><a href="https://www.queerty.com/prepared">Prepared</a></li>
<li id="menu-item-573116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-573116"><a href="https://www.queerty.com/health">Health</a></li>
</ul></div>
<ul>
<li><a href="https://www.lgbtqnation.com/">LGBTQ Nation News</a></li>
<li><a href="https://www.gaycities.com/">GayCities Travel Guides</a></li>
</ul>
<ul>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
</ul>
<ul><li><a href="#" id="toggle-dark-mode">Toggle Dark Mode</a></li></ul>
</nav>
<div class="queerty-menu-fade-screen"></div>
<div id="content" class="site-content"> <header class="archive-header entertainment-header">
<h1 class="category-heading">
<a href="/entertainment">
Entertainment<span>*</span>
</a>
</h1>
<div class="term-sponsorship" style="width:320px; margin-left:10px;">
<div id="div-gpt-ad-sponsorship1"><script>AdBridg.cmd.push(function(){ AdBridg.display('div-gpt-ad-sponsorship1'); });</script></div>
</div>
</header>
<div class="single-wrapper">
<div id="primary" class="content-area single-article ">
<main id="main" class="site-main" role="main">
<article id="post-591033" class="post-591033 post type-post status-publish format-standard has-post-thumbnail hentry category-ad-friendly category-entertainment category-feature category-queerty tag-burn-book tag-daily-dose tag-mean-girls tag-mean-girls-day tag-screen-gems tag-weekend-binge">
<header class="entry-header">
<div class="kicker ">screen gems</div> <h1 class="entry-title"><a href="https://www.queerty.com/mean-girls-day-celebrate-fetch-way-possible-20211003"><span itemprop="headline">It&#8217;s &#8216;Mean Girls&#8217; Day! Celebrate in the most fetch way possible.</span></a></h1>
<div class="entry-meta">
<span class="byline"> By <span itemprop="author"> <a href="https://www.queerty.com/author/david-reddish" title="Posts by David Reddish" rel="author">David Reddish</a></span></span> <time class="posted-on" itemprop="datePublished" datetime="2021-10-03T10:20:45-04:00">2 hours ago</time> </div>
</header>
<div class="entry-content" itemprop="articleBody">
<figure id="attachment_591036" aria-describedby="caption-attachment-591036" style="width: 670px" class="wp-caption alignnone"><img loading="lazy" class="size-large wp-image-591036" src="https://queerty-prodweb.s3.amazonaws.com/2021/10/mean-girls-670x670.jpg" alt="" width="670" height="670" srcset="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/mean-girls-670x670.jpg?&amp;auto=format&amp;auto=compress&amp;w=670 670w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/mean-girls-670x670.jpg?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/mean-girls-670x670.jpg?&amp;auto=format&amp;auto=compress&amp;w=1400 1536w, https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/mean-girls-670x670.jpg?&amp;auto=format&amp;auto=compress&amp;w=1400 1588w" sizes="(max-width: 670px) 100vw, 670px"><figcaption id="caption-attachment-591036" class="wp-caption-text"><em>Mean Girls</em></figcaption></figure>
<p><em>Welcome to Screen Gems, our weekend dive into queer and queer-adjacent titles of the past that deserve a watch or a re-watch.</em></p>
<h2>The Holiday: Mean Girls</h2>
<p>October 3 marks the newly-minted holiday <a href="https://www.cnn.com/ampstories/entertainment/its-mean-girls-day-heres-how-to-celebrate"><em>Mean Girls</em> Day</a>, and as such, we think it’s time to celebrate.</p>
<p><a href="https://www.queerty.com/mean-girls-get-big-screen-musical-treatment-20200124"><em>Mean Girls</em></a>, of course, won great reviews and became a major hit when it debuted back in 2004. The film follows the arrival of wide-eyed innocent Cady (Lindsay Lohan) into an upper-middle-class high school, and the vicious fellow females she encounters from the outset. The Plastics, led by the uber-nasty Regina (Rachel McAdams), dominate student life with their mixture of snark, beauty and cunning manipulation. A war of sorts ensues as Cady and Regina both try to assert their personalities within the high school dynamic, with both women becoming more and more superficial and vicious as a result.</p><div class="inline-ad-holder"><div id="div-gpt-ad-inarticle1"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle1"); });</script></div></div>
<div class="inline-ad-holder">
<div id="div-gpt-ad-inarticle1"><a href="https://www.queerty.com/lindsay-lohan-returns-latest-single-doesnt-suck-20200403">Lindsay Lohan</a> may have become a household name based on the success of <em>Mean Girls</em>, though the film’s real legacy comes from its announcement of Rachel McAdams and Amanda Seyfried as up-and-coming starlets, along with Daniel Franzese and <a href="https://www.queerty.com/mean-girls-alum-jonathan-bennett-lead-hallmarks-first-gay-christmas-movie-20200923">Jonathan Bennett.</a> Both Franzese and Bennett would go on to successful acting careers, and become outspoken, out-gay advocates. Writer Tina Fey too would find herself pushed into a higher echelon of Hollywood writers, as the film developed a cult around it that has only expanded over time.</div>
</div>
<p>Witty, deep and oh so fetch, <em>Mean Girls</em> is exactly the kind of comfort food we need this weekend. To further celebrate the day, we also recommend rallying some friends to play Burn Book, the new party game based on the movie.. Burn Book, as the name implies, involves throwing a bit of shade among friends. Each player answers a question about every other player, for example, “trademark pickup line” or “first dating website screen name.” Each player then must correctly attribute the snarky answers to every other player, which brings out—shall we say—the frequent burns. It also brings about frequent laughs in our experience, which wins it a strong recommendation. Fans of <a href="https://www.queerty.com/mean-girls-retirement-home-whats-not-love-20210612"><i>Mean Girls</i></a> will revel in the bitchery, while everyone else will enjoy the mixture of creativity, wit, and cheeky jibes.</p>
<p>Enjoy both the game and the original movie this weekend. Tall glass of wine optional but encouraged.</p>
<p><em>Mean Girls streams on Paramount+, <a href="https://amzn.to/3B19l0F">Amazon</a>, YouTube &amp; VUDU.</em></p>
<p><em>Burn Book available from <a href="https://bigpotato.com/products/mean-girls">Big Potato</a> and at Target.</em></p><div class="inline-ad-holder"><div id="div-gpt-ad-inarticle2"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle2"); });</script></div></div>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe loading="lazy" title="Mean Girls (2004) Trailer #1 | Movieclips Classic Trailers" width="872" height="491" src="https://www.youtube.com/embed/oDU84nmSDZY?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p><em>Note: This article contains portions of previous articles published here on Queerty.</em></p>
</div>
<footer class="entry-footer">
<span class="tags-links"><a href="https://www.queerty.com/entertainment" rel="category">Entertainment</a> <a href="https://www.queerty.com/tag/burn-book" rel="tag">burn book</a> <a href="https://www.queerty.com/tag/daily-dose" rel="tag">daily dose</a> <a href="https://www.queerty.com/tag/mean-girls" rel="tag">mean girls</a> <a href="https://www.queerty.com/tag/mean-girls-day" rel="tag">mean girls day</a> <a href="https://www.queerty.com/tag/screen-gems" rel="tag">screen gems</a> <a href="https://www.queerty.com/tag/weekend-binge" rel="tag">weekend binge</a></span><div class="comments-link-area"><a href="https://www.queerty.com/mean-girls-day-celebrate-fetch-way-possible-20211003#respond"><span class="comments-link">Add a comment</span></a></div> </footer>
</article>
</main>
<div class="article-email-prompt-red" id="queerty-article-email-prompt">
<h3><span class="asterisk"> </span>Get Queerty Daily</h3>
Subscribe to Queerty for a daily dose of #entertainment #burnbook #dailydose stories and more
<form action="//queerty.us1.list-manage.com/subscribe/post?u=ecab442566f15d8d4dcf64b0d&amp;id=221c27272a" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank">
<input type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="Your email" autocomplete="email">
<input type="hidden" name="group[5437][16]" value="1">
<input type="hidden" value="2" name="group[5409][2]" id="mce-group[5409]-5409-0">
<input type="hidden" value="1" name="group[5409][1]" id="mce-group[5409]-5409-1">
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ecab442566f15d8d4dcf64b0d_221c27272a" tabindex="-1" value=""></div>
<input type="submit" value="Subscribe" name="submit" id="mc-embedded-subscribe" class="button">
</form>
</div>
<div style="width:90%; margin-left:auto; margin-right:auto;">
<h3 style="margin-bottom:4px;">Featured on Queerty TV</h3>
<script>
!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>
<script id="63359461e10348e1843f01215f3c4ead">
  cnxps.cmd.push(function () {
    cnxps({
      playerId: "461d6acb-cbff-447a-b4e7-ee9ee29c9631"
    }).render("63359461e10348e1843f01215f3c4ead");
  });
</script>
</div>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Add your Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/mean-girls-day-celebrate-fetch-way-possible-20211003#respond" style="display:none;">Cancel reply</a></small></h3><p class="nocomments">Please <a href="https://www.queerty.com/wp/wp-login.php?redirect_to=https%3A%2F%2Fwww.queerty.com%2Fmean-girls-day-celebrate-fetch-way-possible-20211003">log in</a> to add your comment<br>Need an account? <strong><a href="https://www.queerty.com/wp/wp-login.php?action=register">Register</a></strong> *It's free and easy.</p> </div>
</div>
</div>
<script type="text/javascript" async="async" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-58640af04b28c97d"></script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.queerty.com\/mean-girls-day-celebrate-fetch-way-possible-20211003"},"headline":"It&#8217;s &#8216;Mean Girls&#8217; Day! Celebrate in the most fetch way possible.","url":"https:\/\/www.queerty.com\/mean-girls-day-celebrate-fetch-way-possible-20211003","datePublished":"2021-10-03T10:20:45-04:00","dateModified":"2021-10-03T10:20:33-04:00","description":"October 3 marks the newly-minted holiday Mean Girls Day. It's time to celebrate.","thumbnailUrl":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/10\/mean-girls-jonathan-bennett-307x289.jpg","image":{"@type":"ImageObject","url":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2021\/10\/mean-girls-jonathan-bennett-307x289.jpg","height":670,"width":377},"creator":"David Reddish","author":{"@type":"Person","name":"David Reddish"},"articleSection":"Entertainment","keywords":["Ad Friendly","Feature","Queerty","burn book","daily dose","mean girls","mean girls day","screen gems","weekend binge","[ Has: YouTube embed ]","[ Word count: 300-600 ]"],"publisher":{"@type":"NewsMediaOrganization","name":"Queerty","url":"https:\/\/www.queerty.com\/","logo":{"@type":"ImageObject","url":"https:\/\/www.queerty.com\/assets\/q-2017\/queerty-logo-225x60.png","height":"60","width":"225"},"address":{"@type":"PostalAddress","streetAddress":"584 Castro St. #623","addressLocality":"San Francisco","addressRegion":"CA","postalCode":"94114","addressCountry":"USA"},"sameAs":["https:\/\/en.wikipedia.org\/wiki\/Queerty","https:\/\/www.facebook.com\/queerty","https:\/\/www.twitter.com\/queerty","https:\/\/www.instagram.com\/queerty","https:\/\/www.youtube.com\/user\/queertyTV"]}}</script>
<aside id="secondary" class="article-sidebar" role="complementary">
<div class="sidebar-ad-1" id="div-gpt-ad-box1">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box1'); });
			</script>
</div>
<div id="q-video-player" style="display:none;"></div>
<section class="sidebar-related">
<h3 class="category-heading">
More in Entertainment </h3>
<div class="cards-list">
<article id="post-590919" class="card card-small ">
<a href="https://www.queerty.com/need-reason-watch-football-outside-super-bowl-halftime-show-try-gay-bowl-20211003">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/Screen-Shot-2021-10-01-at-1.13.17-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Need a reason to watch football outside the Super Bowl Halftime show? Try the gay bowl.">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">pig skin</div>
<h2 class="entry-title">Need a reason to watch football outside the Super Bowl Halftime show? Try the gay bowl.</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-591038" class="card card-small ">
<a href="https://www.queerty.com/welcome-halloween-season-overlooked-gay-romance-terrifying-classic-20211002">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/the-haunting2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Welcome Halloween season with an overlooked gay romance in a terrifying classic">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">screen gems</div>
<h2 class="entry-title">Welcome Halloween season with an overlooked gay romance in a terrifying classic</h2> <div class="entry-meta">
<a href="https://www.queerty.com/welcome-halloween-season-overlooked-gay-romance-terrifying-classic-20211002" rel="bookmark"><time class="entry-date published updated" datetime="2021-10-02T10:46:38-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-591000" class="card card-small ">
<a href="https://www.queerty.com/musto-ben-platt-rosie-odonnell-patti-lupone-drag-queen-lands-just-like-20211002">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/shutterstock_1518834317-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="MUSTO: Ben Platt, Rosie O&#8217;Donnell, Patti LuPone dish, and a drag queen lands on &#8220;Just like that&#8221;!">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">READ NOW, CRY LATER</div>
<div class="card-commentcount">11 </div><h2 class="entry-title">MUSTO: Ben Platt, Rosie O&#8217;Donnell, Patti LuPone dish, and a drag queen lands on &#8220;Just like that&#8221;!</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-590953" class="card card-small ">
<a href="https://www.queerty.com/dive-queer-murder-mystery-one-worlds-great-actresses-20211001">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/prime-suspect.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Dive into a queer murder mystery with one of the world&#8217;s great actresses">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Weekend Binge</div>
<h2 class="entry-title">Dive into a queer murder mystery with one of the world&#8217;s great actresses</h2> <div class="entry-meta">
<a href="https://www.queerty.com/dive-queer-murder-mystery-one-worlds-great-actresses-20211001" rel="bookmark"><time class="entry-date published updated" datetime="2021-10-01T16:09:59-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-2" id="div-gpt-ad-box2">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box2'); });
			</script>
</div>
<br>
<section class="sidebar-related">
<h3 class="category-heading">
Popular on Queerty
</h3>
<div class="cards-list">
<article id="post-590713" class="card card-small ">
<a href="https://www.queerty.com/matt-gaetz-screwed-appears-preparing-scorched-earth-trial-20210927">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/08/matt-gaetz-podcast.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Matt Gaetz is so screwed, appears to be preparing for &#8220;scorched earth&#8221; trial">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">impending doom</div>
<div class="card-commentcount">25 comments</div><h2 class="entry-title">Matt Gaetz is so screwed, appears to be preparing for &#8220;scorched earth&#8221; trial</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-590307" class="card card-small ">
<a href="https://www.queerty.com/brief-probably-incomplete-list-lgbtq-celebrities-perez-hilton-tried-destroy-20210926">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2020/12/Perez-hilton.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="A brief, probably incomplete list of all the LGBTQ celebrities Perez Hilton tried to destroy">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">deliberate cruelty</div>
<div class="card-commentcount">34 </div><h2 class="entry-title">A brief, probably incomplete list of all the LGBTQ celebrities Perez Hilton tried to destroy</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-590675" class="card card-small ">
<a href="https://www.queerty.com/anti-gay-pastor-says-ok-hit-kids-god-put-cushioned-butt-20210927">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/pastor_roger_jimenez_verity_spanking_youtube.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Anti-gay pastor says it’s OK to hit kids as God put a “cushioned” butt on them">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">hanky spanky</div>
<div class="card-commentcount">23 comments</div><h2 class="entry-title">Anti-gay pastor says it’s OK to hit kids as God put a “cushioned” butt on them</h2> <div class="entry-meta">
<a href="https://www.queerty.com/anti-gay-pastor-says-ok-hit-kids-god-put-cushioned-butt-20210927" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-27T09:50:07-04:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-590719" class="card card-small ">
<a href="https://www.queerty.com/rosie-odonnell-says-theres-one-person-particular-can-blamed-donald-trump-20210927">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/03/Rosie-Shutterstock-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Rosie O&#8217;Donnell says there&#8217;s one person in particular who can be blamed for Donald Trump">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">in quotes</div>
<div class="card-commentcount">77 comments</div><h2 class="entry-title">Rosie O&#8217;Donnell says there&#8217;s one person in particular who can be blamed for Donald Trump</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-590695" class="card card-small ">
<a href="https://www.queerty.com/taron-egerton-jonathan-bailey-serious-cck-20210927">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/taron-egerton-jonathan-bailey.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Taron Egerton and Jonathan Bailey are about to do some serious &#8216;C*ck&#8217;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">west end boys</div>
<div class="card-commentcount">17 comments</div><h2 class="entry-title">Taron Egerton and Jonathan Bailey are about to do some serious &#8216;C*ck&#8217;</h2> <div class="entry-meta">
<a href="https://www.queerty.com/taron-egerton-jonathan-bailey-serious-cck-20210927" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-27T12:31:49-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-3" id="div-gpt-ad-box3">
<script>
		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box3'); });
		</script>
</div>
</aside>
<br clear=all>
<div class="single-bottom-articles">
<h3>
Latest on Queerty </h3>
<div class="single-bottom-articles-slider slider slick-slider">
<div><article id="post-591121" class="card card-small ">
<a href="https://www.queerty.com/edible-trixie-mattel-coming-grandma-suburban-driveway-drag-queen-20211003">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/Jake-Hill-sniffies-Grandma-Steven-tiktok.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="An edible Trixie Mattel, coming out to grandma, &#038; a suburban driveway drag queen">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">tiktalk</div>
<h2 class="entry-title">An edible Trixie Mattel, coming out to grandma, &#038; a suburban driveway drag queen</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-590919" class="card card-small ">
<a href="https://www.queerty.com/need-reason-watch-football-outside-super-bowl-halftime-show-try-gay-bowl-20211003">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/Screen-Shot-2021-10-01-at-1.13.17-PM.png?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Need a reason to watch football outside the Super Bowl Halftime show? Try the gay bowl.">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">pig skin</div>
<h2 class="entry-title">Need a reason to watch football outside the Super Bowl Halftime show? Try the gay bowl.</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-591038" class="card card-small ">
<a href="https://www.queerty.com/welcome-halloween-season-overlooked-gay-romance-terrifying-classic-20211002">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/the-haunting2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Welcome Halloween season with an overlooked gay romance in a terrifying classic">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">screen gems</div>
<h2 class="entry-title">Welcome Halloween season with an overlooked gay romance in a terrifying classic</h2> <div class="entry-meta">
<a href="https://www.queerty.com/welcome-halloween-season-overlooked-gay-romance-terrifying-classic-20211002" rel="bookmark"><time class="entry-date published updated" datetime="2021-10-02T10:46:38-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-591081" class="card card-small ">
<a href="https://www.queerty.com/eliad-cohens-swing-matthew-camps-ropes-malumas-bubble-bath-20211002">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/Elliott-Norris-taylor-bennett-brian-jordan-alvarez-xavier-Prather-instastuds.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Eliad Cohen&#8217;s swing, Matthew Camp&#8217;s ropes, &#038; Maluma&#8217;s bubble bath">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">INSTASTUDS</div>
<h2 class="entry-title">Eliad Cohen&#8217;s swing, Matthew Camp&#8217;s ropes, &#038; Maluma&#8217;s bubble bath</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-590753" class="card card-small ">
<a href="https://www.queerty.com/watch-woman-punches-anti-gay-protester-face-irish-pride-parade-20211002">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/shutterstock_429351967-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="WATCH: Woman punches anti-gay protester in the face at Irish Pride parade">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">schadenfreude</div>
<h2 class="entry-title">WATCH: Woman punches anti-gay protester in the face at Irish Pride parade</h2> <div class="entry-meta">
<a href="https://www.queerty.com/watch-woman-punches-anti-gay-protester-face-irish-pride-parade-20211002" rel="bookmark"><time class="entry-date published updated" datetime="2021-10-02T10:00:10-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-590854" class="card card-small ">
<a href="https://www.queerty.com/homophobic-minister-arrested-molesting-boy-bus-stop-20211002">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/michael-coghill-mug-.1632429158487-2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Homophobic minister arrested for molesting boy at bus stop">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">oh lord</div>
<div class="card-commentcount">16 comments</div><h2 class="entry-title">Homophobic minister arrested for molesting boy at bus stop</h2> <div class="entry-meta">
<a href="https://www.queerty.com/homophobic-minister-arrested-molesting-boy-bus-stop-20211002" rel="bookmark"><time class="entry-date published updated" datetime="2021-10-02T09:30:38-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-591019" class="card card-small ">
<a href="https://www.queerty.com/fiance-homophobe-kids-20211002">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/shutterstock_1554532169-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Her fiancé is a homophobe. What should she do about their kids?">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">dear abby</div>
<h2 class="entry-title">Her fiancé is a homophobe. What should she do about their kids?</h2> <div class="entry-meta">
<a href="https://www.queerty.com/fiance-homophobe-kids-20211002" rel="bookmark"><time class="entry-date published updated" datetime="2021-10-02T09:00:32-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-591000" class="card card-small ">
<a href="https://www.queerty.com/musto-ben-platt-rosie-odonnell-patti-lupone-drag-queen-lands-just-like-20211002">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/shutterstock_1518834317-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="MUSTO: Ben Platt, Rosie O&#8217;Donnell, Patti LuPone dish, and a drag queen lands on &#8220;Just like that&#8221;!">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">READ NOW, CRY LATER</div>
<div class="card-commentcount">11 </div><h2 class="entry-title">MUSTO: Ben Platt, Rosie O&#8217;Donnell, Patti LuPone dish, and a drag queen lands on &#8220;Just like that&#8221;!</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-590953" class="card card-small ">
<a href="https://www.queerty.com/dive-queer-murder-mystery-one-worlds-great-actresses-20211001">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/09/prime-suspect.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Dive into a queer murder mystery with one of the world&#8217;s great actresses">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Weekend Binge</div>
<h2 class="entry-title">Dive into a queer murder mystery with one of the world&#8217;s great actresses</h2> <div class="entry-meta">
<a href="https://www.queerty.com/dive-queer-murder-mystery-one-worlds-great-actresses-20211001" rel="bookmark"><time class="entry-date published updated" datetime="2021-10-01T16:09:59-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-591028" class="card card-small ">
<a href="https://www.queerty.com/horrendous-news-trumps-failing-d-c-hotel-20211001">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/02/shutterstock_577577467.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="More horrendous news for Trump&#8217;s failing D.C. hotel">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">no man's land</div>
<div class="card-commentcount">23 comments</div><h2 class="entry-title">More horrendous news for Trump&#8217;s failing D.C. hotel</h2> <div class="entry-meta">
<a href="https://www.queerty.com/horrendous-news-trumps-failing-d-c-hotel-20211001" rel="bookmark"><time class="entry-date published updated" datetime="2021-10-01T14:30:35-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-591031" class="card card-small gaycities-link">
<a target="_blank" href="https://www.gaycities.com/outthere/55445/photos-best-nsfw-looks-years-folsom-street-fair/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=PHOTOS%3A+Best+NSFW+looks+from+this+year%E2%80%99s+Folsom+Street+Fair">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/213A3580-1.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="PHOTOS: Best NSFW looks from this year’s Folsom Street Fair">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">wanderlust</div>
<h2 class="entry-title">PHOTOS: Best NSFW looks from this year’s Folsom Street Fair</h2> <div class="entry-meta">
<a href="https://www.queerty.com/photos-best-nsfw-looks-years-folsom-street-fair-20211001" rel="bookmark"><time class="entry-date published updated" datetime="2021-10-01T13:51:30-04:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-591006" class="card card-small gaycities-link">
<a target="_blank" href="https://www.gaycities.com/outthere/55498/billboards-telling-lgbtq-youth-loved-springing-us-cities/?utm_source=queerty&#038;utm_medium=directlink&#038;utm_campaign=directlink&#038;utm_content=Why+are+billboards+telling+LGBTQ+youth+they+are+loved+springing+up+in+US+cities%3F">
<section class="card-thumb">
<img src="https://adabgmwwup.cloudimg.io/v7/_queerty-prodweb_/2021/10/rae_Senarighi_transpainter_helena_north_carolina.jpg?&auto=format&auto=compress&crop=faces&fit=crop&gravity=face&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Why are billboards telling LGBTQ youth they are loved springing up in US cities?">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">wanderlust</div>
<h2 class="entry-title">Why are billboards telling LGBTQ youth they are loved springing up in US cities?</h2> <div class="entry-meta">
<a href="https://www.queerty.com/billboards-telling-lgbtq-youth-loved-springing-us-cities-20211001" rel="bookmark"><time class="entry-date published updated" datetime="2021-10-01T13:20:49-04:00"></time></a> </div>
</section>
</a>
</article>
</div>
</div>
</div></div>
</div>
<div class="site-footer-holder">
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="footer-brand">
<span class="asterisk"> </span> Free of an agenda (except that gay one)
</div>
<div class="tags-links">
<a href="//www.queerty.com/tag/andy-cohen">Andy Cohen</a> <a href="//www.queerty.com/tag/bowen-yang">Bowen Yang</a> <a href="//www.queerty.com/tag/colton-underwood">Colton Underwood</a> <a href="//www.queerty.com/tag/conrad-rocha">Conrad Rocha</a> <a href="//www.queerty.com/tag/gus-kenworthy">Gus Kenworthy</a> <a href="//www.queerty.com/tag/janet-mock">Janet Mock</a> <a href="//www.queerty.com/tag/lil-nas-x">Lil Nas X</a> <a href="//www.queerty.com/tag/ricky-martin">Ricky Martin</a> <a href="//www.queerty.com/tag/russell-tovey">Russell Tovey</a> <a href="//www.queerty.com/tag/ryan-murphy">Ryan Murphy</a> <div class="second-row">
<a href="//www.queerty.com/tag/homophobia">Homophobia</a> <a href="//www.queerty.com/tag/racism">Racism</a> <a href="//www.queerty.com/tag/rupaul's-drag-race">Rupaul's Drag Race</a> <a href="//www.queerty.com/tag/matt-gaetz">Matt Gaetz</a> <a href="//www.queerty.com/tag/transphobia">Transphobia</a> <a href="//www.queerty.com/tag/relationships">Relationships</a> <a href="//www.queerty.com/tag/grindr">Grindr</a>
</div>
</div>
<div class="footer-links">
<ul class="main" id="footer-company-links">
<li><a href="http://www.q.digital"><img src="/assets/q-digital-blue-90x37.png" alt="Q.digital" width="90"></a></li>
<li><b>A Q.Digital Company</b></li>
<li>&copy; 2021 Queerty, Inc.</li>
<li><a href="http://www.q.digital">Advertise With Us</a></li>
</ul>
<ul class="main" id="footer-contact-links">
<li><h3>Contact</h3></li>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
<li><a href="https://www.queerty.com/queertys-comment-policy">Comments Policy</a>
<li><a href="https://www.queerty.com/privacy-policy">Privacy Statement</a>
<li><a href="https://www.queerty.com/terms-of-use">Terms of Use</a>
<li><a id="ccpaOptOut">Do Not Sell My Personal Information</a>
</ul>
<ul class="main" id="footer-follow-links">
<li><h3>Follow</h3></li>
<li><a href="https://www.facebook.com/Queerty/">Facebook</a></li>
<li><a href="https://www.twitter.com/Queerty/">Twitter</a></li>
<li><a href="https://www.instagram.com/Queerty/">Instagram</a></li>
<li><a href="https://www.youtube.com/user/QueertyTV/">YouTube</a></li>
</ul>
<ul class="main double" id="footer-gaycities-links">
<li><h3>GayCities: Your Gay Travel Guide:</h3></li>
<li><a href="https://newyork.gaycities.com/">New York</a></li>
<li><a href="https://london.gaycities.com/">London</a></li>
<li><a href="https://sanfrancisco.gaycities.com/">San Francisco</a></li>
<li><a href="https://chicago.gaycities.com/">Chicago</a></li>
<li><a href="https://losangeles.gaycities.com/">Los Angeles</a></li>
<li><a href="https://washingtondc.gaycities.com/">Washington DC</a></li>
<li><a href="https://dallas.gaycities.com/">Dallas</a></li>
<li><a href="https://saskatoon.gaycities.com/">Gay Saskatoon</a></li>
<li><a href="https://www.gaycities.com/places/"><b>See all 230+ cities...</b></a></li>
</ul>
</div>
</footer>
</div>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "32666898" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=32666898&cv=2.0&cj=1" alt="Comscore Measurement" />
</noscript>

<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '686853021424163');
  fbq('track', 'PageView');
</script>
<noscript><img height='1' width='1' style='display:none'
  src='https://www.facebook.com/tr?id=686853021424163&ev=PageView&noscript=1'
/></noscript>

<script>
  fbq('track', 'ViewContent');
</script>
<script>
	window.dataLayer = window.dataLayer || []
	dataLayer.push({
	   'event': 'Page Details',
	   'pageType': 'article',
	   'pageCategory': 'entertainment'
	   
	});
	</script>
<script type="text/javascript">var algolia = {"debug":false,"application_id":"6S92GABH7H","search_api_key":"cfd5e12cdf4a6106712391cbcf54f087","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"queerty_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"queerty_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]}}};</script><script type='text/javascript' src='https://q-digital.videoplayerhub.com/galleryplayer.js?ver=20201101' id='bt-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/comment-reply.min.js?ver=5.8.1' id='comment-reply-js'></script>
<script type='text/javascript' async src='https://platform.twitter.com/widgets.js?ver=20161216' id='twitter-js-js'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js?ver=5.8.1' id='slick-js'></script>
<script type='text/javascript' async src='https://www.queerty.com/content/themes/queerty_2017/js/min/queerty-nosticky-min.js?ver=20210712a' id='queerty_2017-main-js'></script>
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/wp-embed.min.js?ver=5.8.1' id='wp-embed-js'></script>
<script data-cfasync="false" id="parsely-cfg" data-parsely-site="queerty.com" src="https://cdn.parsely.com/keys/queerty.com/p.js"></script>
</body>
</html>