<!DOCTYPE html>
<html>
<head>
<link rel="stylesheet" href="https://use.typekit.net/cdb4vyt.css">
<meta name="viewport" content="width=device-width, initial-scale=1">

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
</script>

<script type='text/javascript'>
  var AdBridg = AdBridg || {};
  AdBridg.cmd = AdBridg.cmd || [];
  (function() {
      var adb = document.createElement("script");
      adb.async = true;
      adb.type = "text/javascript";
      adb.src = '//prod.adspsp.com/adb.2634970.min.js?cachebuster=1';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(adb, node);

      // Return control to GPT if the AdBridg library fails to load.
      adb.onerror = function() {
        console.log('Fallback: ')
        if (AdBridg.exists) { return; }
        document.createElement('IMG').src = '//adspsp.com/pt/2634970/3/1/?e=0';
        var dq = [], es;
        dq.process = function() { while(dq.length) { googletag.display(dq.shift()); }}
        AdBridg.defineSlot = function(p, s, d) { return googletag.defineSlot(p, s, d).addService(googletag.pubads()); }
        AdBridg.defineOutOfPageSlot = function(p, d) { return googletag.defineOutOfPageSlot(p, d).addService(googletag.pubads()); }
        AdBridg.destroySlots = function(s) { return googletag.destroySlots(s); }
        AdBridg.display = function(d) { dq.push(d); if (es) { dq.process(); }}
        AdBridg.refresh = function(s, o) { googletag.pubads().refresh(s, o); }
        AdBridg.render = function() { }
        AdBridg.serve = function() { googletag.enableServices(); es=1; dq.process(); }
        AdBridg.sizeMapping = function() { return googletag.sizeMapping(); }
        AdBridg.useSizeMapping = function() { }
        AdBridg.cmd.push = function(f) {
          if (typeof(f)=='object') {
            var api_fallback = function(o) {
              googletag.cmd.push(function() {
                var u=AdBridg.defineSlot(o.gpt_path,o.size||[],o.dom_id);
                if(o.size_map) {
                  var m = googletag.sizeMapping();
                  for(var oi=0;oi<o.size_map.length;oi++){m=m.addSize(o.size_map[oi].viewport, o.size_map[oi].sizes);}
                  u.defineSizeMapping(m.build());
                }
                if(o.events) {
                  if(o.events["gpt.defined"]){o.events["gpt.defined"](u);}
                  var fl = function(a,b){if(o.events[a]){googletag.pubads().addEventListener(b,function(e){if(e.slot===u){o.events[a](u,e)}})}}
                  fl("gpt.rendered",'slotRenderEnded');
                  fl("gpt.viewed",'impressionViewable');
                  fl("gpt.visibilityChanged",'slotVisibilityChanged');
                }
              });
            }
            if(f.length){for(var i=0;i<f.length;++i){api_fallback(f[i]);}}else{api_fallback(f);}
            f=function(){AdBridg.serve()}
          }
          return googletag.cmd.push(f);
        }
        while (AdBridg.cmd.length) { AdBridg.cmd.push(AdBridg.cmd.shift()); }
      }
  })();
</script>
<script>
AdBridg.cmd.push(function () {
	googletag.pubads().collapseEmptyDivs();
	googletag.pubads().setTargeting('articleid', ['571666']);
	googletag.pubads().setTargeting('Tag', ['articlepage','culture club','dashing in december','funny boy','imma bea','queer japan','the christmas setup','the prom','ad friendly','entertainment','feature','queerty']);
	googletag.pubads().setTargeting('UGC', ['no']);
	
  });
</script>
<script>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</script><title>What to Watch: Big queer &#8216;Prom,&#8217; gay boys get &#8216;Christmas Setup,&#8217; &#8216;Brokeback&#8217; style / Queerty</title>
<link rel='dns-prefetch' href='//platform.twitter.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//q-digital.videoplayerhub.com' />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Feed" href="https://www.queerty.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; Comments Feed" href="https://www.queerty.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Queerty &raquo; What to Watch: Big queer &#8216;Prom,&#8217; gay boys get &#8216;Christmas Setup,&#8217; &#8216;Brokeback&#8217; style Comments Feed" href="https://www.queerty.com/watch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210/feed" />
<link rel='stylesheet' id='queerty_2017-style-css' href='https://www.queerty.com/content/themes/queerty_2017/style.css?ver=20201009b' type='text/css' media='all' />
<script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<link rel='prev' title='US Marshalls apprehend fugitive gay basher in Texas' href='https://www.queerty.com/us-marshalls-apprehend-fugitive-gay-basher-texas-20201210' />
<link rel="canonical" href="https://www.queerty.com/watch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210" />
<meta property="og:site_name" content="Queerty" /> <meta name="description" content="So many handsome sugar plum fairies this week..." />
<meta property="og:description" content="So many handsome sugar plum fairies this week...">
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.queerty.com/watch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210" />
<meta property="og:title" content="What to Watch: Big queer &#8216;Prom,&#8217; gay boys get &#8216;Christmas Setup,&#8217; &#8216;Brokeback&#8217; style" />
<meta property="og:image" content="https://queerty-prodweb.imgix.net/2020/12/dashing-in-december.png?&auto=format&auto=compress&crop=faces&fit=crop&w=1024&h=576" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta name="twitter:image" content="https://queerty-prodweb.imgix.net/2020/12/dashing-in-december.png?&auto=format&auto=compress&crop=faces&fit=crop&w=1024&h=576" />
<meta property="article:published_time" content="2020-12-10T12:13:29-05:00" />
<meta property="article:modified_time" content="2020-12-10T12:13:29-05:00" />
<meta name="twitter:url" content="https://www.queerty.com/watch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210" />
<meta name="twitter:title" content="What to Watch: Big queer &#8216;Prom,&#8217; gay boys get &#8216;Christmas Setup,&#8217; &#8216;Brokeback&#8217; style" />
<meta name="twitter:description" content="So many handsome sugar plum fairies this week..." />
<meta name="news_keywords" content="culture club, Dashing In December, funny boy, imma bea, queer Japan, the christmas setup, the prom"><meta property="article:tags" content="culture club, Dashing In December, funny boy, imma bea, queer Japan, the christmas setup, the prom"><meta name="author" property="author" content="David Reddish" />

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@Queerty" />
<meta name="twitter:url" content="https://www.queerty.com/watch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210" />
<meta name="twitter:title" content="What to Watch: Big queer &#8216;Prom,&#8217; gay boys get &#8216;Christmas Setup,&#8217; &#8216;Brokeback&#8217; style" />
<meta name="twitter:description" content="So many handsome sugar plum fairies this week &hellip;" />
<meta name="twitter:image" content="https://queerty-prodweb.s3.amazonaws.com/2020/12/dashing-in-december.png"><meta name="twitter:image:alt" content="">

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-KRQPBJR');</script>

<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.queerty.com/wp");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '2269d7e8-77de-42f4-85e0-e16c905e72b8';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Queerty";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing!";
oneSignal_options['welcomeNotification']['url'] = "https://www.queerty.com/";
oneSignal_options['path'] = "https://www.queerty.com/content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.32a023df-3e37-4c19-843f-3978a63a946e";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = 'Queerty';
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = 'Titles of Breaking Stories Will Appear Here';
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = 'Queerty';
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
<link rel="amphtml" href="https://www.queerty.com/watch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210/amp"> <link rel="preconnect" href="https://queerty-assets.s3.amazonaws.com">
<link rel="preload" href="https://www.googletagservices.com/tag/js/gpt.js">
<link rel="preconnect" href="https://www.googletagmanager.com">
<link rel="preconnect" href="https://queerty-prodweb.imgix.net">
<meta property="fb:app_id" content="153299894806318" />
<meta name="theme-color" content="#f43700" />
<meta name="apple-itunes-app" content="app-id=1046987164">
<meta property="fb:pages" content="33720334139" />
<meta name="apple-mobile-web-app-title" content="Queerty*">
<meta name="application-name" content="Queerty*">
<meta name="msapplication-config" content="/assets/q-2017/favicons/browserconfig.xml?v=lkgzj5W5Gl">
<link rel="apple-touch-icon" sizes="180x180" href="/assets/q-2017/favicons/apple-touch-icon.png?v=lkgzj5W5Gl">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-32x32.png?v=lkgzj5W5Gl" sizes="32x32">
<link rel="icon" type="image/png" href="/assets/q-2017/favicons/favicon-16x16.png?v=lkgzj5W5Gl" sizes="16x16">
<link rel="manifest" href="/assets/q-2017/favicons/manifest.json?v=20180829">
<link rel="mask-icon" href="/assets/q-2017/favicons/safari-pinned-tab.svg?v=lkgzj5W5Gl" color="#5bbad5">
<link rel="shortcut icon" href="/assets/q-2017/favicons/favicon.ico?v=lkgzj5W5Gl">
<meta property="article:publisher" content="https://www.facebook.com/queerty" />
<style>
.ad-leaderboard-header {
	background-color:transparent !important;
	position:relative;
	margin-top:10px;
}
.queerty-header {
	padding-top:10px !important;
}
@media screen and (max-height: 769px) {
	.queerty-header {
    	min-height: 4.688rem;
    	padding: 10px 0 10px !important;
	}
}
</style>
<script async src="https://powerad.ai/script.js"></script>
</head>
<body class="post-template-default single single-post postid-571666 single-format-standard category-ad-friendly category-entertainment category-feature category-queerty">
<div id="top-of-page" style="display:none;"></div>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KRQPBJR"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id="page" class="site">
<div class="ad-leaderboard-header" id="div-gpt-ad-leader1">
<script>
				AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-leader1'); });
				</script>
</div>

<div id="is-phone"></div>

<header id="masthead" class="queerty-header">
<div class="queerty-header-wrapper">
<nav id="site-navigation" class="main-navigation" role="navigation">
<ul id="js-header-main-menu" class="queerty-header-menu show">
<li class="nav-link "><a href="/">Latest</a>
</li>
<li class="nav-link navcat-life "><a class="scroll-on-page-link" data-scroll="category-life" href="https://www.queerty.com/life">Life</a></li>
<li class="nav-link navcat-entertainment selected"><a class="scroll-on-page-link" data-scroll="category-entertainment" href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li class="nav-link navcat-politics "><a class="scroll-on-page-link" data-scroll="category-politics" href="https://www.queerty.com/politics">Politics</a></li>
<li class="nav-link navcat-out-for-good "><a href="/out-for-good">Out for Good</a></li>
</ul>
</nav>
<div class="logo-area">
<a href="/" class="queerty-logo">
<img src="/assets/q-2017/queerty-logo.svg" width="275" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo">
<img src="/assets/promos/pride/2019/queerty-pride.svg" width="275" alt="Queerty* Pride" class="queerty-header-pride-logo" style="display:none;">
</a>
</div>
<nav id="right-navigation" class="secondary-navigation" role="navigation">
<ul id="js-header-secondary-menu" class="queerty-header-menu show">
<li class="nav-link">
<a href="https://www.facebook.com/Queerty/"><img src="/assets/icons/facebook-f-icon.svg" height="19" aria-hidden="true" alt="Facebook"></a>
</li>
<li class="nav-link">
<a href="https://twitter.com/queerty"><img src="/assets/icons/twitter-icon.svg" height="19" aria-hidden="true" alt="Twitter"></a>
</li>
<li class="nav-link">
<a href="https://www.instagram.com/queerty/"><img src="/assets/icons/instagram-icon.svg" height="19" aria-hidden="true" alt="Instagram"></a>
</li>
<li class="nav-link">
<a href="https://eepurl.com/RrfMf"><img src="/assets/icons/envelope-regular.svg" height="19" aria-hidden="true" alt="newsletter"></a>
</li>
<li class="nav-link queerty-menu-button" id="more-menu">
<img src="/assets/icons/bars-solid.svg" height="19" aria-hidden="true" title="Open Menu" alt="Menu">
</li>
</ul>
</nav>
</div>
</header>
<nav class="queerty-menu-content">
<div class="queerty-menu-close"><img src="/assets/icons/times-solid.svg" height="19" aria-hidden="true" title="Close Menu" alt="Close"></i></div>
<div class="queerty-menu-logo"><img src="/assets/q-2017/queerty-logo.svg" width="100" alt="Queerty*" id="queerty-logo-img" class="queerty-header-logo"></div>
<div class="queerty-menu-searchbox">
<form role="search" method="get" class="search-form" action="https://www.queerty.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
<ul>
<li><a href="https://www.queerty.com/wp/wp-login.php?redirect_to=%2F%2Fwww.queerty.com%2Fwatch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210" id="menu-login">Log in</a></li>
<li><a href="https://www.queerty.com/wp/wp-login.php?action=register" id="menu-register">Register</a></li>
</ul>
<div class="menu-now-on-queerty-container"><ul id="menu-now-on-queerty" class="menu"><li id="menu-item-441445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441445"><a href="https://www.queerty.com/life">Life</a></li>
<li id="menu-item-441443" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-441443"><a href="https://www.queerty.com/entertainment">Entertainment</a></li>
<li id="menu-item-441446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441446"><a href="https://www.queerty.com/politics">Politics</a></li>
<li id="menu-item-441444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441444"><a href="https://www.queerty.com/goods">Goods</a></li>
<li id="menu-item-555321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-555321"><a href="https://www.queerty.com/pride">Pride</a></li>
<li id="menu-item-504333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-504333"><a href="https://www.queerty.com/ever-after">Queerty Ever After</a></li>
<li id="menu-item-420166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-420166"><a href="https://www.queerty.com/dragaholic">Dragaholic</a></li>
<li id="menu-item-469065" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-469065"><a href="https://www.queerty.com/prepared">Prepared</a></li>
<li id="menu-item-420168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-420168"><a href="//www.queerty.com/queerty-tv/">Video (Queerty TV)</a></li>
</ul></div>
<ul>
<li><a href="https://www.lgbtqnation.com/">LGBTQ Nation News</a></li>
<li><a href="https://www.gaycities.com/">GayCities Travel Guides</a></li>
</ul>
<ul>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
</ul>
</nav>
<div class="queerty-menu-fade-screen"></div>
<div id="content" class="site-content"> <div class="single-wrapper">
<div id="primary" class="content-area single-article ">
<main id="main" class="site-main" role="main">
<article id="post-571666" class="post-571666 post type-post status-publish format-standard has-post-thumbnail hentry category-ad-friendly category-entertainment category-feature category-queerty tag-culture-club tag-dashing-in-december tag-funny-boy tag-imma-bea tag-queer-japan tag-the-christmas-setup tag-the-prom">
<header class="entry-header">
<div class="kicker ">Culture Club</div> <h1 class="entry-title"><a href="https://www.queerty.com/watch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210"><span itemprop="headline">What to Watch: Big queer &#8216;Prom,&#8217; gay boys get &#8216;Christmas Setup,&#8217; &#8216;Brokeback&#8217; style</span></a></h1>
<div class="entry-meta">
<span class="byline"> By <span itemprop="author"> <a href="https://www.queerty.com/author/david-reddish" title="Posts by David Reddish" rel="author">David Reddish</a></span></span> <time class="posted-on" itemprop="datePublished" datetime="2020-12-10T12:13:29-05:00">19 minutes ago</time> </div>
</header>
<div class="entry-content" itemprop="articleBody">

<div id="div-gpt-ad-textpromo1">
<script type='text/javascript'>
                    		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-textpromo1'); });
                    		</script>
</div>
<figure id="attachment_568474" aria-describedby="caption-attachment-568474" style="width: 670px" class="wp-caption alignnone"><img loading="lazy" class="size-large wp-image-568474" src="https://queerty-prodweb.s3.amazonaws.com/2020/10/TP-05300RC-1-670x447.jpg" alt="" width="670" height="447" srcset="https://queerty-prodweb.imgix.net/2020/10/TP-05300RC-1-670x447.jpg?&amp;auto=format&amp;auto=compress&amp;w=670 670w, https://queerty-prodweb.imgix.net/2020/10/TP-05300RC-1-670x447.jpg?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://queerty-prodweb.imgix.net/2020/10/TP-05300RC-1-670x447.jpg?&amp;auto=format&amp;auto=compress&amp;w=1536 1536w, https://queerty-prodweb.imgix.net/2020/10/TP-05300RC-1-670x447.jpg?&amp;auto=format&amp;auto=compress&amp;w=2048 2048w" sizes="(max-width: 670px) 100vw, 670px"><figcaption id="caption-attachment-568474" class="wp-caption-text"><em>THE PROM (L to R) MERYL STREEP as DEE DEE ALLEN, JAMES CORDEN as BARRY GLICKMAN in THE PROM. Cr. MELINDA SUE GORDON/<a href="https://www.queerty.com/tag/netflix">NETFLIX</a> © 2020</em></figcaption></figure>
<p><em>Whatever your entertainment needs, we got your back (and hopefully your mind) with Queerty’s weekly “Culture Club” column with some of the highlights of new releases, streaming shows, classics worth revisiting, and what to drink while you watch.</em></p>
<h2>The Event: The Prom</h2>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="The Prom | Official Trailer | Netflix" width="872" height="491" src="https://www.youtube.com/embed/TJ0jBNa6JUQ?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>At last, <a href="https://www.queerty.com/watch-netflix-releases-full-trailer-ryan-murphys-gay-themed-prom-20201127">Ryan Murphy’s adaptation of the popular Broadway musical</a> arrives on Netflix this week, albeit with an unfortunate onus. As with the stage version, <i>The Prom</i> follows a lesbian high schooler in Indiana whose banning from her senior prom becomes a cause celebre for a set of out of work Broadway stars hoping to make a comeback. A handful of noisy critics have accused the film of homophobia for the casting of <a href="https://www.queerty.com/james-corden-says-hed-explain-gay-relationships-kids-beautiful-20180301">James Corden</a> as an effeminate gay man. Having seen the film, we can assert, we didn’t find Corden’s work offensive. In fact, he plays his character with sincerity and complexity, enough so we found his performance quite moving. Detractors seem to want to attack Corden for the way the character is written (criticism the role generated on Broadway as well), or to push their own agenda. Corden does what Murphy and the role ask of him.</p>
<p>That out of the way, <i>The Prom, </i>at its best, features uplifting songs and stirring moments. <a href="https://www.queerty.com/andrew-rannells-test-tell-good-gay-character-bad-one-heres-20201209">Andrew Rannells</a> and Meryl Streep deliver their usual, spirited work, though the real standout is Keegan-Michael Key who gives a full-blown romantic leading man performance. Likewise, newcomer Jo Ellen Pellman and Corden tug the heartstrings with their sincerity. At its worst, <i>The Prom</i> plays like a manic episode of <i>Glee</i>, with its camera spinning around teen acrobats lit by oversaturated colored lights. The film also underuses the talents of Kerry Washington, Tracy Ullman and Nicole Kidman, though the latter <em>does</em> get a showstopping song. Viewers who can get on board with Murphy’s approach will have a great time, and even the most jaded in the audience should enjoy the film for its strengths.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle1"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle1"); });</script></div>
<p><em>Streams on Netflix December 11.</em></p>
<h2>The Awards Contender: Funny Boy</h2>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="Funny Boy Trailer #1 (2020) | Movieclips Indie" width="872" height="491" src="https://www.youtube.com/embed/oQOlnuJxU4Y?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>This Canadian-Sri Lankan film has already generated early Oscar buzz. Based on the novel by Shyam Selvadurai, the film follows Arjie, a young gay boy growing up in Sri Lanka during the 70s and 80s. At the time, a racial conflict between the native Sinhalese and wealthy Tamils had begun to bubble. Amid Arjie’s own period of self-discovery, he and his family find themselves pulled into growing violence that threatens to spark a civil war. Oscar-winning director Deepa Meetha captures the lush beauty and colors of <a href="https://www.queerty.com/sri-lanka-police-anally-torture-men-suspected-gay-sex-20201020">Sri Lanka</a> with her camera, and gets moving performances out of her actors, particularly Arush Nand who plays Arjie as a child. <i>Funny Boy</i> has generated backlash from Tamil people in Sri Lanka for a dearth of Tamil actors in the film; Meetha defends it by noting that she had original cast Tamil performers, all of whom dropped out because of the film’s queer subject matter or visa restrictions. In any case, we found Meetha’s treatment of the Tamil characters respectful, and the movie’s handling of its queer themes frank and honest. For that reason, we recommend viewers give the film a watch and decide for themselves.</p>
<p><em>Streams on Netflix December 10.</em></p>
<h2>The Spotlight: Queer Japan</h2>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="Queer Japan - U.S. Trailer" width="872" height="491" src="https://www.youtube.com/embed/utB6igqVJPQ?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>We recommended this film on <a href="https://www.queerty.com/outfest-2019-teen-cam-romances-brazilian-leather-men-psychic-dominatrix-trans-athletes-20190715">the festival circuit last year</a>. This week it arrives on streaming services, offering up its expose’ of Japan’s beautiful and eccentric queer culture. <i>Queer Japan</i> focuses on a group of LGBTQ Japanese artists and their efforts to gain acceptance in the very traditional Japanese society. As with underground queer culture in the US, their work pushes the boundaries of good taste with hypersexualized and downright outrageous content. Maybe that’s why we found the characters in the film—which include a transgender politician, an erotic manga artist, and a drag queen—so endearing. Even if the folks profiled in the movie don’t find mainstream acceptance in Japan, they may well find it stateside. With <a href="https://www.queerty.com/tag/coronavirus">COVID-19</a> continuing to prevent travel, we suggest giving the film a <a href="https://www.queerty.com/enjoy-taste-queer-japan-comfort-home-20201205">look as a kind of virtual vacation</a>.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle2"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle2"); });</script></div>
<p><em>Streams on Amazon December 11.</em></p>
<h2>The Adorable: The Christmas Setup</h2>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="The Christmas Setup Trailer" width="872" height="491" src="https://www.youtube.com/embed/9vAxvFMAMMI?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>The Lifetime holiday movie—the first-ever to feature a queer-themed love story at its center—arrives this week. <a href="https://www.queerty.com/watch-lifetime-drops-trailer-gay-themed-christmas-setup-love-20201123">Real-life husbands Ben Lewis and Blake Lee</a> play Hugo and Patrick, respectively, two gay professionals who once attended the same high school in suburban Milwaukee. Hugo has made his way to New York as a powerful lawyer, while Patrick has stuck around town working at his family’s landscaping business. When the pair reconnect, sparks fly. But can Hugo sacrifice his New York job for love?</p>
<p>If the plot sounds familiar, that should come as no surprise—<a href="https://www.queerty.com/mean-girls-alum-jonathan-bennett-lead-hallmarks-first-gay-christmas-movie-20200923">these kinds of holiday films on Lifetime or the Hallmark Channel</a> often follow the same formula. In this case, that’s not a bad thing. <i>The Christmas Setup</i> is a fairytale romance for the LGBTQ community, one whose sweetness managed to melt even our cynical heart. The picturesque winterscapes provide a beautiful backdrop, and <a href="https://www.queerty.com/fran-drescher-indebted-spills-comedy-stay-resilient-tragic-times-20200319">Fran Drescher</a>, as Hugo’s mother, gives an all-in performance that helps make the ridiculous plot believable. The real charm, though, comes from the very real chemistry between Lewis &amp; Lee who have a palatable sexual charge to their relationship. Somehow, watching the pair share a kiss is far more erotic than graphic scenes of sex. With rumors of a sequel—one which will push LGBTQ inclusion even further—already abounding, we suggest giving the film a look. It’s fun to see a holiday fantasy centered on two men…and imagine what their characters are probably doing <i>off-screen</i>.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle3"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle3"); });</script></div>
<p><em>Airs on Lifetime December 12.</em></p>
<h2>The Brokeback: Dashing in December</h2>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="Dashing in December Official Trailer | Premieres 12/13 on Paramount Network" width="872" height="491" src="https://www.youtube.com/embed/gWeCkrg8VUU?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>If someone made <a href="https://www.queerty.com/lee-daniels-couldnt-stand-watch-brokeback-mountain-15-years-heres-20200620"><i>Brokeback Mountain</i></a> as a Christmas romance, the result would probably look a lot like <i>Dashing in December</i> yet another queer-themed holiday film coming down the chimney this week. Peter Porte plays Wyatt, a New York financier who returns to his Colorado hometown for the holidays. While staying at his mom’s (Andie MacDowell) horse ranch, he develops a wandering eye for Heath (<a href="https://www.queerty.com/juan-pablo-di-pace-doesnt-just-want-play-gay-characters-wants-meryl-streep-20201205">Juan Pablo Di Pace</a>), the newest ranch hand. As the sexual tension mounts, Wyatt must make a choice to sell the ranch and return to New York and his feelings for Heath.</p>
<p>Sound like a familiar plot yet? If so, please see our above entry for <i>The Christmas Setup</i>. <i>Dashing in December</i> features its own mix of snowy mountains, men on horseback, romantic meet-cutes, as well as scenes of rugged men line dancing, rustic Rocky Mountain ranches and emotional disclosures to equine friends. MacDowell gives a sweet performance as Wyatt’s mom, Deb, while Porte and Di Pace go very easy on the eyes. Whether or not that will keep viewers interested will vary.</p><div class="ad-300 inline" id="div-gpt-ad-inarticle4"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle4"); });</script></div>
<p><em>Streams on the Paramount Network December 13.</em></p>
<h2>The Giggle: Dudley Beene’s “I’m a Bea”</h2>
<div class="youtube embed-responsive embed-responsive-16by9"><iframe title="Imma Bea (Golden Girls vs. Black Eyed Peas parody)" width="872" height="491" src="https://www.youtube.com/embed/J5ijd3m27gQ?feature=oembed&amp;enablejsapi=1" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p><a href="https://www.queerty.com/shelley-duvall-cleans-up-the-halloween-mess-with-shining-surface-cleaner-20151028">Comedian Dudley Beene</a>, best known as the <a href="https://www.queerty.com/learn-some-wicked-new-pick-up-lines-in-this-exclusive-scene-from-first-period-20150421">writer/star of the cult comedy <i>First Period</i></a>, drops his latest endeavor this week: a <i>very</i> strange ode to <i>The Golden Girls</i> parodying the Black Eyed Peas’ “Imma Be.” The resultant video packs the song with no shortage of <i>Golden Girls </i>references, and sees Beene impersonating all four of the show’s leading ladies. The amazing thing about the video is how well Beene has copied some of the show’s most iconic costumes; we hope he didn’t raid Betty White’s closet. Fans of <i>The Golden Girls </i>should get a kick out of the video and we hope it helps get Beene bankrolled onto the long-rumored <i>First Period</i> sequel.</p>
<p><em>Streams on YouTube.</em></p><div class="ad-300 inline" id="div-gpt-ad-inarticle5"><script>AdBridg.cmd.push(function() { AdBridg.display("div-gpt-ad-inarticle5"); });</script></div>
<h2>The Sip: Mulled Wine</h2>
<figure id="attachment_571678" aria-describedby="caption-attachment-571678" style="width: 670px" class="wp-caption alignnone"><img loading="lazy" class="size-large wp-image-571678" src="https://queerty-prodweb.s3.amazonaws.com/2020/12/Mulled_wine_1-670x503.jpg" alt="" width="670" height="503" srcset="https://queerty-prodweb.imgix.net/2020/12/Mulled_wine_1-670x503.jpg?&amp;auto=format&amp;auto=compress&amp;w=670 670w, https://queerty-prodweb.imgix.net/2020/12/Mulled_wine_1-670x503.jpg?&amp;auto=format&amp;auto=compress&amp;w=400 400w, https://queerty-prodweb.imgix.net/2020/12/Mulled_wine_1-670x503.jpg?&amp;auto=format&amp;auto=compress&amp;w=1000 1000w" sizes="(max-width: 670px) 100vw, 670px"><figcaption id="caption-attachment-571678" class="wp-caption-text"><em>via Wikimedia commons</em></figcaption></figure>
<p>In honor of not one, but <em>two</em> gay-themed holiday romances, we offer up one of our favorite–and most romantic–holiday cocktails: mulled wine. Easy to make at home, it mixes citrus and spice in a rich and delicious blend perfect for watching a Christmas movie, snuggling up on with someone special on the couch…or imagining snuggling up with someone <em>from</em> a Christmas movie on the couch. Either way, it will warm you.</p>
<ul>
<li><span data-amount="1">1</span> bottle of dry red wine</li>
<li><span data-amount="1">1</span> orange, sliced into rounds</li>
<li><span data-amount="8">8</span> whole cloves</li>
<li><span data-amount="2">2</span> cinnamon sticks</li>
<li><span data-amount="2">2</span> star anise</li>
<li><span data-amount="2">2</span>–<span data-amount="4">4</span> tablespoons sugar, honey, or maple syrup to taste</li>
</ul>
<p><em>Mix ingredients in a saucepan. Stir and bring to low simmer. Let simmer between 30 minutes and 3 hours to taste. Strain into a mug and serve. </em></p>

<div id="div-gpt-ad-textpromo2">
<script type='text/javascript'>
                    		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-textpromo2'); });
                    		</script>
</div>
</div>
<footer class="entry-footer">
<span class="tags-links"><a href="https://www.queerty.com/entertainment" rel="category">Entertainment</a> <a href="https://www.queerty.com/tag/culture-club" rel="tag">culture club</a> <a href="https://www.queerty.com/tag/dashing-in-december" rel="tag">Dashing In December</a> <a href="https://www.queerty.com/tag/funny-boy" rel="tag">funny boy</a> <a href="https://www.queerty.com/tag/imma-bea" rel="tag">imma bea</a> <a href="https://www.queerty.com/tag/queer-japan" rel="tag">queer Japan</a> <a href="https://www.queerty.com/tag/the-christmas-setup" rel="tag">the christmas setup</a> <a href="https://www.queerty.com/tag/the-prom" rel="tag">the prom</a></span><div class="comments-link-area"><a href="https://www.queerty.com/watch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210#respond"><span class="comments-link">Add a comment</span></a></div> </footer>
</article>
</main>
<div class="article-email-prompt-red" id="queerty-article-email-prompt">
<h3><span class="asterisk"> </span>Get Queerty Daily</h3>
Subscribe to Queerty for a daily dose of #entertainment #cultureclub #dashingindecember stories and more
<form action="//queerty.us1.list-manage.com/subscribe/post?u=ecab442566f15d8d4dcf64b0d&amp;id=221c27272a" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank">
<input type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="Your email" autocomplete="email">
<input type="hidden" name="group[5437][16]" value="1">
<input type="hidden" value="2" name="group[5409][2]" id="mce-group[5409]-5409-0">
<input type="hidden" value="1" name="group[5409][1]" id="mce-group[5409]-5409-1">
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ecab442566f15d8d4dcf64b0d_221c27272a" tabindex="-1" value=""></div>
<input type="submit" value="Subscribe" name="submit" id="mc-embedded-subscribe" class="button">
</form>
</div>
<script>
!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>
<script id="63359461e10348e1843f01215f3c4ead">
  cnxps.cmd.push(function () {
    cnxps({
      playerId: "461d6acb-cbff-447a-b4e7-ee9ee29c9631"
    }).render("63359461e10348e1843f01215f3c4ead");
  });
</script>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Add your Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/watch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210#respond" style="display:none;">Cancel reply</a></small></h3><p class="nocomments">Please <a href="https://www.queerty.com/wp/wp-login.php?redirect_to=https%3A%2F%2Fwww.queerty.com%2Fwatch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210">log in</a> to add your comment<br>Need an account? <strong><a href="https://www.queerty.com/wp/wp-login.php?action=register">Register</a></strong> *It's free and easy.</p> </div>
</div>

<div id="div-gpt-ad-textpromo3">
<script type='text/javascript'>
                    		AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-textpromo3'); });
                    		</script>
</div>
</div>
<script type="text/javascript" async="async" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-58640af04b28c97d"></script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.queerty.com\/watch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210"},"headline":"What to Watch: Big queer &#8216;Prom,&#8217; gay boys get &#8216;Christmas Setup,&#8217; &#8216;Brokeback&#8217; style","url":"https:\/\/www.queerty.com\/watch-big-queer-prom-gay-boys-get-christmas-setup-brokeback-style-20201210","datePublished":"2020-12-10T12:13:29-05:00","dateModified":"2020-12-10T12:13:29-05:00","description":"So many handsome sugar plum fairies this week...","thumbnailUrl":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2020\/12\/dashing-in-december-307x289.png","image":{"@type":"ImageObject","url":"https:\/\/queerty-prodweb.s3.amazonaws.com\/2020\/12\/dashing-in-december-307x289.png","height":670,"width":370},"creator":"David Reddish","author":{"@type":"Person","name":"David Reddish"},"articleSection":"Entertainment","keywords":["Ad Friendly","Feature","Queerty","culture club","Dashing In December","funny boy","imma bea","queer Japan","the christmas setup","the prom","[ Has: YouTube embed ]","[ Has: YouTube embed (5+) ]","[ Word count: 1000+ ]"],"publisher":{"@type":"NewsMediaOrganization","name":"Queerty","url":"https:\/\/www.queerty.com\/","logo":{"@type":"ImageObject","url":"https:\/\/www.queerty.com\/assets\/q-2017\/queerty-logo-225x60.png","height":"60","width":"225"},"address":{"@type":"PostalAddress","streetAddress":"584 Castro St. #623","addressLocality":"San Francisco","addressRegion":"CA","postalCode":"94114","addressCountry":"USA"},"sameAs":["https:\/\/en.wikipedia.org\/wiki\/Queerty","https:\/\/www.facebook.com\/queerty","https:\/\/www.twitter.com\/queerty","https:\/\/www.instagram.com\/queerty","https:\/\/www.youtube.com\/user\/queertyTV"]}}</script>
<aside id="secondary" class="article-sidebar" role="complementary">
<div class="sidebar-ad-1" id="div-gpt-ad-box1">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box1'); });
			</script>
</div>
<div id="civsci-id-1487938606" data-civicscience-widget="7e525d9d-2b18-3944-8162-270cab0eef2f"></div>
<script type="text/javascript" async src="https://www.civicscience.com/jspoll/4/civicscience-widget.js"></script>
<section class="sidebar-related">
<h3 class="category-heading">
More in Entertainment </h3>
<div class="cards-list">
<article id="post-571643" class="card card-small ">
<a href="https://www.queerty.com/super-gay-vampire-series-true-blood-get-reboot-treatment-hbo-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/trueblood4_ep12_bill_eric2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Super gay vampire series &#8216;True Blood&#8217; to get the reboot treatment at HBO">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Undead</div>
<h2 class="entry-title">Super gay vampire series &#8216;True Blood&#8217; to get the reboot treatment at HBO</h2> <div class="entry-meta">
<a href="https://www.queerty.com/super-gay-vampire-series-true-blood-get-reboot-treatment-hbo-20201209" rel="bookmark"><time class="entry-date published updated" datetime="2020-12-09T17:30:57-05:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-571652" class="card card-small ">
<a href="https://www.queerty.com/andrew-rannells-test-tell-good-gay-character-bad-one-heres-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/Andrew-Rannells-shutterstock-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Andrew Rannells has a test to tell a good gay character from a bad one. Here&#8217;s how&#8230;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">In Quotes</div>
<h2 class="entry-title">Andrew Rannells has a test to tell a good gay character from a bad one. Here&#8217;s how&#8230;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-571635" class="card card-small ">
<a href="https://www.queerty.com/shawn-mendes-talks-gay-rumors-doesnt-mince-words-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/shaw-mendes.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Shawn Mendes talks gay rumors &#038; doesn&#8217;t mince his words">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Behind the music</div>
<div class="card-commentcount">59 comments</div><h2 class="entry-title">Shawn Mendes talks gay rumors &#038; doesn&#8217;t mince his words</h2> <div class="entry-meta">
<a href="https://www.queerty.com/shawn-mendes-talks-gay-rumors-doesnt-mince-words-20201209" rel="bookmark"><time class="entry-date published updated" datetime="2020-12-09T13:14:08-05:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-571620" class="card card-small dragaholic-link">
<a href="https://www.queerty.com/oop-trailer-rupauls-drag-race-season-13-leaks-online-revealing-big-twist-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/drag-race-rupaul-shocked.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Oop! Trailer for &#8216;RuPaul&#8217;s Drag Race&#8217; season 13 leaks online revealing big twist">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Start your engines</div>
<h2 class="entry-title">Oop! Trailer for &#8216;RuPaul&#8217;s Drag Race&#8217; season 13 leaks online revealing big twist</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div>
</section>
<div class="sidebar-ad-2" id="div-gpt-ad-box2">
<script>
			AdBridg.cmd.push(function() { AdBridg.display('div-gpt-ad-box2'); });
			</script>
</div>
<br>
<section class="sidebar-related" style="background-color:#e33400; margin-bottom:10px; clear:both; background: url('assets/editorial-headers/out-for-good-2020-sidebar-background.jpg') repeat">
<div style="width:100%; height:230px; position:relative; text-align:center;">
<img src="https://www.queerty.com/assets/editorial-headers/out-for-good-2020-logo.png" style="width:80%; margin:15px auto 20px;">
<div id="div-gpt-ad-sponsorship2" style="position:absolute; bottom:8px;left:0; width:100%; height:155px;"><script>AdBridg.cmd.push(function(){ AdBridg.display('div-gpt-ad-sponsorship2'); });</script></div>
</div>
<div class="cards-list">
<article id="post-568733" class="card card-side out-for-good-link">
<a href="https://www.queerty.com/actor-dj-qualls-laid-lifelong-burden-came-gay-20201208">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/10/dj-qualls.png?&auto=format&auto=compress&crop=faces&fit=crop&w=120&h=155" width="120" height="155" class="wp-post-image" alt="Actor DJ Qualls laid down a lifelong burden when he came out as gay">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">qualls without qualms</div> <div class="card-commentcount">1.3K shares</div><h2 class="entry-title">Actor DJ Qualls laid down a lifelong burden when he came out as gay</h2> <div class="entry-meta">
<a href="https://www.queerty.com/actor-dj-qualls-laid-lifelong-burden-came-gay-20201208" rel="bookmark"><time class="entry-date published updated" datetime="2020-12-08T09:00:48-05:00"></time></a> </div>
</section>
</a>
</article>
<article id="post-571491" class="card card-side out-for-good-link">
<a href="https://www.queerty.com/watch-ryan-russell-jackie-cox-holiday-traditions-redefining-festive-season-20201207">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/nissan-out-for-ggo-holiday-trave.png?&auto=format&auto=compress&crop=faces&fit=crop&w=120&h=155" width="120" height="155" class="wp-post-image" alt="WATCH: Ryan Russell, Jackie Cox &#038; more on holiday traditions and redefining the festive season">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Homo for the holidays</div> <h2 class="entry-title">WATCH: Ryan Russell, Jackie Cox &#038; more on holiday traditions and redefining the festive season</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
<article id="post-571253" class="card card-side out-for-good-link">
<a href="https://www.queerty.com/real-housewives-star-braunwyn-windham-burke-im-gay-like-women-20201203">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/braunwyn-burke-girlfriend.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=120&h=155" width="120" height="155" class="wp-post-image" alt="&#8216;Real Housewives&#8217; star Braunwyn Windham-Burke: &#8220;I&#8217;m gay. I like women.&#8221;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Closet Door Bustdown</div> <h2 class="entry-title">&#8216;Real Housewives&#8217; star Braunwyn Windham-Burke: &#8220;I&#8217;m gay. I like women.&#8221;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div>
</section>
</aside>
<br clear=all>
<div class="single-bottom-articles">
<h3>
Latest on Queerty </h3>
<div class="single-bottom-articles-slider slider slick-slider">
<div><article id="post-571461" class="card card-small ">
<a href="https://www.queerty.com/us-marshalls-apprehend-fugitive-gay-basher-texas-20201210">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/frank-macias.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="US Marshalls apprehend fugitive gay basher in Texas">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Caught</div>
<h2 class="entry-title">US Marshalls apprehend fugitive gay basher in Texas</h2> <div class="entry-meta">
<a href="https://www.queerty.com/us-marshalls-apprehend-fugitive-gay-basher-texas-20201210" rel="bookmark"><time class="entry-date published updated" datetime="2020-12-10T11:33:25-05:00">59 minutes ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-571699" class="card card-small ever-after-link">
<a href="https://www.queerty.com/mom-breaks-sons-heart-says-hes-killing-marrying-boyfriend-20201210">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/henry_jimenez_instagram.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Mom breaks son’s heart, says he’s killing her by marrying boyfriend">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Heartbreaking</div>
<div class="card-commentcount">1K shares</div><h2 class="entry-title">Mom breaks son’s heart, says he’s killing her by marrying boyfriend</h2> <div class="entry-meta">
<a href="https://www.queerty.com/mom-breaks-sons-heart-says-hes-killing-marrying-boyfriend-20201210" rel="bookmark"><time class="entry-date published updated" datetime="2020-12-10T08:55:36-05:00">3 hours ago</time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-571643" class="card card-small ">
<a href="https://www.queerty.com/super-gay-vampire-series-true-blood-get-reboot-treatment-hbo-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/trueblood4_ep12_bill_eric2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Super gay vampire series &#8216;True Blood&#8217; to get the reboot treatment at HBO">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Undead</div>
<h2 class="entry-title">Super gay vampire series &#8216;True Blood&#8217; to get the reboot treatment at HBO</h2> <div class="entry-meta">
<a href="https://www.queerty.com/super-gay-vampire-series-true-blood-get-reboot-treatment-hbo-20201209" rel="bookmark"><time class="entry-date published updated" datetime="2020-12-09T17:30:57-05:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-571669" class="card card-small ">
<a href="https://www.queerty.com/jeffree-star-accuser-paid-45k-recant-sexual-assault-claim-new-report-says-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/jeffree-star.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Jeffree Star accuser was paid $45K to recant sexual assault claim, new report says">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Receipts</div>
<div class="card-commentcount">9 comments</div><h2 class="entry-title">Jeffree Star accuser was paid $45K to recant sexual assault claim, new report says</h2> <div class="entry-meta">
<a href="https://www.queerty.com/jeffree-star-accuser-paid-45k-recant-sexual-assault-claim-new-report-says-20201209" rel="bookmark"><time class="entry-date published updated" datetime="2020-12-09T16:44:47-05:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-571652" class="card card-small ">
<a href="https://www.queerty.com/andrew-rannells-test-tell-good-gay-character-bad-one-heres-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/Andrew-Rannells-shutterstock-scaled.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Andrew Rannells has a test to tell a good gay character from a bad one. Here&#8217;s how&#8230;">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">In Quotes</div>
<h2 class="entry-title">Andrew Rannells has a test to tell a good gay character from a bad one. Here&#8217;s how&#8230;</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-571657" class="card card-small ">
<a href="https://www.queerty.com/rugby-star-opens-tricked-filming-gay-sex-video-says-haunted-years-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/shutterstock_289463432.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Rugby star opens up about being tricked into filming gay sex video, says it&#8217;s haunted him for years">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">speaking out</div>
<div class="card-commentcount">26 comments</div><h2 class="entry-title">Rugby star opens up about being tricked into filming gay sex video, says it&#8217;s haunted him for years</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-571632" class="card card-small ">
<a href="https://www.queerty.com/meet-21-year-old-con-artist-scammed-gays-trump-donors-cash-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/Gays-for-Trump-Gofundme.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Meet the 21-year-old con artist who scammed &#8216;Gays For Trump&#8217; donors out of cash">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Fake News</div>
<h2 class="entry-title">Meet the 21-year-old con artist who scammed &#8216;Gays For Trump&#8217; donors out of cash</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-571633" class="card card-small ">
<a href="https://www.queerty.com/rumors-ivanka-will-run-florida-governor-just-ticked-approximately-32-million-notches-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/ivanka-pbs-rnc.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Rumors that Ivanka will run for Florida governor just ticked up approximately 32 million notches">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">madam governor?</div>
<div class="card-commentcount">1.9K shares</div><h2 class="entry-title">Rumors that Ivanka will run for Florida governor just ticked up approximately 32 million notches</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-571635" class="card card-small ">
<a href="https://www.queerty.com/shawn-mendes-talks-gay-rumors-doesnt-mince-words-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/shaw-mendes.png?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Shawn Mendes talks gay rumors &#038; doesn&#8217;t mince his words">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Behind the music</div>
<div class="card-commentcount">59 comments</div><h2 class="entry-title">Shawn Mendes talks gay rumors &#038; doesn&#8217;t mince his words</h2> <div class="entry-meta">
<a href="https://www.queerty.com/shawn-mendes-talks-gay-rumors-doesnt-mince-words-20201209" rel="bookmark"><time class="entry-date published updated" datetime="2020-12-09T13:14:08-05:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-571619" class="card card-small ">
<a href="https://www.queerty.com/pete-buttigieg-rumored-become-next-ambassador-china-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/11/Mayor-Pete-James-Corden2.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Pete Buttigieg rumored to become the next ambassador to China">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">New gig</div>
<div class="card-commentcount">35 comments</div><h2 class="entry-title">Pete Buttigieg rumored to become the next ambassador to China</h2> <div class="entry-meta">
<a href="https://www.queerty.com/pete-buttigieg-rumored-become-next-ambassador-china-20201209" rel="bookmark"><time class="entry-date published updated" datetime="2020-12-09T12:52:51-05:00"></time></a> </div>
</section>
</a>
</article>
</div><div><article id="post-571620" class="card card-small dragaholic-link">
<a href="https://www.queerty.com/oop-trailer-rupauls-drag-race-season-13-leaks-online-revealing-big-twist-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/drag-race-rupaul-shocked.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="Oop! Trailer for &#8216;RuPaul&#8217;s Drag Race&#8217; season 13 leaks online revealing big twist">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">Start your engines</div>
<h2 class="entry-title">Oop! Trailer for &#8216;RuPaul&#8217;s Drag Race&#8217; season 13 leaks online revealing big twist</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div><div><article id="post-571616" class="card card-small ">
<a href="https://www.queerty.com/attending-white-house-christmas-party-trump-lawyer-jenna-ellis-winds-coronavirus-20201209">
<section class="card-thumb">
<img src="https://queerty-prodweb.imgix.net/2020/12/jenna-ellis-cspan.jpg?&auto=format&auto=compress&crop=faces&fit=crop&w=412&h=206" width="280" height="140" class="wp-post-image" alt="After attending White House Christmas party, Trump lawyer Jenna Ellis winds up with coronavirus">
<div class="card-thumb-gradient"> </div>
</section>
<section class="card-content">
<div class="kicker">happy holidays</div>
<h2 class="entry-title">After attending White House Christmas party, Trump lawyer Jenna Ellis winds up with coronavirus</h2> <div class="entry-meta">
</div>
</section>
</a>
</article>
</div>
</div>
</div></div>
</div>
<div class="site-footer-holder">
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="footer-brand">
<span class="asterisk"> </span> Free of an agenda (except that gay one)
</div>
<div class="tags-links">
<a href="//www.queerty.com/tag/adam-rippon">Adam Rippon</a> <a href="//www.queerty.com/tag/freddie-mercury">Freddie Mercury</a> <a href="//www.queerty.com/tag/gus-kenworthy">Gus Kenworthy</a> <a href="//www.queerty.com/tag/nick-jonas">Nick Jonas</a> <a href="//www.queerty.com/tag/nico-tortorella">Nico Tortorella</a> <a href="//www.queerty.com/tag/pietro-boselli">Pietro Boselli</a> <a href="//www.queerty.com/tag/ricky-martin">Ricky Martin</a> <a href="//www.queerty.com/tag/russell-tovey">Russell Tovey</a> <a href="//www.queerty.com/tag/zac-efron">Zac Efron</a> <div class="second-row">
<a href="//www.queerty.com/tag/donald-trump">Donald Trump</a> <a href="//www.queerty.com/tag/homophobia">Homophobia</a> <a href="//www.queerty.com/tag/coming-out">Coming Out</a> <a href="//www.queerty.com/tag/rupaul's-drag-race">Rupaul's Drag Race</a> <a href="//www.queerty.com/tag/scandal">Scandal</a> <a href="//www.queerty.com/tag/religion">Religion</a> <a href="//www.queerty.com/tag/relationships">Relationships</a> <a href="//www.queerty.com/tag/grindr">Grindr</a>
</div>
</div>
<div class="footer-links">
<ul class="main" id="footer-company-links">
<li><a href="http://www.q.digital"><img src="/assets/q-digital-blue-90x37.png" alt="Q.digital" width="90"></a></li>
<li><b>A Q.Digital Company</b></li>
<li>&copy; 2020 Queerty, Inc.</li>
<li><a href="http://www.q.digital">Advertise With Us</a></li>
</ul>
<ul class="main" id="footer-contact-links">
<li><h3>Contact</h3></li>
<li><a href="&#109;&#097;&#105;&#108;&#116;&#111;:&#104;&#111;&#108;&#108;&#097;&#064;&#113;&#117;&#101;&#101;&#114;&#116;&#121;&#046;&#099;&#111;&#109;">Share a Tip</a></li>
<li><a href="https://www.queerty.com/queertys-comment-policy">Comments Policy</a>
<li><a href="https://www.queerty.com/privacy-policy">Privacy Statement</a>
<li><a href="https://www.queerty.com/terms-of-use">Terms of Use</a>
<li><a id="ccpaOptOut">Do Not Sell My Personal Information</a>
</ul>
<ul class="main" id="footer-follow-links">
<li><h3>Follow</h3></li>
<li><a href="https://www.facebook.com/Queerty/">Facebook</a></li>
<li><a href="https://www.twitter.com/Queerty/">Twitter</a></li>
<li><a href="https://www.instagram.com/Queerty/">Instagram</a></li>
<li><a href="https://www.youtube.com/user/QueertyTV/">YouTube</a></li>
</ul>
<ul class="main double" id="footer-gaycities-links">
<li><h3>GayCities: Your Gay Travel Guide:</h3></li>
<li><a href="https://newyork.gaycities.com/">New York</a></li>
<li><a href="https://london.gaycities.com/">London</a></li>
<li><a href="https://sanfrancisco.gaycities.com/">San Francisco</a></li>
<li><a href="https://chicago.gaycities.com/">Chicago</a></li>
<li><a href="https://losangeles.gaycities.com/">Los Angeles</a></li>
<li><a href="https://washingtondc.gaycities.com/">Washington DC</a></li>
<li><a href="https://dallas.gaycities.com/">Dallas</a></li>
<li><a href="https://saskatoon.gaycities.com/">Gay Saskatoon</a></li>
<li><a href="https://www.gaycities.com/places/"><b>See all 230+ cities...</b></a></li>
</ul>
</div>
</footer>
</div>
</div>

<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "32666898" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=32666898&cv=2.0&cj=1" alt="Comscore Measurement" />
</noscript>

<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '686853021424163');
  fbq('track', 'PageView');
</script>
<noscript><img height='1' width='1' style='display:none'
  src='https://www.facebook.com/tr?id=686853021424163&ev=PageView&noscript=1'
/></noscript>

<script>
  fbq('track', 'ViewContent');
</script>
<script>
	window.dataLayer = window.dataLayer || []
	dataLayer.push({
	   'event': 'Page Details',
	   'pageType': 'article',
	   'pageCategory': 'entertainment'
	   
	});
	</script>
<script type="text/javascript" src="//b-code.liadm.com/a-04zq.min.js" async="true" charset="utf-8"></script><script src="//d2wy8f7a9ursnm.cloudfront.net/v7/bugsnag.min.js"></script><script type="text/javascript">var algolia = {"debug":false,"application_id":"6S92GABH7H","search_api_key":"cfd5e12cdf4a6106712391cbcf54f087","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"queerty_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true},{"index_id":"terms_category","index_name":"queerty_terms_category","label":"Categories","admin_name":"Categories","position":20,"max_suggestions":3,"tmpl_suggestion":"autocomplete-term-suggestion","enabled":true},{"index_id":"terms_post_tag","index_name":"queerty_terms_post_tag","label":"Tags","admin_name":"Tags","position":20,"max_suggestions":3,"tmpl_suggestion":"autocomplete-term-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"queerty_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]},"terms_category":{"name":"queerty_terms_category","id":"terms_category","enabled":true,"replicas":[]},"terms_post_tag":{"name":"queerty_terms_post_tag","id":"terms_post_tag","enabled":true,"replicas":[]}}};</script><script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/comment-reply.min.js?ver=5.5.1' id='comment-reply-js'></script>
<script type='text/javascript' async src='https://platform.twitter.com/widgets.js?ver=20161216' id='twitter-js-js'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js?ver=5.5.1' id='slick-js'></script>
<script type='text/javascript' async src='https://www.queerty.com/content/themes/queerty_2017/js/min/queerty-nosticky-min.js?ver=20200120a' id='queerty_2017-main-js'></script>
<script type='text/javascript' async src='https://q-digital.videoplayerhub.com/galleryplayer.js?ver=20201101' id='bt-js'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script type='text/javascript' src='https://www.queerty.com/wp/wp-includes/js/wp-embed.min.js?ver=5.5.1' id='wp-embed-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.5.1' async='async' id='remote_sdk-js'></script>
<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":571666,"object_key":"post","object_type":"post","term_ids":[69394,2215,6255,310,20687,87744,87895,87894,84417,87320,83825]};</script>
<script data-cfasync="false" id="parsely-cfg" data-parsely-site="queerty.com" src="https://cdn.parsely.com/keys/queerty.com/p.js"></script>
</body>
</html>